Cover

Synway IPPBX Series

User Manual

Version 1.6.0

Synway Information Engineering Co., Ltd

www.synway.net


Content

Content i

Copyright Declaration. iv

Revision History. v

Chapter 1 Product Introduction. 1

1.1 Typical Application.. 1

1.2 Feature List 2

Chapter 2 Quick Guide. 5

Chapter 3 WEB Configuration. 6

3.1 System Login.. 6

3.2 Status. 6

3.2.1 System Status. 6

3.2.1.1 System Info. 6

3.2.1.2 Network. 6

3.2.1.2.1 LAN.. 6

3.2.1.2.2 WAN.. 7

3.2.1.3 Performance. 7

3.2.1.4 Storage Usage. 7

3.2.2 PBX Status. 8

3.2.2.1 PBX Monitor 8

3.2.2.1.1 Extension. 8

3.2.2.1.2 Trunk. 8

3.2.2.2 Module Status (Special for UC500H) 8

3.2.2.3 Active Call Queue. 8

3.2.2.4 Active Calls. 9

3.3 CDR.. 9

3.3.1 Call Detail Records. 9

3.3.2 Extension Summary. 9

3.3.3 Conference Recording Session. 10

3.4 PBX.. 10

3.4.1 Extensions. 10

3.4.1.1 Extensions. 10

3.4.1.1.1 Basic. 10

3.4.1.1.2 Features. 11

3.4.1.1.3 Advanced. 12

3.4.1.2 Extension Groups. 14

3.4.2 Trunks. 14

3.4.2.1 Basic. 14

3.4.2.2 CODEC.. 15

3.4.2.3 Advance. 15

3.4.2.4 DOD.. 17

3.4.2.5 Adapt Caller ID.. 17

3.4.3 Call Control 18

3.4.3.1 Inbound Routes. 18

3.4.3.2 Outbound Routes. 19

3.4.3.3 Number Attribution. 21

3.4.3.4 Outbound Restrictions. 22

3.4.3.5 AutoCLIP. 22

3.4.3.6 CC Routes. 23

3.4.3.7 Time Condition. 23

3.4.4 Call Features. 23

3.4.4.1 IVR.. 23

3.4.4.2 Conference Room.. 24

3.4.4.3 Call Center Queues. 25

3.4.4.3.1 Basic. 25

3.4.4.3.2 Caller Experience Settings. 26

3.4.4.3.3 Caller Experience Settings. 27

3.4.4.4 Intercept Groups. 27

3.4.4.5 Ring Groups. 27

3.4.4.6 BlackList 28

3.4.4.7 PIN Numbers. 29

3.4.4.8 Speed Dial 29

3.4.4.9 Paging. 29

3.4.4.10 DISA. 29

3.4.4.11 Call Back. 30

3.4.4.12 Wakeup Services. 30

3.4.4.13 Emergencies. 30

3.4.5 Feature Code. 31

3.4.6 Voice Prompts. 34

3.4.6.1 Voice Prompts. 34

3.4.6.2 System Prompt 34

3.4.6.3 Music On Hold. 34

3.4.6.4 Custom Prompt 34

3.4.7 Voicemail 34

3.4.8 Record Settings. 35

3.4.9 Preference. 36

3.4.10 SIPSettings. 36

3.4.11 Auto Provision. 38

3.4.12 Phone Book. 39

3.5 System.. 39

3.5.1 Network Settings. 39

3.5.1.1 Basic Settings. 39

3.5.1.2 OPENVPN.. 39

3.5.1.3 Static Routes. 40

3.5.2 Security Strategy. 40

3.5.2.1 Security Strategy. 40

3.5.2.2 Service. 40

3.5.3 Date Time Settings. 41

3.5.4 Storage. 41

3.5.4.1 Preference. 41

3.5.4.1.1 Storage Locations. 41

3.5.4.1.2 Storage Devices. 42

3.5.4.2 Auto Cleanup. 42

3.5.4.2.1 CDR Auto Cleanup. 42

3.5.4.2.2 Voicemail and One Touch Recording Auto Cleanup. 42

3.5.4.2.3 Recordings Auto Cleanup. 42

3.5.4.2.4 Logs Auto Cleanup. 43

3.5.4.2.5 Backups. 43

3.5.5 User Permission. 43

3.5.5.1 Users. 43

3.5.5.2 User Group. 44

3.5.6 Event Setting. 44

3.5.6.1 System Settings. 44

3.5.6.2 PBX Settings. 44

3.5.6.3 Notification Contacts. 45

3.5.7 Email Settings. 45

3.5.8 Centralized Manage Setting. 45

3.6 Maintenance. 46

3.6.1 Upgrade. 46

3.6.2 Reboot 46

3.6.3 Backup and Restore. 46

3.6.3.1 Backup. 46

3.6.3.2 Restore. 46

3.6.3.3 Backup Lists. 46

3.6.4 Factory Reset 46

3.6.5 PBX LOG.. 47

3.6.6 Operation Log. 47

3.6.7 Log Viewer 47

3.6.8 Trouble Shooting. 47

3.6.9 Authorization. 48

3.6.9.1 Authorization Info. 48

3.6.9.2 Upload Authorization File. 48

3.6.9.3 Clear Authorization. 48

3.6.10 Event Log. 48

Appendix A Troubleshooting. 49

Appendix B Technical/sales Support 51


Copyright Declaration

All rights reserved; no part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, without prior written permission from Synway Information Engineering Co., Ltd (hereinafter referred to as ‘Synway’).

Synway reserves all rights to modify this document without prior notice. Please contact Synway for the latest version of this document before placing an order.

Synway has made every effort to ensure the accuracy of this document but does not guarantee the absence of errors. Moreover, Synway assumes no responsibility in obtaining permission and authorization of any third party patent, copyright or product involved in relation to the use of this document.


Revision History

Version | Date | Comments
Version 1.4.0 | 2019-02 | Initial publication
Version 1.6.0 | 2019-09 | New revision

Note: Please visit our website http://www.synway.netto obtain the latest version of this document.


Chapter 1 Product Introduction

Thank you for choosing the Synway IPPBX Series products which provide excellent VoIP solutions for Enterprise Unified Communications, Customer Service Center, Hotel Voice Communications, etc.


1.1 Typical Application

Figure 1‑1IPPBX Typical Application

Main functions in typical applications:

Enterprise Unified Communications: Extension, trunk, route, CDR, call recording, IVR, voicemail, teleconference, call forwarding, time condition, monitoring, mobile extension, intercepting, etc.

Customer Service/Call Center: Extension, trunk, route, CDR, call recording, queue, monitoring, call forwarding, time condition, etc.

Hotel Communications: Extension, trunk, switchboard, wakeup service, paging, etc.


1.2 Feature List

Basic Features

Description

Extension

Allow users to make calls from extension to extension after registering SIP extensions to IPPBX.

Trunk

Allow extension users to make incoming and outgoing calls by SIP and FXO trunks with the help of inbound and outbound routes.

Inbound Routes

Enable forwarding calls from SIP or FXO trunks to internal extensions, IVR, conference, call center, DISA, callback systems, etc.

Outbound Routes

Enable making calls from extensions to external PSTN users.

CDR

Allow users to query and download detailed call records by condition on the webpage.

Call Recording

Record extensions, trunks, conferences, call centers; query, play and download the recording.

Call Forwarding

Extensions can be forwarded on different conditions such as ‘Always’, ‘On Busy’, ‘No Answer’, or ‘Not Registered’. Meanwhile, time condition settings are supported.

Call Waiting

This feature allows an FXS extension to receive another call while on the phone. It will make the feature of transfer on busy invalid.

Hotline

If an extension on the FXS port doesn’t dial out within the set time after it is picked up, the preset number will be called automatically.

Do Not Disturb

Reject all incoming calls to this extension.

Mobile Number

Multiple mobile numbers can be set for an extension to avoid missing any call to it.

Monitor

Support monitoring modes All, Listen, Whisper, Barge-in and monitoring authorities Disable, Enable All, Extensions to set for an extension.

Voicemail

Each extension supports an independent voicemail box as well as sending messages to a designated E-mail address.

Fax

Support T.38 fax extension and fax gateway modes.

Extension Security

Guarantee the security of extensions by password, ACL, UserAgent, etc.

Communication without Power

Enable a connection of the station which is linked with the FXS port and the trunk which is linked with the FXO port to keep the calls between the FXS and FXO ports uninterrupted during power outage.

IVR

Customize multi-level IVR.

Call Center Queue

Customize call center queues, providing multiple station ringing strategies to satisfy a variety of applications.

Conference

Support teleconferencing with more than 30 parties.

AutoCLIP

Redirect call to original extension.

CC Routes

When the extension is busy, the call will be recorded. After the callback interval, the call will be dialed back.

Ring Groups

Set a group of extensions into a ring group. When the callers call the ring group, all available extensions will ring simultaneously or sequentially (up to different ringing strategies).

Intercept Groups

Support interception of inside calls in a group and calls of specified extensions.

Call Paging

Meet such requirements as paging system.

Call Parking

Allow users to “park” a phone call with a parking extension number, placing it on hold to be answered on a softphone or any other phone in the office. The caller is put on hold while users switch phones.

Blacklist

Numbers in the blacklist will be blocked to call in, or called, or both. It supports two modes: Exact Match and Regex Match.

DISA

Enable outside users using PBX service just like the system extensions to make calls.

Callback

Hang up the specified callers and let the PBX call them back.

Speed Dial

Customize a short number that allows fast dialing of your frequently used numbers so that you can place a call by pressing a reduced number of keys without having to look up his/her phone number.

Time Condition

This feature is supported for inbound routes, call forwarding, mobile extensions, etc.

PIN Code

This feature is supported for outbound routes, DISA, conference, voicemail, etc.

Signaling & Protocol

Description

SIP Signaling

Supported protocol: SIP V1.0/2.0, RFC3261

Voice

CODEC | G.711A, G.711U, G.729
DTMF Mode | RFC2833, RFC4733, SIP INFO, INBAND

Network

Description

Network Protocol

Supported protocol: TCP/UDP, TLS, SSH, HTTPS, ARP/RARP, DNS, NTP, TFTP, TELNET, STUN.

Static IP

IP address modification support.

DHCP

IP address dynamic allocation support.

DNS

Domain Name Service support.

Security

Description

ACL

This feature is supported for extension registration and WEB access, etc.

Auto Defense

Allow users to customize dynamic firewall strategies to guarantee the security of system and network.

TLS&SRTP

Guarantee the security of signaling and voice communications.

Maintain & Upgrade

Description

WEB Configuration

Support of configurations through the WEB user interface.

Language

Chinese, English.

Software Upgrade

Support of user interface, IPPBX service, kernel and firmware upgrades based on WEB.

Tracking Test

Support of Ping and Tracert tests based on WEB.

SysLog Type

ERROR, WARNING, NOTICE, INFO, DEBUG, CONSOLE


Chapter 2 Quick Guide

This chapter is intended to help you grasp the basic operations of the UC series IPPBX products in the shortest time.

Step 1: Confirm that your packing box contains all the following things.

l UC200/UC500 *1

l UC200: External 12V Power Adapter *1

l Warranty Card *1

l Installation Manual *1

Step 2: Connect the network cable.

Connect the LAN port of UC500 with the network cable of the PC, or connect it to the router or PBX. Configure the IP address of the PC to 192.168.0.200 and then you can go https://192.168.0.101 to visit the webpage of UC500.

Go to the page Network Settings to configure the actual IP address, subnet mask, gateway, etc. Then use the modified IP to visit the webpage of UC500.

Step 3: Add and configure SIP extensions.

Go to the page Extensions to add SIP extensions. Modify extension settings and enable necessary functions according to your requirements. After that, you can perform a dial from extension to extension.

Step 4: Add and configure SIP trunks.

Go to the page Trunks to add SIP trunks and modify trunk settings according to your requirements.

Step 5: Add call features.

Go to the page Call Features to add necessary call features, such as IVR menus, conference rooms, call center queues, ringing groups, etc.

Step 6: Add inbound routes.

Go to the page Inbound Routes to add inbound routes and set route destinations, such as extensions, IVR menus, conference rooms, call center queues, ringing groups, etc.

Step 7: Add outbound routes.

Go to the page Outbound Routes to add outbound routes and set member extensions for each route.

Special Instructions:

l The chassis of the UC series IPPBX product must be grounded for safety reasons, according to standard industry requirements. A simple way is earthing with the third pin on the plug or the grounding studs on the machine. No or improper grounding may cause instability in operation as well as decrease in lightning resistance.

l As the device will gradually heat up while being used, please maintain good ventilation to prevent sudden failure, ensuring that the ventilation holes are never jammed.

l During runtime, if the SYS indicator doesn’t flash regularly and you cannot figure out and solve the problem by yourself, please contact our technicians for help. Otherwise it may lead to a drop in performance or unexpected errors.


Chapter 3 WEB Configuration


3.1 System Login

Make sure the LANs of PC and IPPBX are in the same network segment. Enter the default IP address of IPPBX https://192.168.0.101 to log in the web interface.

The original username and password are both admin. After login, you can add users and set users’ access authority, as well as modify the username and password.

Note: We suggest you use those browsers Chrome 67, Firefox60, IE11 or above versions to ensure the normal access of the management interface.

WANIP: 192.168.1.101;

LANIP: 192.168.0.101.


3.2 Status

It includes two parts: System Status and PBX Status.


3.2.1 System Status


3.2.1.1 System Info

Item | Description
System Time | Current system time of IPPBX
Up Time | Running time of IPPBX since startup
Product | UC200/UC500/UC500H
Serial Number | Unique identifier of the device
Max Sessions | The default value for UC200 is 15, for UC500 is 30, for UC500H is 30. It can be authorized.
Max Extensions | The default value for UC200 is 60, for UC500 is 150, for UC500H is 150. It can be authorized.
uboot | Version information of the current uboot
kernel | Version information of the kernel
version | Version information of the current software


3.2.1.2 Network

1

2

3

3.1

3.2

3.2.1

3.2.1.1

3.2.1.2


3.2.1.2.1 LAN
Item | Description
TYPE | Static IP
MAC | MAC address of LAN
IP Address | IP address of LAN
Gateway | Gateway address which displays only when LAN is the default network interface
Subnet Mask | Information about subnet mask
Preferred DNS Server | Information about preferred DNS server
Alternate DNS Server | Information about alternate DNS server
Network State | When the network cable is well connected and the network goes normal, here displays connection. If the network cable is not connected or the network is unreachable, here displays disconnection.


3.2.1.2.2 WAN
Item | Description
TYPE | Static IP, DHCP or PPPoE
MAC | MAC address of WAN
IP Address | IP address of WAN
Subnet Mask | Information about subnet mask
Preferred DNS Server | Information about preferred DNS server
Alternate DNS Server | Information about alternate DNS server
Network State | When the network cable is well connected and the network goes normal, here displays connection. If the network cable is not connected or the network is unreachable, here displays disconnection.


3.2.1.3 Performance

Item | Description
CPU | Real-time display of current CPU utilization
MEMORY | Real-time display of current memory utilization
LAN | Real-time display of current rate of LAN
WAN | Real-time display of current rate of WAN


3.2.1.4 Storage Usage

Item | Description
Flash | Display of total and used storage of the built-in flash card as well as the utilization
TF | Display of total and used storage of the outer TF card as well as the utilization
USB | Display of total and used storage of the outer USB card as well as the utilization
NetDisk | Display of total and used storage of the network disk space as well as the utilization


3.2.2 PBX Status


3.2.2.1 PBX Monitor

3.2.2

3.2.2.1


3.2.2.1.1 Extension
Item | Description
Status | For a SIP trunk, display of status: unregistered/registered/ringback/ringing/talking; for an FXO trunk, display of status: idle/ringback/ringing/talking.
Extension | Extension number
Name | Name of the extension user
Type | Extension type, FXS or SIP
IP and Port | For a SIP trunk, display of IP address and port number; for an FXS trunk, display of physical port number.


3.2.2.1.2 Trunk
Item | Description
Trunk Name | User-defined name of the trunk
Type | Trunk type, FXO or SIP
Trunk Status | For an FXO trunk, display of status: unusable/idle/in use; for a SIP peer trunk, display of status: unmonitored/unusable/usable; for a SIP Regiter trunk, display of status: fail to register/registered.
Domainname/IP/Port | For a SIP extension, display of domain name/IP address of the registered IP/Soft phone; for an FXO extension, display of physical port number.


3.2.2.2 Module Status (Special for UC500H)

Item | Description
No. | Slot number index, 6 slots in total.
Module IP | Display the IP address of the module in the slot.
Gateway Type | The type of the module in the slot, including digital, analog (FXS or FXO), wireless, etc.
Configuration | Click to enter the subpage of the module configuration and do corresponding operations.


3.2.2.3 Active Call Queue

3.2.3

3.2.3.1

Item | Description
Active Call Center | Statistics for queue connection rate, total number of calls, number of connected calls, number of waiting calls, number of abandoned calls, average waiting time, average talking time.
Agents | Click to view the statistics information about the agents in the queue (Extension, Total Calls, Answered, Missed, Caller Hangup While Agent Ringing, Login Time, Talk Time, Agent Type, Agent Status)
Queue | Click to view the call status information (Status, Caller, Called, Location, Wait Time, Talk Time), and you can hang up, monitor and transfer the current call.


3.2.2.4 Active Calls

3.2.4

3.2.4.1

Item | Description
Eavesdrop | Click to monitor the current call
Kill | Click to end the current call compulsively


3.3 CDR


3.3.1Call Detail Records

See below for all kinds of query conditions of call records.

Basic | Description
Time Range | Query CDR according to the start and end times.
Call From | Usually it is the calling party number.
Call To | Search the CDR information according to the final destination number.
Direction | Three options available: Inbound, Outbound and Local
Call Status | Include such options as Answered, Missed, Voicemail, Cancelled, Failed, etc.
Talk Duration | Query CDR according to the time length of the call.
Advanced | Description
Hangup Cause | Query CDR according to the reason why the call ends.
MOS Score | Query CDR according to Mean Opinion Score (MOS) which is a measure of voice quality.
CID Name | Query CDR according to the name of caller identification (CID).
Original Destination | Query CDR according to the original destination of the caller.
Trunk Name | Query CDR according to the used trunk name.
Outbound CallerId Number | Query CDR according to the calling party number of the outgoing call.
Last Destination | Search the CDR information according to the lastest destination.
DID Number | Search the CDR information according to the DID number.
Wait Time in Queue | Search the CDR information according to the wait time in queue.
Agent Ring Time | Search the CDR information according to the agent ring time.
Agent Talk Time | Search the CDR information according to the agent talk time.


3.3.2Extension Summary

See below for all kinds of query conditions of call records.

Basic | Description
Quick Select | Count extension calls based on an approximate time. The default setting is today.
Custom Choose | Description
Time Range | Count extension calls according to the start and end times.


3.3.3Conference Recording Session

See below for all kinds of query conditions of conference records.

Basic | Description
Start Time/End Time | Query conference calls according to the start and end times.
Room Name | Name of the conference room.
Conference Center Number | Number of the conference center.


3.4 PBX


3.4.1 Extensions


3.4.1.1 Extensions

3.3

3.4

3.4.1

3.4.1.1


3.4.1.1.1 Basic
General | Description
Type | Extension type, SIP or FXS
Extension | Extension number consists of all digits, with the default value range of 1000~5899 which can be modified in ‘PBX->Preference->Extension Preferences’.
Password | It is generated randomly during the creation of a SIP extension and can be modified by users.
Enabled | Set whether to enable the extension or not. By default it is set to true.
Max Registrations | Maximum amount of registrations of this SIP extension, with the default value of 3.
Effective Caller ID Number | The callerID number for this extension to call outbound, i.e. the UserName field.
UserInfo | Description
Name | The callerID number for this extension to call outbound, i.e. the DisplayName field.
User Password | The password for this extension user to log into the system. Username is Name, while the default password is ‘Pass’ plus the extension number.
Voicemail Mail To | The email address to send voicemail to
Mobile Number | Fill in the mobile phone number of this extension user.
Prompt Language | The language of voice prompts. Three options available: System Default, Chinese and English. System Default means to use the same language as set in Voice Prompts.


3.4.1.1.2 Features
Voicemail | Description
Voicemail Enabled | Once this feature is enabled, the call to this extension will enter the voicemail if failed. By default, the setting is True.
Voicemail Password | The password to enter the extension voicemail which is a randomly generated value by default and can be modified by users.
Voicemail Keep Local | Set whether to save the voicemail at IPPBX after it is sent with a specified email. By default, the setting is True.
Voicemail File | Set the way to send the voicemail. Audio File Attachment: Send the voice message via email attachment; Download Link: Send the voice message via link. The latter is the default setting.
Monitor | Description
Allow being monitored | Set if this extension can be monitored or not. *Disable: Not allow to be monitored, as default. *Enable All: Allow all extensions to monitor.*Extensions: Select extensions to monitor.
Monitor Mode | Set the mode in which this extension monitors other ones. The default setting is None None: You will not be allowed to monitor calls; All: All the following 3 modes will be available for use; Listen: You can only listen into the call, but cannot talk (default feature code:*90) Whisper: You can talk to the extension you are monitoring without being heard by the other parties (default feature code: *91) Barge-in: You can talk to both parties (default feature code: *92)
Call Forwarding | Description
Always | Always redirect calls to the designated destination within the period set by the following time condition select box. The default setting is Disabled.
On Busy | Redirect calls to the designated destination if the extension is busy within the period set by the following time condition select box. The default setting is Disabled.
No Answer | Redirect calls to the designated destination if not answered within the period set by the following time condition select box. The default setting is Disabled.
Not Registered | Redirect calls to the designated destination if the extension is not registered within the period set by the following time condition select box. The default setting is Disabled.
Follow Me | Description
Follow Me | Bind a target number (internal extension or external number) to this extension. When there is an incoming call, both original and bind numbers will ring at the same time so that the agent could pick up the call in different locations. The external number will go out through SIP trunks.
Do Not Disturb | Description
Do Not Disturb | When DND is enabled for an extension, it will reject all incoming calls. The default setting is Disabled.


3.4.1.1.3 Advanced
RTP Settings | Description
Enable SRTP | When this feature is enabled, the RTP stream is encrypted, sharing the same certification with TLS. The default setting is False.
SIP Bypass Media | Set whether to send the media stream point to point or in transparent proxy mode. Proxy Media: The media stream will pass IPPBX (default); Bypass Media: The media stream will be transported point to point. Do not enable recording when set to ‘Bypass Media’ to avoid problems.
RTP Codec String | Set RTP Codecs. So far G711A, G711U, G729, G722 are supported.
Register Settings | Description
AuthACL | Once enabled, only the IP address or IP segment that matches the setting will be able to register this extension number. For example, 192.168.1.235/24 means all IP addresses in the segment of 192.168.1 are allowed to register; 192.168.1.235/32 means only the address 192.168.1.235 is allowed to register. By default it is null.
Online Detection | Send the OPTIONS message to this extension to check if it is registered and reachable. The default setting is False.
SIP Force Expires | Calculated by second. The default value 0 means using the registration validity of SIP extensions while other values mean compulsively using the registration validity of IPPBX. Range: 0~3600.
SIP Expires Max Deviation | Reply to new REGISTER messages with time difference. This item should work with SIP Force Expires. For example, if SIP Force Expires is set 1800 seconds and this item is set 600 seconds, the value of Expires in the 200ok message which is returned by IPPBX upon successful registration will be a random value within the range of 1200s-2400s. By default it is 0.
UserAgent Filter | It is null by default, which means not to verify the UserAgent field in the Register message. If it is not set to null, a SIP extension can register successfully only when the UserAgent field in the Register message conform with the character string of this configuration item.
SIP Force Contact | Set whether to rewrite the contact port, or rewrite both the contact IP and port. This function will not take effect until the registration is refreshed. It is null by default.
Call Settings | Description
Call Timeout | Set the maximum ringing duration in seconds for every call of this extension. The default value is 30s.
Max Call Duration | Set the maximum call duration in seconds for every call of this extension, the call will be terminated once it exceeds the time. This item is only valid for calling external numbers. The default value is 6000s.
Wait Dial Tone Time Out | The maximum time to wait for the dial tone, calculated by ms. The default value is 0.
Wait Dial Timeout | Wait Dial Timeout, with the default value of 10000 in milliseconds. The value range is 6000-15000ms.
Digit Timeout | Digit Timeout, with the default value of 2000 in milliseconds. The value range is 1000-10000ms.
Outbound Restriction | When this feature is set to True, this extension cannot call out except for emergency numbers. The default setting is False.
Extension Trunk | When this feature is enabled, the remote SIP trunk devices can use this extension and its password to register to this IPPBX and call in without any configuration. You can find this extension in the outbound trunk list and select it as a trunk to call out. The default setting is False.
Outbound CallerId Name | CallerID name of this extension trunk displayed in an outbound call once the Extension Trunk feature is enabled, having a higher priority than similar settings in Extensions.
Outbound CallerId Number | CallerID number of this extension trunk displayed in an outbound call once the Extension Trunk feature is enabled, having a higher priority than similar settings in Extensions.
Call Permission | Set the call permission of an extension, four options available: No Call: Block any calls from the extension. Internal Call: Only internal calls are allowed Local Call: Allow the calls without 0 as the start number Long-distance Call: Allow the calls with only one 0 at the beginning. International Call (default): Allow the calls with two 0 at the beginning.
Hotline Settings | Description
Hotline Number | After FXS hookoff, if you do not have any operations, it will call the hotline number which is 2 to 30bits in length. By default it is null.
Hotline Timeout | Hotline timeout, with the default value of 3000 in milliseconds. The value range is 0~10000(ms) and this value must be less than Wait Dial Timeout.
FXS Settings | Description
Min Flash Detection | Set the minimum amount of time, in milliseconds, that a hook flash must remain depressed in order for the system to consider it as a valid flash event. The default value is 300ms.
Max Flash Detection | Set the maximum amount of time, in milliseconds, that a hook flash must remain depressed in order for the system to consider it as a valid flash event. The default value is 1000ms.
RX Volume | Set the volume in the direction from the analog phone to the FXS port. The value range is -7~7 and the default value is 0.
TX Volume | Set the volume in the direction from the FXS port to the analog phone. The value range is -7~7 and the default value is 0.
Echo Cancellation Level | The default value is 64ms
Enable Cut DTMF | Set the length of the in-band DTMF voice to cut. Do not set it too large lest normal voice signals be cut. The default value is 25.
Enable DTMF Passthrough | Enable the DTMF passthrough during the conversation. By default it is unticked.
Flash Event | Press the hook flash on the analog phone during a call to direct this call to 3-way calling or call forwarding. The corresponding options are 3 Way (default) and Call Swap.
DTMF Duration | Set the length of the DTMF tone sent by FXS, calculated by ms. The value range is 20-800 and the default value is 100ms.
DTMF Gap | Set the interval for FXS to send DTMF tones, calculated by ms. The value range is 20-800 and the default value is 100ms.
Tone Country | Two options available: USA (default) and China.
Call Waiting | Enable the Call Waiting feature for this extension. By default it is unticked.


3.4.1.2 Extension Groups

Item | Description
Name | The name of the extension group. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Member | Select one or more extensions to become members of the extension group. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.2 Trunks


3.4.2.1 Basic

Item | Description
Trunk Type | Trunk type, SIP or FXO.
Trunk Name | User-defined, consisting of letters and digits.
Record | Set whether to save the recording data. The default setting is False.
Enabled | Enable or disable the trunk. The default setting is True.
Transport | Three options available: UDP, TCP, TLS. TLS goes valid only if it is enabled in SIP Settings. The default setting is udp.
Register | Set whether to register the SIP trunk, which is determined by the trunk provider. The default setting is False.
Profile | Two options available: LAN (default), WAN. Note that the UC500H has an inner network port which must be used by the module.
Trunk IP/Domain | IP address or domain name of the SIP trunk plus port number. The module trunk of the UC500H is just the module IP address.
Username | Username of the registered SIP trunk
Auth Username | Used for SIP authentication. In most cases, it is the same with the username.
Password | The registration password of the SIP trunk.
Expire Seconds | The default value is 800 seconds.
Reg Fail Retry | The default value is 30 seconds.
Keep Inbound CallerID | In case of unregistration, use the transparent extension as the caller by default; in case of registration, use the registered account as the caller by default.
Enable Proxy | Support of proxy mode for trunks like IMS. By default it is unticked.
Outbound CallerId Name | CallerID name of this trunk displayed in an outbound call, having a higher priority than similar settings in Extensions. By default it is null.
Outbound CallerID Number | CallerID number of this trunk displayed in an outbound call, having a higher priority than similar settings in Extensions. By default it is null.


3.4.2.2 CODEC

Item | Description
Codec Preferences | Set the RTP codec for SIP trunk outbound calls. G711A, G711U, G729, G722are supported at present. If none is selected, all Codecs in SDP will be used by default; otherwise, only the selected ones will beassigned.


3.4.2.3 Advance

VoIP Settings

Description

Send CID Type

* NONE (default): Put the CID information only in the From field;

* Remote-Party-ID: Add the Remote Party-ID field with the CID information;

* P-Asserted-Identify: Add the P-Asserted-Identify field with the CID information.

OPTIONS Interval

The interval to send the OPTIONS message to check if this SIP trunk is available, calculated by second. The default setting null means no sending. By default it is null, which means not to send.

Send Privacy ID

When this item is set to True, the header field Privacy:id will be added to the INVITE message. By default it is set to False.

TX Volume

Set the volume for voice from the SIP line to the IP port. The value ranges from -4 to 4 and the default value is 0.

RX Volume

Set the volume for voice from the IP port to the SIP line. The value ranges from -4 to 4 and the default value is 0.

From User

Use the value of this item to override the UserName field in the From header field while sending the INVITE message. By default it is null.

From Domain

Use the value of this item to override the Domain field in the From header field while sending the INVITE message. By default it is null.

SIP Force Contact

When you select ‘rewrite-contact-IP’, the host field representing contact is overwritten by the source IP address.

Enable SRTP

When it is ticked, the RTP stream is encrypted and the certificate is the same as TLS. By default it is unticked.

Other Settings

Description

Limit Max Calls

Set the maximum number of concurrent calls for this SIP. The default value is 0 which means no limit.

Enable Early Session

Add the message header P-Early-Session: supported to the SIP message.

Enable Early Media

Add the message header P-Early-Media: supported to the SIP message.

User Phone

You can add content to the To field of the INVITE message.

Call Timout

Set the maximum response time of the trunk for a call out from it. The default value is 30s.

DNIS

Dial Number Identification Service is used to identify which trunk a call comes in. It allows users to define the display name of an incoming call instead of the called number so that the phone will display the DNIS name when a call comes in on the corresponding trunk. It is unticked by default.

DNIS

Description

DNIS

Dial Number Identification Service is used to identify which trunk a call comes in. It allows users to define the display name of an incoming call instead of the called number so that the phone will display the DNIS name when a call comes in on the corresponding trunk. It is unticked by default.

DNIS Name

The name of the caller ID displayed for the incoming call through this SIP trunk.

DNIS Number

The number of the callee ID of the incoming call through this SIP trunk according to which users determine the value of DNIS Name.

FXO

Description

TX Volume

Set the volume in the direction from the FXO port to the analog phone. The value range is -7~7 and the default value is 0.

RX Volume

Set the volume in the direction from the analog phone to the FXO port. The value range is -7~7 and the default value is 0.

Hangup Detection

Description

Hangup Detection Method

Two methods available: Busy Tone (default) and Polarity.

Busy Count

Specify how many busy tones to wait for before hangup. The default value is 4.

Busy Freq

Set the frequency of busy tones detected. The default value is 450Hz.

Delay Detect Busy Tone

Set the delay time before detecting the next busy tone, calculated by 20ms. The default value is 25.

Busy Tone Detection Cycle

Set the cycle to detect the busy tone, calculated by 20ms. The default value is 200.

Answer Detection

Description

Answer Detection Method

Set whether to use the Polarity method to detect if the remote end picks up the call and answers.

None (default): Once an FXO outbound number is successfully sent, the call will be regarded as answered by the callee and the IPPBX will send 200ok message in the direction to the caller.

Polarity: When an FXO outbound number is successfully sent and the polarity reversal signal is detected as 1 on the line, the call will be regarded as answered by the callee and the IPPBX will send 200ok message in the direction to the caller.

DID Number

Set the DID number for the incoming call through this FXO port. By default it is null.

Caller ID Settings

Description

Caller ID Detection

Set whether to detect the Caller ID of an incoming call. By default it is ticked.

Polarity Delay

Set the minimum time interval for the answer polarity detection and the hangup polarity detection. The default value is 600ms.

Enable Debug Caller ID

Enable the caller number debugging feature for recording and analyzing the caller.

Set Record Time for Caller ID

Set the recording timing, after the first ring or ahead of the first ring.

Other Settings

Description

Enable Cut DTMF

Set the length of the in-band DTMF voice to cut. Do not set it too large lest normal voice signals be cut. The default value is 25ms which means not to cut.

Enable DTMF Passthrough

Enable the DTMF passthrough during the conversation. By default it is unticked.

DTMF Duration

Set the length of the DTMF tone sent by FXO, calculated by ms. The value range is 20-800 and the default value is 100ms.

DTMF Gap

Set the interval for FXO to send DTMF tones, calculated by ms. The value range is 20-800 and the default value is 100ms.

Wait Dialtone Timeout

The maximum time to wait for the dial tone, calculated by ms. The default value is 0.

Delay Dial Timeout

The maximum time to delay for the dial, calculated by ms. The default value is 500. If you wish to customize, enter the value in the text box directly. The valid range is greater than or equal to ‘0’.

Echo Cancellation Level

The default value is 64ms.

Tone Country

Two options available: USA (default) and China.

Fast Release upon Inbound Call Failure

Set whether to enable this feature for a trunk. It is disabled by default. If enabled, inbound calls will be released quickly as they are failed.


3.4.2.4 DOD

Item | Description
DOD | This feature allows users to set the caller ID and number of associated extensions displayed when dialing out which have the higher priority than the caller ID and number configured in basic settings.
DOD Name | The caller ID name of an outbound call.
DOD Number | The caller ID number of an outbound call.
Bind Extension | Determine which extensions are selected to bind the DOD number


3.4.2.5 Adapt Caller ID

Item

Description

Adapt Caller ID

Adapt the incoming caller ID number by cutting or adding the prefix in order to facilitate the use of the callback feature for the SIP extension.

Match Mode

Use regular expression to match.

(1) ^123$: "^" starts matching, "$" ends matching, ^123$ indicates strict matching

(2) 123^(123|456)$: "|" means or, ^(123|456)$ means to match 123 or 456

(3) ^123|456$:It means to match the string beginning with 123 or the string ending with 456

(4) ^123[4-6]$: "[]" means to match any of the characters within, [4-6] is equivalent to [456], ^123[4-6]$ means matching 1234, 1235, 1236

(5) ^123\d$: "\d" means any number from 0 to 9, ^123\d$ is equivalent to ^123[0-9]$

(6) ^123\d+$: "+" means to match one or more characters in front of it, ^123\d+$ means matching at least 4 digit strings beginning with 123, such as: 1234, 12300, ..., 123456789, etc.

(7) ^123\d*$: "*" means to match 0 or more digits in front of it, ^123\d*$ means matching at least 3 digit strings beginning with 123, such as: 123,1234,12300 ,...,123400000, etc.

(8) ^123: It means any string beginning with 123, such as: 123, 12345, 123abc, etc.

(9) 123$: It means any string ending with 123, such as: 123, 666123, abc123, etc.

(10) ^123\d{3}$: "\d{3}" means to match 3 digits, ^123\d{3}$ means matching any 6-digit string beginning with 123

(11) ^(13[4-9]|147|15[0-2,7-9]): It indicates to match the string beginning with 134, 135, 136, 137, 138, 139, 147, 150, 151, 152, 157, 158, 159

(12) .*: "." represents any character, .* means to match any string

Strip

Remove the prefix of an incoming call number.

Prepend

Add the prefix content after removing the prefix.


3.4.3 Call Control


3.4.3.1 Inbound Routes

Item

Description

Name

User-defined name of this inbound route. It must be filled in; otherwise the configuration will fail to be saved.

Enabled

Set whether to enable this route. The default setting is True.

DID Pattern

Use regular expression to match.

(1) ^123$: "^" starts matching, "$" ends matching, ^123$ indicates strict matching

(2) 123^(123|456)$: "|" means or, ^(123|456)$ means to match 123 or 456

(3) ^123|456$:It means to match the string beginning with 123 or the string ending with 456

(4) ^123[4-6]$: "[]" means to match any of the characters within, [4-6] is equivalent to [456], ^123[4-6]$ means matching 1234, 1235, 1236

(5) ^123\d$: "\d" means any number from 0 to 9, ^123\d$ is equivalent to ^123[0-9]$

(6) ^123\d+$: "+" means to match one or more characters in front of it, ^123\d+$ means matching at least 4 digit strings beginning with 123, such as: 1234, 12300, ..., 123456789, etc.

(7) ^123\d*$: "*" means to match 0 or more digits in front of it, ^123\d*$ means matching at least 3 digit strings beginning with 123, such as: 123,1234,12300 ,...,123400000, etc.

(8) ^123: It means any string beginning with 123, such as: 123, 12345, 123abc, etc.

(9) 123$: It means any string ending with 123, such as: 123, 666123, abc123, etc.

(10) ^123\d{3}$: "\d{3}" means to match 3 digits, ^123\d{3}$ means matching any 6-digit string beginning with 123

(11) ^(13[4-9]|147|15[0-2,7-9]): It indicates to match the string beginning with 134, 135, 136, 137, 138, 139, 147, 150, 151, 152, 157, 158, 159

(12) .*: "." represents any character, .* means to match any string

Set the DID number to a group of consecutive extension numbers. Please fill in the DID number range, select "Destination" as "Extension Range" and fill in the corresponding extension range. For example, DID range: 5503301-5503305, extension range: 1001-1005.

Caller ID Pattern

Same as the item DID Pattern. By default it is null.

Destination

Multiple options available, such as Extensions, IVR Menus, Ring Groups, Conference Rooms, Call Center, etc. By default it is null and must be filled in; otherwise the configuration will fail to be saved.

Enable Inband DTMF Detection

Enable the inband DTMF detection, and the default setting is False.

Enable Fax Detection

Set whether to enable the fax detection. The default setting is False.

*False: Neither detect Fax tone nor send Fax.

*True: Proceed to send Fax if Fax tone detected.

Fax Destination

In case the fax detection is enabled and the property of the SDP field in the INVITE message is detected as fax, it is necessary to set a route to the corresponding fax destination. By default it is null.

Send Ring Tone

Local: When an incoming call to the trunk is transferred to the extension and the extension is ringing, the IPPBX will send the 183 messages well as the ringback tone to the calling party.

Remote: When an incoming call to the trunk is transferred to the extension, the IPPBX will transmit the 180/183 message and the ringback tone from the extension transparently to the calling party.

The default setting is Remote.

Enable Time Condition

The feature is disabled by default. Once enabled, it is required to set a destination corresponding to this time condition.

Distinctive Ring Tone

Send the INVITE message with the Alert-Info header field to the called extension to let it select different ring tone files based on the Alert-Info header field. By default it is null.

Priority

Used to adjust the priority of multiple inbound routes. The default value is 100. The smaller the value, the higher the routing priority.

Member Trunks

Select the trunks that can use this route. It must be filled in; otherwise the configuration will fail to be saved.


3.4.3.2 Outbound Routes

Item

Description

Name

User-defined name of this outbound route. It must be filled in; otherwise the configuration will fail to be saved.

Enabled

Set whether to enable this route. The default setting is True.

Dial Patterns

Use regular expression to match.

(1) ^123$: "^" starts matching, "$" ends matching, ^123$ indicates strict matching

(2) 123^(123|456)$: "|" means or, ^(123|456)$ means to match 123 or 456

(3) ^123|456$:It means to match the string beginning with 123 or the string ending with 456

(4) ^123[4-6]$: "[]" means to match any of the characters within, [4-6] is equivalent to [456], ^123[4-6]$ means matching 1234, 1235, 1236

(5) ^123\d$: "\d" means any number from 0 to 9, ^123\d$ is equivalent to ^123[0-9]$

(6) ^123\d+$: "+" means to match one or more characters in front of it, ^123\d+$ means matching at least 4 digit strings beginning with 123, such as: 1234, 12300, ..., 123456789, etc.

(7) ^123\d*$: "*" means to match 0 or more digits in front of it, ^123\d*$ means matching at least 3 digit strings beginning with 123, such as: 123,1234,12300 ,...,123400000, etc.

(8) ^123: It means any string beginning with 123, such as: 123, 12345, 123abc, etc.

(9) 123$: It means any string ending with 123, such as: 123, 666123, abc123, etc.

(10) ^123\d{3}$: "\d{3}" means to match 3 digits, ^123\d{3}$ means matching any 6-digit string beginning with 123

(11) ^(13[4-9]|147|15[0-2,7-9]): It indicates to match the string beginning with 134, 135, 136, 137, 138, 139, 147, 150, 151, 152, 157, 158, 159

(12) .*: "." represents any character, .* means to match any string

Strip

The number of digits to be removed from the prefix. By default it is null.

Prepend

The digits to be added to the prefix. The default setting is null.

Suffix

The digits to be added to the suffix. The default setting is null.

Delay

The delay time before dial, calculated by ms. The default setting is null.

Member Extensions

Add member extensions for controlling the outbound call authority. Only those extensions selected have the authority to use this route. It must be filled in; otherwise the configuration will fail to be saved.

Member Trunks

Select the trunks that can use this route. It must be filled in; otherwise the configuration will fail to be saved.

SIP Code

Set the route to the next trunk or route when receiving a specific SIP cause code.

Next Route

If enabled, when the route is successfully matched and the call is not established normally, the next route will continue to be matched. By default it is ticked.

Password

Set if you need a password for using this outbound route. The default setting is none.

*None: The call goes out directly

*Pin List: The gateway will require Password for outgoing calls, and will check the entered PIN with the selected PIN list in Call Features - Pin Numbers. The call will be preceded while the entered PIN matches any in the PIN list.

*Single Pin: Manually set password .The gateway will require Password for outgoing calls, and the call will be preceded only if the entered PIN is correct.

Rrmemory Hunt

Round robin with memory, remember which trunk was used last time, and then use the next available trunk to call out.

Description

Description of the outbound route. By default it is null.

Priority

Used to adjust the priority of multiple outbound routes. Smaller Number means higher Priority. The default value is 1000. The smaller the value, the higher the routing priority.

Time Condition

Set which time period to use this route. Untick any option by default, which means no time limits on outbound calls.


3.4.3.3 Number Attribution

Item

Description

Number Attribution Matching

If a number matches the matching mode, the attribution determination will be made. NULL means to disable the determination.

(1) ^123$: "^" starts matching, "$" ends matching, ^123$ indicates strict matching

(2) 123^(123|456)$: "|" means or, ^(123|456)$ means to match 123 or 456

(3) ^123|456$:It means to match the string beginning with 123 or the string ending with 456

(4) ^123[4-6]$: "[]" means to match any of the characters within, [4-6] is equivalent to [456], ^123[4-6]$ means matching 1234, 1235, 1236

(5) ^123\d$: "\d" means any number from 0 to 9, ^123\d$ is equivalent to ^123[0-9]$

(6) ^123\d+$: "+" means to match one or more characters in front of it, ^123\d+$ means matching at least 4 digit strings beginning with 123, such as: 1234, 12300, ..., 123456789, etc.

(7) ^123\d*$: "*" means to match 0 or more digits in front of it, ^123\d*$ means matching at least 3 digit strings beginning with 123, such as: 123,1234,12300 ,...,123400000, etc.

(8) ^123: It means any string beginning with 123, such as: 123, 12345, 123abc, etc.

(9) 123$: It means any string ending with 123, such as: 123, 666123, abc123, etc.

(10) ^123\d{3}$: "\d{3}" means to match 3 digits, ^123\d{3}$ means matching any 6-digit string beginning with 123

(11) ^(13[4-9]|147|15[0-2,7-9]): It indicates to match the string beginning with 134, 135, 136, 137, 138, 139, 147, 150, 151, 152, 157, 158, 159

(12) .*: "." represents any character, .* means to match any string

Remove Prefix 0 from Local CalleeID

If this feature is enabled, the prefix 0 will be automatically removed from the local CalleeID.

Add Prefix 0 to Non-local CalleeID

If this feature is enabled, the prefix 0 will be automatically added to the non-local CalleeID.

Enable

It is set to False by default.

Export Attribution Info

Export the attribution information of the PBX.

Import Attribution Info

Import the attribution information to the PBX.


3.4.3.4 Outbound Restrictions

Item | Description
Name | Name of this user-defined outbound restriction. It must be filled in; otherwise the configuration will fail to be saved.
Time Limit | Set a time limit for calls. The default value is 5 minutes.
Number of Calls Limit | Set how many calls are allowed in the limited time. For example, if Time Limit is set to 5 minutes and this item is set to 5, it means the designated extension can only make 5 calls in 5 minutes. When this extension makes the 6th call, it will be locked.
Auto Cancel Restriction | The setting of True means the designated extension can make more calls after the time limit even if it is locked; the setting of False means this extension, once it is locked, cannot make outbound calls any more until it is unlocked manually.
Enabled | Set whether to enable this outbound restriction rule. The default setting is True.
Member Extensions | Select the extensions that use this restriction rule. It must be filled in; otherwise the configuration will fail to be saved.


3.4.3.5 AutoCLIP

Item | Description
AutoCLIP | AutoCLIP can redirect call to original extension. The IPPBX automatically stores information about outgoing calls to the AutoCLIP routing table. When the same person calls back, the call will be routed directly to the original extension that made the former mentioned outgoing call.
View AutoCLIP List | A list of extension outbound calls.
Delete Used Records | If enabled, when an AutoCLIP record is matched, it will be automatically deleted afterwards. By default it is unticked.
Record Keep Time | Set how long each record will be kept in the AutoCLIP list. The default value is 8 hours.
Only Keep Missed Call Records | If enabled, the system will only keep records of outbound calls that are not answered by the called party in the AutoCLIP list. By default it is ticked.
Match Outgoing Trunk | If enabled, only the calls that come in through the same trunk as the last call go out from will match against the AutoCLIP list. By default it is ticked.
Record PSTN Trunk | If enabled, calls that go out through PSTN will be recorded to the AutoCLIP list. By default it is ticked.
Digits Match | Define how many digits from the last digit of the incoming call number will be used to match the AutoCLIP record. If the number has fewer digits than the value defined here, it will be matched in full length. The default value is 7.
Enabled | Set whether to enable the AutoClip routing. The default setting is False.
Member Trunks | Select the trunk on which outgoing calls will be recorded. It is required; otherwise the configuration will fail to be saved.


3.4.3.6 CC Routes

Item | Description
CC Routes | When the extension is busy, the call will be recorded. After the callback interval, the call will be dialed back.
View CC List | View the list of calls which are recorded upon the extension is busy and need to be dialed back.
CC Interval Time | The callback interval for calls in the CC record. The default value is 1 minute.
Record Keep Time | The time to keep a CC record. The default value is 8 hours.
Enabled | Set whether to enable the CC routes. By default it is False.
Member Extensions | Add the extensions which have the authority to control the CC routes.


3.4.3.7 Time Condition

Item | Description
Time Condition | It can be set for such features as outbound routes, inbound routes, call forwarding, and follow me.
Name | User-defined name of a time condition. It must be filled in; otherwise the configuration will fail to be saved.
Type | Three options available: Work Time (default), Holiday, Custom.
Settings | Define worktime and custom conditions necessary to execute the destination selection.
Advance | If ticked, more settings will appear for you. By default it is unticked.
WorkTime | Multiple times allowed to set, including day of week, hour and minute by default. If you need to set year, month, day of month, tick the above item Advance.
Holiday | Multiple times allowed to set, including year, month and day of month by default. If you need to set day of week, tick the above item Advance.
Custom | Multiple times allowed to set, including month, day of month, week of month, day of week, hour, minute, as well as exclude holiday.


3.4.4 Call Features


3.4.4.1 IVR

Basic | Description
Name | User-defined IVR name. It must be filled in; otherwise the configuration will fail to be saved.
IVR Number | The extension number that can be routed to this IVR, with the default value range of 6500~6599 which can be modified in ‘PBX->Preference->Extension Preferences’. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Greet Long | It is played as the first prompt for entering the IVR menu. The default setting is Default.
Greet Short | It is played when the user doesn’t enter any key or enters a wrong key. By default it is null.
Response Timeout | The time waiting for a digit input after prompt. The default value is 10000ms.
Inter-Digit Timeout | The maximum time between your entering of two adjacent DTMF digits. The default value is 3000ms.
Max Timeouts | Maximum number of timeouts before exit. The default value is 3.
Max Failures | Maximum number of retries before exit. The default value is 3.
Digit Length | Maximum number of digits allowed for the caller ID. The default value is 4.
Enabled | Set whether to use the IVR. By default it is True.
Direct Extension | Set whether the user can dial directly to extensions after hearing the IVR prompt.
FXO Flash Transfer | Set whether to allow the current FXO to flash transfer. By default it is False.
Direct Outbound | Set whether the user can dial directly out after hearing the IVR prompt. By default it is unticked.
Advanced | Description
Invalid Sound | The prompt played in case of invalid keypress. The default setting is Default.
Exit Sound | The prompt played upon exiting the IVR menu. The default setting is Default.
Exit Action | The destination selected to enter after exiting the IVR menu. By default it is null.
Caller ID Name Prefix | The prefix of the caller ID name sent upon the call passing from IVR to an internal extension. By default it is null.
Ring Back | The ring back tone the caller will hear upon the call passing from IVR to an internal extension. The default setting is Default.
Key Press Event | Description
Keypress Event | Set the destinations respectively according to 0~9, *, # and invalid keys.


3.4.4.2 Conference Room

Item | Description
Room Name | User-defined name of a conference room. It must be filled in; otherwise the configuration will fail to be saved.
Conference Center Number | The number dialed to reach this conference room, with the default value range of 6400~6499 which can be modified in ‘PBX->Preference->Extension Preferences’. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Greeting | The greeting played upon joining this conference room. The default setting is Default.
Schedule | Set the start and end time for this conference room.
No Pin | Set whether a password is needed for entering this conference room. The default setting is True.
Record | Set whether to enable the recording. By default it is False.
Max Members | The maximum number of members allowed in this conference room.
Wait for Moderator | If set to True, the participants could not hear each other until the moderator joins the conference. The default setting is True.
Say your name | If set to True, you will hear a prompt ‘Please say your name’ upon you enter a conference room, and other members will hear a prompt ‘xxx enters the conference’ upon you successfully join in the conference. The default setting is True.
Announce | If set to True, other members will hear prompts upon a member enters or exits this conference room; if set to False, there will be no prompt for a member’s entering or exiting. The default setting is False.
Mute Participant | If set to True, the participants expect for the moderator are not allowed to speak in this conference room. The default setting is False.
Allow Participant to Invite | If set to True, all participants could press *0 to invite other users to enter this conference room, press *1 to launch an invitation with confirmation request and press *2 to kick the member they invited out of this room. The administrator could press *3 to kick out all participants in the conference. The default setting is True.
Enabled | Sets whether to use the conference room. The default setting is True.
Moderator Member | Specify the moderator extension for this conference. It must be filled in; otherwise the configuration will fail to be saved.


3.4.4.3 Call Center Queues

3.4.2

3.4.3

3.4.4

3.4.4.1

3.4.4.2

3.4.4.3


3.4.4.3.1 Basic
Item | Description
Queue Name | User-defined name of a call center queue. It must be filled in; otherwise the configuration will fail to be saved.
Queue Number | The number dialed to reach this call center queue, with the default value range of 6700~6799 which can be modified in ‘PBX->Preference->Extension Preferences’. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
No Pin | Set whether a password is needed for dynamic agents to enter this queue. The default setting is False.
Agent Password | Set the password for dynamic agents to enter this call center queue. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Ring Strategy | Ring All: All available agents ring. Longest Idle Agent (default): The agent keeping idle for the longest time rings first. Round Robin: All available agents ring in rotation. Random: All available agents ring randomly. Agent with Least Talk Time: The agent whose total call time is shortest rings first. Agent with Fewest Calls: The agent with fewest calls rings first. Top Down: The agents ring from top to down in the order already configured. Sequentially by Agent Order: The agents ring in the order of their numbers.
Agent Call Timeout | The maximum time for each agent to ring. The default value is 15 seconds.
Max No Answer | The allowed number of consecutive unanswered calls. 0 means no limit and the default value is 3.
Max Wait Time | The maximum time a caller can wait in a queue before being pulled out, calculated by second. 0 means no time limit.
Timeout Action | Select the destination to enter when the call in the queue doesn’t be answered in the maximum waiting time. By default it is null.
Record | Set whether to enable call recording for the queue. By default it is False.
Agent Answer Announce | Announcement played upon the agent answers the call. The default setting is null.
Agent Retry Time | The interval time between the failed and new calls of an agent. The default value is 30 seconds.
Wrap Up Time | The interval time between the answer of an incoming call and the allocation of a new one.
Max Queue Length | Set how many callers are allowed in the queue.
Caller ID Name Prefix | The prefix of a caller ID name sent when the queue allocates a call to the agent. By default it is null.
Overflow Action | Transfer to the destination when the number of calling parties in the queue exceeds the upper limit.
Alert Info | Set the content of the Alert-Info field. By default it is null.
Agents | Set one or several extensions to be the fixed station of the current queue.


3.4.4.3.2 Caller Experience Settings
Item | Description
Music on Hold | Select the music on hold to play when the caller enters this queue. The default setting is Default.
Join When No Agent | If enabled, callers can join a queue that has no agents. By default it is unticked.
Max Wait Time with No Agent | The maximum waiting time for a caller in the queue that has no agents. The default value is 90s.
Join Announce | Announcement played to callers upon joining the queue. The default setting is Default.
Queue Busy Resume Offer | Set whether to assign incoming calls to other stations if the current station is already in call. The default setting is True.
Transfer Prompt | When the calling party enters the queue, the system prompt tone will be heard periodically. If the agent rings, the prompt tone will be played. For example: "Call forwarding, please wait for a moment". The default setting is Default.
Caller Position Announcements | Description
Announce Position | Announce the current position of the caller in the queue. By default it is ticked.
Announce Hold Time | Announce how long the caller shall wait in the queue. By default it is ticked.
Call Duration | The average call length estimated by users based on actual situations, used to calculate the waiting time for the caller. The default value is 60s.
Announce Frequency | Set how often to announce the queue position and the hold time. The default value is 30s.
Periodic Announcements | Description
Announce Sound | The system prompt that will be played periodically to callers in the queue, such as ‘All agents are busy. Please wait a minute. To leave a message, press 1; to end the call, just hang up’. The default setting is Default.
Announce Frequency | How often the system prompt is played. The default value is 0s.
Busy Callback | Description
Enable Busy Callback | When this feature is enabled, the caller can choose to hang up the call while hearing a corresponding voice prompt and this call still waits in line. Then once it is the caller’s turn to transfer the call to an agent, IPPBX will start a call to this agent and wait for answers before dialing back to the caller to establish a connection. The default setting is False.
Agent Busy Announce | Select a voice file as the prompt for agent busy. The default setting is Default.
Agent Busy Callback Key | Press this key to enter the flow of dialing back upon agent busy. The default value is 2.


3.4.4.3.3 Caller Experience Settings
Key Events | Description
Option | The keys that might be pressed after the caller hears the system prompt.
Destination | The destination the call will be transferred to after the caller’s keypress.


3.4.4.4 Intercept Groups

Item | Description
Name | User-defined name of an intercept group. Users can set intercept groups by service requirements, facilitating the members in a group to answer calls for each other. It must be filled in; otherwise the configuration will fail to be saved.
Member | Select members for this group. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.5 Ring Groups

Item | Description
Name | User-defined name of a ring group. It must be filled in; otherwise the configuration will fail to be saved.
Ring Group Number | The number dialed to reach this ring group, with the default value range of 6200~6299 which can be modified in ‘PBX->Preference->Extension Preferences’. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Ring Strategy | Three options available: Simultaneous, Sequence, Random. *Simultaneous (default): All extensions ring at the same time. *Sequence: Ring one by one. Timeout by Second. *Random: Random select extensions, none-repetitive.
Timeout Destination | Select the destination to enter when agents in this ring group are all not answered. By default it is null.
Ring Timeout(s) | The timeout time to ring next extension, and also the timeout time to enter Timeout Destination if all extensions are unavailable. The default value is 30s.
Enabled | Set the status of the ring group. The default setting is True.
Alert Info | Set the content of the Alert-Info field. By default it is null.
Ring Back Scheme | The ringback tone sent to the caller. The default setting is us-ring.
CID Name Prefix | The prefix of a caller ID name sent to the extension. By default it is null.
Extension Answer Confirm | If set to Yes, the extension user will hear the following prompts upon picking up the call: Press 1 to answer; press 2 to reject. The default setting is No.
Member | Select members for this group. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.6 BlackList

Item

Description

Name

User-defined name of a blacklist. It must be filled in; otherwise the configuration will fail to be saved.

Match Mode

Set the mode to match the caller number coming in through the trunk with the blacklist, two options available: Exact Match(default) and Regex Match.

BlackList Number

An exact number in the blacklist.

Regular Expression

Fill in following the rule of Regular Expression .

(1) ^123$: "^" starts matching, "$" ends matching, ^123$ indicates strict matching

(2) 123^(123|456)$: "|" means or, ^(123|456)$ means to match 123 or 456

(3) ^123|456$:It means to match the string beginning with 123 or the string ending with 456

(4) ^123[4-6]$: "[]" means to match any of the characters within, [4-6] is equivalent to [456], ^123[4-6]$ means matching 1234, 1235, 1236

(5) ^123\d$: "\d" means any number from 0 to 9, ^123\d$ is equivalent to ^123[0-9]$

(6) ^123\d+$: "+" means to match one or more characters in front of it, ^123\d+$ means matching at least 4 digit strings beginning with 123, such as: 1234, 12300, ..., 123456789, etc.

(7) ^123\d*$: "*" means to match 0 or more digits in front of it, ^123\d*$ means matching at least 3 digit strings beginning with 123, such as: 123,1234,12300 ,...,123400000, etc.

(8) ^123: It means any string beginning with 123, such as: 123, 12345, 123abc, etc.

(9) 123$: It means any string ending with 123, such as: 123, 666123, abc123, etc.

(10) ^123\d{3}$: "\d{3}" means to match 3 digits, ^123\d{3}$ means matching any 6-digit string beginning with 123

(11) ^(13[4-9]|147|15[0-2,7-9]): It indicates to match the string beginning with 134, 135, 136, 137, 138, 139, 147, 150, 151, 152, 157, 158, 159

(12) .*: "." represents any character, .* means to match any string

Enabled

Set whether to enable the black list feature. By default it is True.


3.4.4.7 PIN Numbers

Item | Description
Name | User-defined name of a PIN number. It must be filled in; otherwise the configuration will fail to be saved.
PIN List | Multiple PIN numbers are allowed and should be separated by ‘,’. This feature is used for such applications as conference, outbound routes which require entering the PIN number to verify authorities. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Enabled | Set whether to enable or disable the PIN list. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.8 Speed Dial

Item | Description
Name | User-defined name of a speed dial, which must be unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Speed Dial Number | Number of a speed dial, unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Destination | Destination number that the speed dial number corresponds to. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.9 Paging

Item | Description
Name | User-defined name of a call paging, which shall be unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Number | Number of a call paging. The default value range is 6300~6399.It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Type | Two options available: Unilateralism(default) and Bidirectional.
CallerID Name Prefix | The prefix of a caller ID name of the call started by the call paging. It is null by default.
Member | Select members for this group. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.10 DISA

Item | Description
Name | User-defined name of a DISA, which must be unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Response Timeout | The maximum time waiting for the caller to press digits after prompt.
Digit Timeout | The maximum time permitted between two digits in dialing an extension number.
Second Dial | Set whether to enable the two-stage dial. The default setting is True.
PIN Type | Three options available: None, Single Pin and Pin List. If set to Single Pin or Pin List, the caller in DISA will hear the prompt for entering a password before inputting the callee number to dial.
Outbound Routes | Select an outbound route for DISA call out. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.11 Call Back

Item | Description
Name | User-defined name of a callback, which must be unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Delay | The delay time to call back after rejecting an incoming call.
Strip | Set how many digits will be stripped from the call number before the callback is placed. It is null by default.
Prepend | Set the digits to prefix the callback number before the callback is placed. It is null by default.
Destination | The destination which the callback will direct the call to. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Through | *Auto (default) *From Come in *Select SIP Trunk


3.4.4.12 Wakeup Services

Item | Description
Name | User-defined name of the wakeup service, unique. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Prompt | The alarm prompt. The default setting is Default.
Custom Date | User-defined alarm date, including day of week, etc. By default it is unticked.
Date | Set the year, month and day information. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Time | Set the time which is by default 00:00.
Snooze Time | Set the time interval for retry. The value range is ≥60 and the default value is 600, calculated by second.
Enabled | Set whether to enable the wakeup service. The default setting is True.
Wakeup Member | The extension members that need the wakeup service. It is null by default and must be filled in; otherwise the configuration will fail to be saved.


3.4.4.13 Emergencies

Item | Description
Emergency Number | The emergency number users fill in by actual requirements, such as 110, 911. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Trunk | Choose trunks for dialing the emergency number. All extensions can make emergency calls through these trunks regardless of the Time Condition setting. When all the trunks are busy, the system will terminate an ongoing call to make sure the emergency call can be put through. The default setting is None.
Announce | When an emergency number is dialed, the system will make a notification call to the selected extension with a prompt. Multiple extensions are allowed. The default setting is None.


3.4.5 Feature Code

Digits Timeout

Description

Feature Code Digits Timeout

The maximum time waiting for the next feature code digit. The default value is 5000ms.

Recording

Description

One Touch Record

The feature code that is used to start call recording. The default code is *2.

Voicemail

Description

Check Voicemail

The feature code that is used to check the voicemail. Press it and enter your password following the prompt. The default code is *97.

Voicemail Main Menu

The feature code that is used to access the global menu for voicemail. The default code is *98.

Voicemail for Extension

The feature code that is used to leave a voicemail to specified extensions or forward an incoming call to an extension’s voicemail directly. The default code is *99.

Transfer

Description

Blind Transfer

Extension A presses this feature code in a call and dials Extension B after hearing the dial tone to transfer the call successfully. The default code is *1.

Attended Transfer

Extension A presses this feature code in a call, dials Extension B after hearing the dial tone, and hangs up the call after communication to transfer the call successfully. Press # to cancel. The default code is *4.

Attended Transfer Timeout

In negotiating a transfer, if the destination is not specified, the call will be transferred back after the set time. The default value is 15 seconds.

Intercept

Description

Group Intercept

By pressing this feature code, an extension can answer the incoming call to another extension in the same intercept group. The default code is *8.

Extension Intercept

By dialing this feature code plus an extension number, users can answer incoming calls to this extension. The default code is **.

Intercom

Description

Intercom

By dialing this feature code plus an extension number, users can start an intercom call to this extension. The default code is *88.

Call Parking

Description

Call Parking

Dial this feature code during a call to put the call on hold and park it at an extension number directed by the system. Any other phone can dial this extension number to resume the conversation. The default feature code is *5.

Park Extension

By dialing this feature code, Extension A will be parked at another extension number. Other extensions can dial this extension number to resume the conversation with Extension A. The default feature code is 5900.

Park Extension Start/Park Extension End

The range of extensions where the call can be parked at. The default setting is 5901~5999.

Park Timeout

The maximum time for an extension allowed to park. The default value is 90 seconds.

Call Forwarding

Description

Enable Forward All Calls

By dialing this feature code, an extension forwards all calls to its voicemail; by dialing this feature code plus a designated number, an extension forwards all calls to this designated number. The default feature code is *72.

Disable Forward All Calls

Dial this feature code to disable forwarding of all calls. The default feature code is *720.

Toggle Forward All Calls

Dial this feature code to toggle forwarding of all calls. The default feature code is *73.

Enable Forward When Busy

By dialing this feature code, an extension forwards all calls to its voicemail when busy; by dialing this feature code plus a designated number, an extension forwards all calls to this designated number when busy. The default feature code is *74.

Disable Forward When Busy

Dial this feature code to disable call forwarding when busy. The default feature code is *740.

Enable Forward No Answer

By dialing this feature code, an extension forwards all calls to its voicemail when no answer; by dialing this feature code plus a designated number, an extension forwards all calls to this designated number when no answer. The default feature code is *75.

Disable Forward No Answer

Dial this feature code to disable call forwarding when no answer. The default feature code is *750.

DND

Description

Enable Do Not Disturb

Dial this feature code to put the extension into the DND state. The default feature code is *78.

Disable Do Not Disturb

Dial this feature code to take the extension out of the DND state. The default feature code is *780.

Toggle Do Not Disturb

Dial this feature code to toggle the DND state. The default feature code is *77.

Call Monitor

Description

Listen

Dial this feature code plus an extension number to monitor the extension. If this feature will work or not is related to the setting of monitor authority. The default value is *90.

Whisper

Dial this feature code plus an extension number to monitor the extension and whisper to it. If this feature will work or not is related to the setting of monitor authority. The default value is *91.

Barge-in

Dial this feature code plus an extension number to enter the call of this extension for monitoring. If this feature will work or not is related to the setting of monitor authority. The default value is *92.

Forcible Hangup

By dialing this feature code in a call, users can disconnect this call forcibly. The default feature code is *6.

Listen Local

Dial this feature code plus an extension number to monitor the conversation from the designated extension and the monitor cannot hear the voice from the other end. The default feature code is *93.

Note: To monitor an extension, you need to configure the Monitor Settings for this extension first.

Listen Remote

Dial this feature code plus an extension number to monitor the conversation from the remote end of the designated extension and the monitor cannot hear the voice from the local designated extension. The default feature code is *94.

Note: To monitor an extension, you need to configure the Monitor Settings for this extension first.

Agent

Description

Agent Login/Logout

By dialing this feature code plus a queue number, the extension can follow the prompt to log in and out the queue dynamically. The default feature code is *22.

Agent Status ID

By dialing this feature code plus a queue number, the extension can follow the prompt to add an extension to the designated queue or delete it from the queue. The default feature code is *23.

BlackList

Description

Blacklist Add

By dialing this feature code, the extension can follow the prompt to add a caller Id to the blacklist dynamically. The default feature code is *40.

Blacklist Remove

By dialing this feature code, the extension can follow the prompt to remove a caller Id from the blacklist dynamically. The default feature code is *41.

Blacklist Add Last Call

By dialing this feature code, the extension will add the latest call number to the blacklist. The default feature code is *42.

Query IP

Description

Query LAN IP

By dialing this feature code, the FXS extension can query such information as the IP address of LAN. The default feature code is *60.

Query WAN IP

By dialing this feature code, the FXS extension can query such information as the IP address of WAN. The default feature code is *61.

CC Routes

Description

CC Routes

When the extension is busy, dial this function key to implement the callback feature. The default feature code is *7.

Conference

Description

Multiparty Conference

The feature of multi-party conference, and the default feature code is *0.


3.4.6 Voice Prompts


3.4.6.1 Voice Prompts

Item | Description
Music On Hold | The music catalog to play when a call is being held. The default setting is default catalog.
Play Call Forwarding Prompt | If enabled, the system will play a prompt before transferring a call. By default it is unticked.
Music On Hold | Set what to play when a call is being held during call forwarding. The default setting is Music On Hold.


3.4.6.2 System Prompt

Item | Description
Upload System Prompts | The supported compression format is zip. Please make sure of the integrity of voice packages to guarantee the normal use.
Prompts List | Display all the voice packages in IPPBX and allow you to select one as the system prompt.
Language | Three options are available: English (default) , Chinese and Turkish.


3.4.6.3 Music on Hold

Item | Description
Catalogue | Select a catalogue of music on hold or press the following button + to create a new catalog.
File Path | Select a new music file and upload it to the list.
File List | Music files in the list can be played or removed.


3.4.6.4 Custom Prompt

Item | Description
Upload | The file to be uploaded should be: 8000Hz sampling rate, 16bit, single channel, wav format.
Record | Define the name of a wav file, select an extension to record, then click the RECORD button. When the extension rings, pick up the call and say what you want to record.


3.4.7 Voicemail

Message Options | Description
Max Messages per Folder | The maximum number of messages to store in a single folder of voicemail. The default value is 100.
Max Message Time | The maximum length of a single piece of message. The default value is 300 seconds.
Min Message Time | The minimum length of a single piece of message. The default value is 3 seconds.
Press 5 to leave a message | If this option is ticked, you will hear the prompt: The phone you dial is unavailable now. Please press 5 to leave your message; if it is unticked, you will hear the prompt: The phone you dial is unavailable now. By default it is ticked.
Operator Breakout from Voicemail | If this option is ticked, you will hear an extra prompt: Press 0 for operator. By default it is unticked.
Greeting Options | Description
Busy Prompt | Select the greeting that will be played when the extension is busy. The default setting is Default.
Unavailable Prompt | Select the greeting that will be played when the extension is unavailable. The default setting is Default.
Playback Options | Description
Announce Message Caller ID | If this option is ticked, the extension number of the caller who left the message will be announced before the content of this message. By default it is unticked.
Announce Message Duration | If this option is ticked, the duration of the message will be announced before the content of this message. By default it is unticked.
Announce Message Arrival Time | If this option is ticked, the arrival time of the message will be announced before the content of this message. By default it is unticked.
View Voicemail | Click to view the voicemail configuration of all extensions. Then click ‘Messages’ following each extension to view the exact voicemail messages.


3.4.8 Record Settings

Item | Description
Internal Call Being Recorded Prompt | The prompt that will be played to both the caller and the callee before the recording of internal calls. The default setting is None.
Outbound/Inbound Calls Being Recorded Prompt | The prompt that will be played to both the caller and the callee before the recording of outbound/inbound calls. The default setting is None.
Record Start | Set the timing to start recording, two options available: After Answer and After Ring. The default setting is After Answer.
Record Mode | Set the recording mode, two options available: Recording on One Side and Recording on Both Sides. The default setting is Recording on One Side.
Record Direction | Set the recording direction, three options available: Incoming Recording, Outgoing Recording, Incoming and Outgoing Recording. The default setting is Incoming Recording.
Record Sample Rate | Set the sampling frequency of the recording, 8000 or 16000.The default value is 8000.
Recording File Format | Set the recording file format, WAV or MP3. The default format is WAV.
Record Trunks | Select trunks on which the calls will be recorded. By default it is null.
Record Extensions | Select extensions on which the calls will be recorded. By default it is null.
Record Conferences | Select conference rooms in which the calls will be recorded. By default it is null.


3.4.9 Preference

Item

Description

Max Duration

The maximum time length permitted for a call. The default value is 6000 seconds. 0 means no limit.

Attended Transfer Caller ID

The Caller ID that will be displayed on the recipient’s phone. There options available: Auto, Transferor(default), Transferee.

Example: 1002calling 1003, 1003transfers this call to 1004.

* Transferor: Show 1003 on the extension 1004.

* Transferee: Show 1002 on the extension 1004.

* Auto: When 1003istransferring the call to 1004, the displayed number is 1003; when 1003 hangs up the call after its successful transfer and1002 is talking to 1004, the displayed number is 1002.

Extension Preferences

Description

User Extensions

The number range of user extensions. By default it is 1000~5899.

Ring Group Extensions

The number range of user extensions in a ring group. By default it is 6200~6299.

Paging Group Extensions

The number range of user extensions in a paging group. By default it is 6300~6399.

Conference Extensions

The number range of user extensions in a conference room. By default it is 6400~6499.

IVR Extensions

The number range of IVR extensions. By default it is 6500~6599.

Queue Extensions

The number range of user extensions in a call center queue. By default it is 6700~6799.


3.4.10 SIP Settings

Item | Description
Enable Session Timer | Enable the timer for a SIP session which should be refreshed in a designated time. It is ticked by default.
Session Timeout | Set the maximum refresh interval for the session timer. The default value is 1800 seconds.
UserAgent | The content of the User-Agent field which is defined by users. The default setting is UC2018.
RTP Range | Set the range of the RTP port used by the PBX. The default setting is 16384-32768.
RTP AutoFix Timing | RTP AutoFix Timing. The default setting is True.
Nat Options Ping | When it is set to True by default, the PBX will send the options message to all the terminals which register after NAT to keep the active connection to the terminal.
DSCP Enabled | In order to guarantee the communications Qos, the eight identification bytes in the IP header of the data packet are encoded to classify the service classes and differentiate the service priorities.
Trunk Profile Setting | Description
Enable External_LAN | By ticking this option, you can create SIP trunks on the LAN port. It is ticked by default.
Enable External_WAN | By ticking this option, you can create SIP trunks on the WAN port. It appears only when the network mode is set to Double or Route. It is ticked by default.
SIP IP | The IP address to be monitored by using the SIP protocol. By default it is the IP address of this network port.
SIP Port | The port to be monitored by using the SIP protocol. By default it is 5080.
Public SIP IP | The SIP IP used for NAT traversal when the PBX stays in the LAN.
Public RTP IP | The RTP IP used for NAT traversal when the PBX stays in the LAN.
100rel Enable | Add Supported:100rel to the INVITE message.
Enable TLS | If this option is ticked, the SIP trunk will support UDP, TCP, TLS at the same time. It is unticked by default.
TLS Only | If this option is ticked, the calls on this SIP trunk will only support TLS.
TLS SIP Port | The default value is 5081.
TLS Version | The TLS version used by the SIP trunk. The default value is tlsv1.
TLS Certificate | The certificate needed in case the PBX works as the client. It will be renamed to agent.pem after it is uploaded.
Extension Profile Setting | Description
Enable Internal_LAN | By ticking this option, you can create SIP extensions on the LAN port. It is ticked by default.
Enable Internal_WAN | By ticking this option, you can create SIP extensions on the WAN port. It appears only when the network mode is set to Double or Route. It is ticked by default.
SIP IP | The IP address to be monitored by using the SIP protocol. By default it is the IP address of this network port.
SIP Port | The port to be monitored by using the SIP protocol. By default it is 5060.
Public SIP IP | The SIP IP used for NAT traversal when the PBX stays in the LAN.
Public RTP IP | The RTP IP used for NAT traversal when the PBX stays in the LAN.
Enable TLS | If this option is ticked, the SIP extension will support UDP, TCP, TLS at the same time. It is unticked by default.
TLS Only | TLS If this option is ticked, the calls on this SIP extension will only support TLS.
TLS SIP Port | The default value is 5061
TLS Version | The TLS version used by the SIP extension. The default value is tlsv1.
Create CA Certificate | When the PBX works as the Server, the CA certificate is used to generate Client and Server certificates, with the filename cafile.pem.
Create Server Certificate | It is a certificate needed when the PBX works as the Server, with the filename agent.pem.
Create Client Certificate | It is a certificate provided by the PBX for other clients to use, generated by using the same CA certificate of the Server certificate, with the filename client.pem.


3.4.11 Auto Provision

Item

Description

Auto Provision

This feature is to generate a configuration file of the IP phone. The phone obtains the configuration file address by sending a paging packet, and downloads the configuration file automatically.

Manufacturer

Select the IP phone manufacturer that generates the phone book.

Name

When the type is Local Phone Book, it cannot be modified; when the type is Remote Phone Book, the phone book can be obtained by this name.

Type

Local Phone Book: IP phone is saved locally on the phone; Remote Phone Book: IP phone can be accessed by URL.

Please Select a File

Upload the phone book to be imported. Different manufacturers need to download different templates.

Template

Select a pre-configured template to automatically fill in such information as features, preferences, etc.

Model

IP phone model.

Account

Information required for the IP phone to register with the SIP server.

Line Key Setting

Set the shortcut keys of the IP phone.

Features

Call Waiting: When the phone is in a call and another extension calls it, it will enter the waiting state if this feature enabled, or it will hang up the call if this feature disabled.

Auto Answer: The IP phone automatically answers after ringing.

Voicemail: When enabled, press the voicemail button on the phone to automatically send *97.

Local Phone Book: When enabled, the configured phone book is automatically downloaded to the IP phone's address book.

Key As Send: To determine if the IP phone directly calls out when pressing the # key.

Remote Phone Book: You can directly view the phone book on the server by using this feature.

CODEC

Set the codec supported by the IP phone.

Preference

Language: Set the display language of the IP phone.

Admin Password: Set the login password for the IP phone.

NTP Server: Set the NTP server address of the IP phone.

Time Display Format: Set the time format for the IP phone.

Date Display Format: Set the date format for the IP phone.

Time Zone: Set the time zone for the IP phone.


3.4.12 Phone Book

Item | Description
Phone Book | This address book is only applicable for UCTALK APP, the access port is 10600, and the uploaded file must be named contacts.txt.
Choose a File | Select the address book to upload.
Phone Book Template Download | Download a template of the address book.


3.5 System


3.5.1 Network Settings


3.5.1.1 Basic Settings

Item | Description
Hostname | The default value is IPPBX.
Mode | Three options available: Dual, Bridge, Route. The default mode is Dual. Dual: Use Both Eth to communicate. Bridge: Working as switch with LAN address activate. Route: Working as a router, Only WAN used to communicate, LAN supports DHCP server in Router Mode.
Default Interface | When the IPPBX is in the Dual network mode, users should make an interface selection from LAN and WAN. The default setting is LAN.
IPv4 | Description
Network Mode | Three options available: IP, DHCP, PPPoE, which are the same as the PC in settings.
IPv6 | Description
Network Mode | Two options available: Static IP, DHCP.


3.5.1.2 OPENVPN

Item | Description
Enable OpenVPN | Choose whether to enable VPN.
Server Address | Enter the server address of OpenVPN.
Server Port | Enter the server port of OpenVPN. The default value is 1194.
Protocol | Select the protocol type. The client and server must use the same setting.
Device Mode | Select the network device. The client and server must use the same setting. TUN: A TUN device is a virtual point-to-point IP link; TAP: A TAP device is a virtual Ethernet adapter.
Username | Specify the username.
Password | Specify the password.
Encryption | Select the encryption method. The client and server must use the same setting.
Compression | Enable or disable compression for data stream. The client and server must use the same setting.
CA Certificate | Upload a CA certificate
Certificate | Upload a client certificate
Key | Upload a client key.
TLS Authentication | Enable or disable TLS authentication. If enabled, please upload a TA key.


3.5.1.3 Static Routes

Item | Description
Add Routes | The way to add routes is the same as that for the PC.


3.5.2 Security Strategy


3.5.2.1 Security Strategy

Static Defense | Description
Enable Firewall | It is ticked by default.
Enable Ping | If it is unticked, the ping will be forbidden. By default it is ticked.
Drop All | By default it is unticked. Add at least one rule that allows TCP to connect to HTTPS:443, telnet:23 before ticking.
Add | The way to add a static security strategy is the same as adding a firewall rule for Linux.
Auto Defense | Description
Port | Enter the port for auto defense. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Protocol | Select a protocol for auto defense, including TCP (default) and UDP.
Number of IP Packets | The allowed number of packets received within the ‘time interval’. If the amount of data from a certain IP packet within the ‘time interval’ exceeds this threshold, the IP will be blacklisted. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Time Interval | Time interval for receiving packets, calculated by second. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Blacklist | Those calls which meet the above set conditions will be blacklisted herein. It can be manually deleted.


3.5.2.2 Service

Service | Description
Auto Logout Time | Set the automatic logout time of the webpage, up to 120 minutes, the default value is 60, calculated by minute.
Protocol | Select the type for webpage access, the default setting is HTTPS.
Port | Set the port for webpage access, the default value is 443.
Redirect from Port 80 | If it is enabled, the access to Port 80 using the HTTP protocol will be automatically redirected to the corresponding port of HTTPS. By default it is ticked.
Enable Telnet | Set whether to enable Telnet and the corresponding port. By default it is ticked and the port is 23.
Enable FTP | Set whether to enable FTP and the corresponding port. By default it is ticked and the port is 21. The FTP login username and password are the same as the admin user. After logging in, you can check the recording data under the storage space such as FLASH, USB mobile hard disk and TF card.
Enable TFTP | Set whether to enable TFTP. By default it is ticked.


3.5.3 Date Time Settings

Item | Description
Current System Time | Display the current system date and time of the PBX.
Time Zone | The default setting is GMT+8:00 (Beijing).
Set up Manually | Set the date and time manually. Tick the option System Time below and you can manually set the time.
Synchronized with NTP Server | Fill in the address or domain name of a NTP server and the PBX will synchronize with it in time automatically.
System Time | Set the system time manually.
Enable NTP Server | Tick this option to provide the NTP service for other devices.


3.5.4 Storage


3.5.4.1 Preference

3.5

3.5.1

3.5.2

3.5.3

3.5.4

3.5.4.1


3.5.4.1.1 Storage Locations
Item | Description
Voicemail | A location to store your voicemail. It is Local Flash by default. If you plug TF or USB storage cards to the PBX, or add network disks, there will be more options: TF/SD, USB or the network disk (user-defined name).
Recordings | A location to store your recordings. It is Local Flash by default. If you plug TF or USB storage cards to the PBX, or add network disks, there will be more options: TF/SD, USB or the network disk (user-defined name).
OTR | A location to store your One Touch Recordings. It is Local Flash by default. If you plug TF or USB storage cards to the PBX, or add network disks, there will be more options: TF/SD, USB or the network disk (user-defined name).
Logs | A location to store your logs. It is Local Flash by default. If you plug TF or USB storage cards to the PBX, or add network disks, there will be more options: TF/SD, USB or the network disk (user-defined name).


3.5.4.1.2 Storage Devices
Item | Description
LOCAL | Display the total storage, available size, usage of the local flash card, providing a reference for storage setting.
TF/SD | Display the total storage, available size, usage of the external TF card, providing a reference for storage setting.
USB | Display the total storage, available size, usage of the external USB card, providing a reference for storage setting.
NETDISK | Display the total storage, available size, usage of the added network disk, providing a reference for storage setting.


3.5.4.2 Auto Cleanup

3.5.4.2


3.5.4.2.1 CDR Auto Cleanup
Item | Description
Max Number of CDR | Set the maximum number of CDR that should be retained. The default value is 10 and the value 0 means no limit. If the threshold is reached, the oldest CDR will be deleted.
CDR Preservation Duration | Set the maximum number of days when CDR should be retained. The default value is 0 which means no limitation. If the threshold is reached, the oldest CDR will be deleted.
Max Number of Conference Sessions | Set the maximum number of conference records allowed to save. If it is exceeded, the oldest record will be deleted. The default value is 5000, and 0 means no limitation.


3.5.4.2.2 Voicemail and One Touch Recording Auto Cleanup
Item | Description
Max Number of Files | Set the maximum number of voicemail and one touch recording files that should be retained respectively for each extension. The default value is 30. If the threshold is reached, the oldest data will be deleted.
Preservation Duration | Set the maximum number of days for voicemail and one touch recording files to be retained respectively for each extension. The default value is 0 which means no limitation. If the threshold is reached, the oldest data will be deleted.
Files Preservation Duration | Set the maximum number of minutes for voicemail and one touch recording files to be retained respectively for each extension. The default value is 0 which means no limitation. If the threshold is reached, the oldest data will be deleted.


3.5.4.2.3 Recordings Auto Cleanup
Item | Description
Max Usage of Device | Set the maximum storage percentage of recording files for the device. The default value is 80% and the value range is 30%~90%. If the threshold is reached, the oldest data will be deleted.
Rec Preservation Duration | Set the maximum number of days for recording files to be retained. The default value is 0 which means no limitation. If the threshold is reached, the oldest data will be deleted.


3.5.4.2.4 Logs Auto Cleanup
Item | Description
Max Size of Total Logs | Set the maximum size of logs that can be saved per file. The default value is 50MB. If the threshold is reached, the oldest data will be deleted.
Logs Preservation Duration | Set the maximum number of log files to be saved. The default value is "7", and "0" means no limit.


3.5.4.2.5 Backups
Item | Description
Auto Upload FTP | After the information of the FTP server is configured, the recording file will be uploaded automatically. The default setting is False.
FTP Address | FTP server address, format: xxx:xxx:xxx:xxx or xxx:xxx:xxx:xxx:xx. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Username | User name used on the FTP server
Password | Password used on the FTP server
Upload Time | Real Time (default): upload every 5 minutes Timing: Upload at a fixed time every day. If you select this item, you need to set the startup time and the default setting is 00:00.
Delete Source File | Set whether to delete the original recording file after it is uploaded. The default setting is False.
FTP Test | After the above configurations are set, you can test whether the FTP connection goes normal.


3.5.5 User Permission


3.5.5.1 Users

This interface is used for adding WEB users. The default user and its password are both admin. The admin user can log in to the device through FTP to access the USB, network disk and local recording folder. The initial password is admin and you can modify it via the web page.

Item | Description
Username | User-defined, not allowed to be Admin.
Password | User-defined.
Confirm Password | Confirm your password.
Language | Select a language, Chinese or English.
Groups | Determine the user’s authority
Enabled | Set the status of this account.


3.5.5.2 User Group

Item | Description
Admin | By default an administrator group has the authority to check status, call records and set recordings, as well as PBX, system and all functional modules. The exact authority of corresponding functional modules can be set by requirements.
Public | By default a public group only has the authority to check status and call records, as well as play and query recordings. The exact authority of corresponding functional modules can be set by requirements.
User | By default a user group only has the authority to check status and call records, as well as play and query recordings. The exact authority of corresponding functional modules can be set by requirements.


3.5.6 Event Setting


3.5.6.1 System Settings

Item | Description
User Login Success | If this option is ticked, the event will be reported after the user logs in successfully. By default it is unticked.
CPU Overload | If this option is ticked, the event will be reported when the CPU reaches the threshold. By default it is unticked and the threshold is 90%.
Local Storage Full | If this option is ticked, the event will be reported when the local storage space reaches the threshold. By default it is unticked and the threshold is 90%.
Memory Overload | If this option is ticked, the event will be reported when the memory usage reaches the threshold. By default it is unticked and the threshold is 90%.
Usb Storage Full | If this option is ticked, the event will be reported when the USB storage space reaches the threshold. By default it is unticked and the threshold is 90%.
Network Attacked | If this option is ticked, the event will be reported when the network is attacked. By default it is unticked.
Network Failure | If this option is ticked, the event will be reported when the network connection fails. By default it is unticked.
System Reboot | If this option is ticked, the event will be reported when the system restarts. By default it is unticked.
PBX Upgrade | If this option is ticked, the event will be reported when the device is upgraded. By default it is unticked.
Script Monitor | If this option is checked, the event will be reported when there is a problem with the API. The default setting is unchecked.


3.5.6.2 PBX Settings

Item | Description
Emergency Call | If this option is ticked, the event will be reported when an emergency call is triggered. By default it is unticked.
Outbound Call Failure | If this option is ticked, the event will be reported when the outbound call fails. By default it is unticked.
Register SIP Trunk Failed | If this option is ticked, the event will be reported when the SIP trunk registration fails. By default it is unticked.
Peer to Peer SIP Trunk Unreachable | If this option is ticked, the event will be reported when the peer-to-peer SIP trunk is unreachable. By default it is unticked.


3.5.6.3 Notification Contacts

Item | Description
Choose Contacts | Select a contact, which can be an FXS extension or a SIP extension. The default setting is Default.
Contact Name | Contact name. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Email Address | Email address. This item must be filled in when Email is ticked as the notification method, otherwise the configuration will fail to be saved.


3.5.7 Email Settings

Item | Description
Username | The email account which is used to send emails, in the format of god@qq.com .It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Password | The login password of the Email account used to send emails. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Display Name | The display name for the email being sent. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Send Mail Server | Only the SMTP server is supported now whose format is smtp.qq.com. It is null by default and must be filled in; otherwise the configuration will fail to be saved.
Port | The port of the SMTP server, with the default setting of 25.It must be filled in; otherwise the configuration will fail to be saved.
Enable SSL/TLS | Depend on if the mail server requires or not. It is ticked by default.
Test Mail | After settings are done, click Test Mail to check if the settings are correct. A test email will be send to the mailbox.


3.5.8 Centralized Manage Setting

Item | Description
Centralized Manage | Tick Enable to start centralized management. It is unticked by default.
Centralized Management Protocol | Centralized management protocol. The default setting is SNMP.
Server Address | Server address. The default setting is 127.0.0.1.
Monitoring Port | Listening port number. The default value is 161.
Community String | Community. The default setting is public.


3.6 Maintenance


3.6.1 Upgrade

Item | Description
Manual Upgrade | Use the upgrading file to upgrade the PBX version manually.


3.6.2 Reboot

Item | Description
Reboot | Reboot the IPPBX system.
Auto Reboot | Set auto reboot in a day, a week or a month.


3.6.3 Backup and Restore


3.6.3.1 Backup

The backup content includes: System Configuration (default), Network Configuration, CDR, Operation Log Record, Customized Voice Prompt Files (default), System Voice Prompt Files. Users can customize the backup content.


3.6.3.2 Restore

Click the Browse button to select a backup file on your PC to restore your device.


3.6.3.3 Backup Lists

Display all lists of files that have been backed up with the backup time. Here you can select a backup file to restore.


3.6.4 Factory Reset

Item | Description
Factory Reset | Restore to the factory settings. You can choose not to restore the network settings. You should enter the correct verification code for reset, which is randomly generated


3.6.5 PBX LOG

Item | Description
Log Level | Six options available: CONSOLE, INFO, NOTICE, WARNING, ERROR, DEBUG. When DEBUG is ticked, you can set subsequently whether to output ‘siptrace’ which is the log of SIP messages.
Log List | The system will generate a log file every day which can be downloaded and deleted.


3.6.6 Operation Log

Item | Description
Filter | Main WEB operations will all be recorded to operation logs which can be queried by Username, IP Address, Start and End Date.
Display | The log list will display the operation time, the user who operated, the IP address, the type of operation as well as the operation details.


3.6.7 Log Viewer

Item | Description
Log Viewer | The key calls will be recorded in logs. On this interface you can filter those logs and sort them in descending order, show their line numbers and set their display size so as to better view the current log information.


3.6.8 Trouble Shooting

Item | Description
Ethernet Capture Tool | Set filter conditions for network capture, such as SIP only, both SIP and RTP, etc.
Port Monitoring Tool | Designate an FXO or FXS port for recording, as well as designate an FXO port to pick up or hang up the call.
IP Ping | Test connection of the destination via IP ping.
Trace Route | Test the network route and path as well as the response time.


3.6.9 Authorization


3.6.9.1 Authorization Info

Item | Description
Serial Number | Device serial number
Max Sessions | Concurrent number. The default value for UC200 is 15, for UC500 is 30, for UC500H is 30.
Max extensions | The number of extensions. The default value for UC200 is60, for UC500 is 150, for UC500H is 150.
Features | The features supported by this device,


3.6.9.2 Upload Authorization File

Item | Description
Upload | Manually upload the authorization file to the IPPBX and you can view the latest authorized information in ‘Authorization Information’.


3.6.9.3 Clear Authorization

Item | Description
Clear | Enter your password to do the clearance.


3.6.10 Event Log

Item | Description
Event Query | All the logs that are reported by the trigger event will be recorded in the event log. You can query them by ‘Event Type’, ‘Event Name’, and ‘Time’.
Event Display | The log list shows such detail information as time, event type, event name, and log content.


Appendix A Troubleshooting

Q1. What to do if I forget the IP address of UC200/UC500/UC500H?

There are two ways to get the IP address:

1) Long press the Reset button on UC200/UC500/UC500Hto restore to factory settings. The default IP address is 192.168.1.101 (WAN) or 192.168.0.101 (LAN).

2) Dial the corresponding function key through an FXS port to query the IP address. See Function Key for more details (excluding UC500H).

Q2. Which RTP codecs are supported by UC200/UC500/UC500H?

At present, the supported RTP codecs are: G.711A, G.711U, G.729.

Q3. How to configure the features Communication without Power for UC200/UC500?

The feature Communication without Power is implemented in hardware. Once the power to the device is cut off, the station which is linked with the FXS port of UC200/UC500 and the trunk which is linked with the FXO port will connect to each other directly and keep the good communications between phones and networks. The FXS and FXO ports are one-to-one correspondence.

Q4. Which size and brand of TF cards are supported for expansion?

Size: up to 256G.

Data writing speed: ≥60MB/s.

l Sandisk Extreme Pro Series;

l Sandisk Extreme Series;

l Samsung Pro Series.

Q5. Which size of external USB drives is supported?

Standard: USB2.0.

Size: up to 1T.

Q6. What is the encoding format for recording?

PCM16 single track.

Q7. Which encoding formats are supported for the user-defined prompts?

G711 A, G711 U, PCM16wav files (8kHz single track).

Q8. How to register a SIP extension to UC200 via the LAN or WAN port?

To register a SIP extension to UC200 via either the LAN or the WAN port, just use the IP address of the LAN or WAN port as the address of the registrar.

Q9. Which are the monitoring ports respectively for SIP extensions and SIP trunks on UC200/UC500/UC500H?

The monitoring port for SIP extensions on UC200/UC500 is 5060 while that for SIP trunks is 5080, both of which can be modified in SIP settings according to your requirements.


Appendix B Technical/sales Support

Thank you for choosing Synway. Please contact us should you have any inquiry regarding our products. We shall do our best to help you.

Headquarters

Synway Information Engineering Co., Ltd

http://www.synway.net/

9F, Synway D&R Center, No.3756, Nanhuan Road, Binjiang District, Hangzhou, P.R.China, 310053

Tel: +86-571-88860561

Fax: +86-571-88850923

Wechat QR Code: Scan the QR code below to add us on Wechat.

Technical Support

Tel: +86-571-88864579

Mobile: +86-18905817070

Email: techsupport@sanhuid.com

Email: techsupport@synway.net

MSN: synway.support@hotmail.com

Sales Department

Tel: +86-571-88860561

Tel: +86-571-88864579

Fax: +86-571-88850923

Email: sales@synway.net