Cover

Synway DST Series

Synway IPR Series

D-channel Event Manual

Synway Information Engineering Co., Ltd

www.synway.net


Contents

Contents. i

Copyright Declaration. vii

Chapter 1 D-Channel Events. 1

1.1 Brief Introduction to D-channel Events. 1

1.2 PBX Events. 1

1.2.1 Ring Events. 1

1.2.1.1 DE_RING_ON (0x101F) 1

1.2.1.2 DE_RING_OFF (0x1020) 2

1.2.2 Audio Events. 2

1.2.2.1 DE_AUDIO_CHG (0x104A) 2

1.2.3 LED Events. 3

1.2.3.1 DE_LT_FASTFLASHING (0x100B) 4

1.2.3.2 DE_LT_FLASHING (0x1003) 4

1.2.3.3 DE_LT_OFF (0x1002) 4

1.2.3.4 DE_LT_ON (0x1001) 4

1.2.3.5 DE_LT_QUICKFLASH (0x1025) 4

1.2.3.6 DE_LT_VERY_FASTFLASHING (0x1033) 4

1.2.3.7 DE_ANSWER_LT_FASTFLASHING (0x10C3) 5

1.2.3.8 DE_ANSWER_LT_FLASHING (0x10C2) 5

1.2.3.9 DE_ANSWER_LT_OFF (0x10C0) 5

1.2.3.10 DE_ANSWER_LT_ON (0x10C1) 5

1.2.3.11 DE_ANSWER_LT_VERY_FASTFLASHING (0x10C4) 5

1.2.3.12 DE_CALLBACK_LT_FASTFLASHING (0x126A) 5

1.2.3.13 DE_CALLBACK_LT_FLASHING (0x1268) 5

1.2.3.14 DE_CALLBACK_LT_OFF (0x1266) 5

1.2.3.15 DE_CALLBACK_LT_ON (0x1267) 6

1.2.3.16 DE_CALLBACK_LT_WINK (0x1269) 6

1.2.3.17 DE_CALLWAITING_LT_ON (0x10F9) 6

1.2.3.18 DE_CONFERENCE_LT_FASTFLASHING (0x10E3) 6

1.2.3.19 DE_CONFERENCE_LT_FLASHING (0x10E2) 6

1.2.3.20 DE_CONFERENCE_LT_OFF (0x10E0) 6

1.2.3.21 DE_CONFERENCE_LT_ON (0x10E1) 7

1.2.3.22 DE_CONFERENCE_LT_QUICKFLASH (0x10E5) 7

1.2.3.23 DE_CONFERENCE_LT_VERY_FASTFLASHING (0x10E4) 7

1.2.3.24 DE_CONFERENCE_LT_WINK (0x10E6) 7

1.2.3.25 DE_DIRECTORY_LT_FASTFLASHING (0x1133) 7

1.2.3.26 DE_DIRECTORY_LT_FLASHING (0x1132) 7

1.2.3.27 DE_DIRECTORY_LT_MEDIUM_WINK(0x1138) 7

1.2.3.28 DE_DIRECTORY_LT_OFF (0x1130) 7

1.2.3.29 DE_DIRECTORY_LT_ON (0x1131) 8

1.2.3.30 DE_DIRECTORY_LT_QUICKFLASH (0x1135) 8

1.2.3.31 DE_DIRECTORY_LT_SLOW_WINK (0x1137) 8

1.2.3.32 DE_DIRECTORY_LT_VERY_FASTFLASHING (0x1134) 8

1.2.3.33 DE_DIRECTORY_LT_WINK (0x1136) 8

1.2.3.34 DE_DIVERT_LT_FASTFLASHING (0x1182) 8

1.2.3.35 DE_DIVERT_LT_FLASHING (0x1181) 8

1.2.3.36 DE_DIVERT_LT_OFF (0x117F) 8

1.2.3.37 DE_DIVERT_LT_ON (0x1180) 9

1.2.3.38 DE_DND_LT_FASTFLASHING (0x1170) 9

1.2.3.39 DE_DND_LT_FLASHING (0x116F) 9

1.2.3.40 DE_DND_LT_MEDIUM_WINK (0x1175) 9

1.2.3.41 DE_DND_LT_OFF (0x116D) 9

1.2.3.42 DE_DND_LT_ON (0x116E) 9

1.2.3.43 DE_DND_LT_QUICKFLASH (0x1172) 9

1.2.3.44 DE_DND_LT_VERY_FASTFLASHING (0x1171) 9

1.2.3.45 DE_DND_LT_WINK (0x1173) 10

1.2.3.46 DE_FEATURE_LT_FASTFLASHING (0x106B) 10

1.2.3.47 DE_FEATURE_LT_FLASHING (0x106A) 10

1.2.3.48 DE_FEATURE_LT_OFF (0x1068) 10

1.2.3.49 DE_FEATURE_LT_ON (0x1069) 10

1.2.3.50 DE_FEATURE_LT_VERY_FASTFLASHING (0x106C) 10

1.2.3.51 DE_FLASH_LT_FASTFLASHING (0x1196) 11

1.2.3.52 DE_FLASH_LT_FLASHING (0x1195) 11

1.2.3.53 DE_FLASH_LT_MEDIUM_WINK (0x119B) 11

1.2.3.54 DE_FLASH_LT_OFF (0x1193) 11

1.2.3.55 DE_FLASH_LT_ON (0x1194) 11

1.2.3.56 DE_FLASH_LT_QUICKFLASH (0x1198) 11

1.2.3.57 DE_FLASH_LT_SLOW_WINK (0x119A) 11

1.2.3.58 DE_FLASH_LT_VERY_FASTFLASHING (0x1197) 11

1.2.3.59 DE_FLASH_LT_WINK (0x1199) 12

1.2.3.60 DE_FUNC_LT_FASTFLASHING (0x100B) 12

1.2.3.61 DE_FUNC_LT_FLASHING (0x1003) 12

1.2.3.62 DE_FUNC_LT_MEDIUM_WINK (0x114D) 12

1.2.3.63 DE_FUNC_LT_OFF (0x1002) 12

1.2.3.64 DE_FUNC_LT_ON (0x1001) 12

1.2.3.65 DE_FUNC_LT_QUICKFLASH (0x1025) 12

1.2.3.66 DE_FUNC_LT_VERY_FASTFLASHING (0x1033) 12

1.2.3.67 DE_FUNC_LT_WINK (0x114B) 13

1.2.3.68 DE_GROUP_LT_FASTFLASHING (0x1179) 13

1.2.3.69 DE_GROUP_LT_FLASHING (0x1178) 13

1.2.3.70 DE_GROUP_LT_OFF (0x1176) 13

1.2.3.71 DE_GROUP_LT_ON (0x1177) 13

1.2.3.72 DE_HOLD_LT_FASTFLASHING (0x1083) 14

1.2.3.73 DE_HOLD_LT_FLASHING (0x1082) 14

1.2.3.74 DE_HOLD_LT_OFF (0x1080) 14

1.2.3.75 DE_HOLD_LT_ON (0x1081) 14

1.2.3.76 DE_HOLD_LT_VERY_FASTFLASHING (0x1084) 14

1.2.3.77 DE_ICM_LT_FASTFLASHING (0x126F) 14

1.2.3.78 DE_ICM_LT_FLASHING (0x126D) 14

1.2.3.79 DE_ICM_LT_OFF (0x126B) 15

1.2.3.80 DE_ICM_LT_ON (0x126C) 15

1.2.3.81 DE_ICM_LT_WINK (0x126E) 15

1.2.3.82 DE_MIC_LT_FASTFLASHING (0x107B) 15

1.2.3.83 DE_MIC_LT_FLASHING (0x107A) 15

1.2.3.84 DE_MIC_LT_OFF (0x1078) 15

1.2.3.85 DE_MIC_LT_ON (0x1079) 15

1.2.3.86 DE_MIC_LT_VERY_FASTFLASHING (0x107C) 15

1.2.3.87 DE_MSG_LT_FASTFLASHING (0x10D3) 16

1.2.3.88 DE_MSG_LT_FLASHING (0x10D2) 16

1.2.3.89 DE_MSG_LT_MEDIUM_WINK (0x119F) 16

1.2.3.90 DE_MSG_LT_OFF (0x10D0) 16

1.2.3.91 DE_MSG_LT_ON (0x10D1) 16

1.2.3.92 DE_MSG_LT_QUICKFLASH (0x10D5) 16

1.2.3.93 DE_MSG_LT_VERY_FASTFLASHING (0x10D4) 16

1.2.3.94 DE_MUTE_LT_FASTFLASHING (0x1121) 17

1.2.3.95 DE_MUTE_LT_FLASHING (0x1120) 17

1.2.3.96 DE_MUTE_LT_OFF (0x111E) 17

1.2.3.97 DE_MUTE_LT_ON (0x111F) 17

1.2.3.98 DE_MUTE_LT_QUICKFLASH (0x1123) 17

1.2.3.99 DE_MUTE_LT_VERY_FASTFLASHING (0x1122) 17

1.2.3.100 DE_MUTE_LT_WINK (0x1124) 17

1.2.3.101 DE_PAGE_LT_FASTFLASHING (0x110B) 18

1.2.3.102 DE_PAGE_LT_FLASHING (0x110A) 18

1.2.3.103 DE_PAGE_LT_OFF (0x1108) 18

1.2.3.104 DE_PAGE_LT_ON (0x1109) 18

1.2.3.105 DE_PAGE_LT_VERY_FASTFLASHING (0x110C) 18

1.2.3.106 DE_PROGRAM_LT_FASTFLASHING (0x10CB) 18

1.2.3.107 DE_PROGRAM_LT_FLASHING (0x10CA) 18

1.2.3.108 DE_PROGRAM_LT_MEDIUM_WINK (0x10CF) 19

1.2.3.109 DE_PROGRAM_LT_OFF (0x10C8) 19

1.2.3.110 DE_PROGRAM_LT_ON (0x10C9) 19

1.2.3.111 DE_PROGRAM_LT_QUICKFLASH (0x10CD) 19

1.2.3.112 DE_PROGRAM_LT_VERY_FASTFLASHING (0x10CC) 19

1.2.3.113 DE_PROGRAM_LT_WINK (0x10CE) 19

1.2.3.114 DE_REDIAL_LT_FASTFLASHING (0x1103) 19

1.2.3.115 DE_REDIAL_LT_FLASHING (0x1102) 19

1.2.3.116 DE_REDIAL_LT_OFF (0x1100) 20

1.2.3.117 DE_REDIAL_LT_ON (0x1101) 20

1.2.3.118 DE_REDIAL_LT_VERY_FASTFLASHING (0x1104) 20

1.2.3.119 DE_RING_LT_FASTFLASHING (0x10BB) 20

1.2.3.120 DE_RING_LT_FLASHING (0x10BA) 20

1.2.3.121 DE_RING_LT_OFF (0x10B8) 20

1.2.3.122 DE_RING_LT_ON (0x10B9) 20

1.2.3.123 DE_RING_LT_QUICKFLASH (0x10BD) 20

1.2.3.124 DE_RING_LT_VERY_FASTFLASHING (0x10BC) 21

1.2.3.125 DE_SCROLL_LT_FASTFLASHING (0x118B) 21

1.2.3.126 DE_SCROLL_LT_FLASHING (0x118A) 21

1.2.3.127 DE_SCROLL_LT_OFF (0x1188) 21

1.2.3.128 DE_SCROLL_LT_ON (0x1189) 21

1.2.3.129 DE_SOFT_LT_FASTFLASHING (0x10EB) 22

1.2.3.130 DE_SOFT_LT_OFF (0x10E8) 22

1.2.3.131 DE_SOFT_LT_ON (0x10E9) 22

1.2.3.132 DE_SPEAKER_LT_FASTFLASHING (0x1073) 22

1.2.3.133 DE_SPEAKER_LT_FLASHING (0x1072) 22

1.2.3.134 DE_SPEAKER_LT_MEDIUM_WINK (0x119E) 22

1.2.3.135 DE_SPEAKER_LT_OFF (0x1070) 22

1.2.3.136 DE_SPEAKER_LT_ON (0x1071) 23

1.2.3.137 DE_SPEAKER_LT_QUICKFLASH (0x1075) 23

1.2.3.138 DE_SPEAKER_LT_VERY_FASTFLASHING (0x1074) 23

1.2.3.139 DE_SPEAKER_LT_WINK (0x1076) 23

1.2.3.140 DE_SPEEDDIAL_LT_FASTFLASHING (0x11A3) 23

1.2.3.141 DE_SPEEDDIAL_LT_FLASHING (0x11A2) 23

1.2.3.142 DE_SPEEDDIAL_LT_MEDIUM_WINK (0x11A8) 23

1.2.3.143 DE_SPEEDDIAL_LT_OFF (0x11A0) 23

1.2.3.144 DE_SPEEDDIAL_LT_ON (0x11A1) 24

1.2.3.145 DE_SPEEDDIAL_LT_QUICKFLASH (0x11A5) 24

1.2.3.146 DE_SPEEDDIAL_LT_SLOW_WINK (0x11A7) 24

1.2.3.147 DE_SPEEDDIAL_LT_VERY_FASTFLASHING (0x11A4) 24

1.2.3.148 DE_SPEEDDIAL_LT_WINK (0x11A6) 24

1.2.3.149 DE_TRANSFER_LT_FASTFLASHING (0x10DB) 24

1.2.3.150 DE_TRANSFER_LT_FLASHING (0x10DA) 24

1.2.3.151 DE_TRANSFER_LT_OFF (0x10D8) 24

1.2.3.152 DE_TRANSFER_LT_ON (0x10D9) 25

1.2.3.153 DE_TRANSFER_LT_VERY_FASTFLASHING (0x10DC) 25

1.2.3.154 DE_TRANSFER_LT_WINK (0x10DE) 25

1.2.4 LCD Events. 25

1.2.4.1 DE_DISPLAY_CLEAR (0x102A) 25

1.2.4.2 DE_DISPLAY_CLOCK (0x1028) 25

1.2.4.3 DE_DISPLAY_MSG (0x104B) 26

1.2.4.4 DE_DISPLAY_TIMER (0x1029) 26

1.2.4.5 DE_MSG_CHG (0x1008) 26

1.2.5 Call State Events. 26

1.2.5.1 DE_ABANDONED (0x103A) 26

1.2.5.2 DE_AUTO_ANSWER (0x102D) 27

1.2.5.3 DE_AUTO_ANSWER_CANCELED (0x102E) 27

1.2.5.4 DE_CFWD (0x102B) 27

1.2.5.5 DE_CFWD_CANCELED (0x102C) 27

1.2.5.6 DE_SET_BUSY (0x102F) 27

1.2.5.7 DE_SET_BUSY_CANCELED (0x1030) 28

1.2.5.8 DE_CISCO_SCCP_CALL_INFO (0x1280) 28

1.2.5.9 DE_CALLSTATE_IDLE (0x1304) 29

1.2.5.10 DE_CALLSTATE_DIALING (0x1306) 29

1.2.5.11 DE_CALLSTATE_ALERTING (0x1307) 29

1.2.5.12 DE_CALLSTATE_FAR_END_RINGBACK (0x1308) 29

1.2.5.13 DE_CALLSTATE_TALK (0x1309) 29

1.3 Phone Events. 29

1.3.1 HOOK Events. 29

1.3.1.1 DE_OFFHOOK (0x8) 29

1.3.1.2 DE_ONHOOK (0xe) 30

1.3.2 Button Events. 30

1.3.2.1 DE_ANSWER_BTN_PRS (0x1015) 30

1.3.2.2 DE_CALLBACK_BTN_PRS (0x1191) 30

1.3.2.3 DE_CALLBACK_BTN_RLS (0x1192) 30

1.3.2.4 DE_CANCEL_BTN_PRS (0x1110) 31

1.3.2.5 DE_CLEAR_BTN_PRS (0x1169) 31

1.3.2.6 DE_CONF_BTN_PRS (0x1018) 31

1.3.2.7 DE_CONF_BTN_RLS (0x1037) 31

1.3.2.8 DE_CTRL_BTN_PRS (0x110E) 31

1.3.2.9 DE_CTRL_BTN_RLS (0x110F) 31

1.3.2.10 DE_DGT_PRS (0x1006) 32

1.3.2.11 DE_DGT_RLS (0x1007) 32

1.3.2.12 DE_DIRECTORY_BTN_PRS (0x1116) 32

1.3.2.13 DE_DIVERT_BTN_PRS (0x115F) 32

1.3.2.14 DE_DND_BTN_PRS (0x1165) 32

1.3.2.15 DE_DND_BTN_RLS (0x1166) 33

1.3.2.16 DE_ENTER_BTN_PRS (0x1167) 33

1.3.2.17 DE_EXIT_BTN_PRS (0x101C) 33

1.3.2.18 DE_FEATURE_BTN_PRS (0x101A) 33

1.3.2.19 DE_FLASH_BTN_PRS (0x1114) 33

1.3.2.20 DE_FLASH_BTN_RLS (0x1115) 33

1.3.2.21 DE_FUNC_BTN_PRS (0x100E) 34

1.3.2.22 DE_FUNC_BTN_RLS (0x100F) 34

1.3.2.23 DE_GROUP_BTN_PRS (0x1161) 34

1.3.2.24 DE_HELP_BTN_PRS (0x101D) 34

1.3.2.25 DE_HOLD_BTN_PRS (0x1010) 34

1.3.2.26 DE_HOLD_BTN_RLS (0x1011) 35

1.3.2.27 DE_ICM_BTN_PRS (0x1270) 35

1.3.2.28 DE_ICM_BTN_RLS (0x1271) 35

1.3.2.29 DE_INTERCOM_BTN_PRS (0x11AD) 35

1.3.2.30 DE_INTERCOM_BTN_RLS (0x11AE) 35

1.3.2.31 DE_LINE_BTN_PRS (0x1021) 36

1.3.2.32 DE_MENU_BTN_PRS (0x1022) 36

1.3.2.33 DE_MIC_BTN_PRS (0x1112) 36

1.3.2.34 DE_MIC_BTN_RLS (0x1113) 36

1.3.2.35 DE_MODE_BTN_PRS (0x119C) 36

1.3.2.36 DE_MODE_BTN_RLS (0x119D) 36

1.3.2.37 DE_MSG_BTN_PRS (0x1040) 37

1.3.2.38 DE_MUTE_BTN_PRS (0x104F) 37

1.3.2.39 DE_MUTE_BTN_RLS (0x11F4) 37

1.3.2.40 DE_NEXT_BTN_PRS (0x1024) 37

1.3.2.41 DE_PAGE_BTN_PRS (0x1057) 37

1.3.2.42 DE_PAUSE_BTN_PRS (0x11AB) 37

1.3.2.43 DE_PAUSE_BTN_RLS (0x11AC) 38

1.3.2.44 DE_PREVIOUS_BTN_PRS (0x1023) 38

1.3.2.45 DE_PROGRAM_BTN_PRS (0x104E) 38

1.3.2.46 DE_RECALL_BTN_PRS (0x1019) 38

1.3.2.47 DE_REDIAL_BTN_PRS (0x1017) 38

1.3.2.48 DE_REDIAL_BTN_RLS (0x1035) 39

1.3.2.49 DE_RELEASE_BTN_PRS (0x1012) 39

1.3.2.50 DE_RELEASE_BTN_RLS (0x1013) 39

1.3.2.51 DE_SCROLL_BTN_PRS (0x115D) 39

1.3.2.52 DE_SCROLL_BTN_RLS (0x115E) 39

1.3.2.53 DE_SELECT_BTN_PRS (0x11A9) 39

1.3.2.54 DE_SELECT_BTN_RLS (0x11AA) 40

1.3.2.55 DE_SHIFT_BTN_PRS (0x1055) 40

1.3.2.56 DE_SHIFT_BTN_RLS (0x1056) 40

1.3.2.57 DE_SOFT_BTN_PRS (0x101E) 40

1.3.2.58 DE_SOFT_BTN_RLS (0x1059) 40

1.3.2.59 DE_SPEAKER_BTN_PRS (0x1016) 41

1.3.2.60 DE_SPEAKER_BTN_RLS (0x1034) 41

1.3.2.61 DE_SPEEDDIAL_BTN_PRS (0x1163) 41

1.3.2.62 DE_SPEEDDIAL_BTN_RLS (0x1164) 41

1.3.2.63 DE_TRANSFER_BTN_PRS (0x1014) 41

1.3.2.64 DE_TRANSFER_BTN_RLS (0x1036) 41

1.3.2.65 DE_SPEEDDIAL_NUMBER (0x130a) 42

1.4 ISDN BRI Events. 42

1.4.1 DE_CALL_ABANDONED (0x75) 42

1.4.2 DE_CALL_ALERTING (0x6E) 42

1.4.3 DE_CALL_CONNECTED (0x6F) 43

1.4.4 DE_CALL_HELD (0x73) 43

1.4.5 DE_CALL_IN_PROGRESS (0x6B) 43

1.4.6 DE_CALL_REJECTED (0x76) 44

1.4.7 DE_CALL_RELEASED (0x70) 44

1.4.8 DE_CALL_RESUMED (0x72) 44

1.4.9 DE_CALL_RETRIEVED (0x74) 45

1.4.10 DE_CALL_SUSPENDED (0x71) 45

Chapter 2 Programming with D-channel Events. 46

2.1 Application-defined Call State Machine. 46

2.2 Non D-channel Events. 46

2.3 State Machine Example. 46

2.4 Time to Start/Stop Recording. 48

Chapter 3 Siemens Hicom/Hipath. 49

3.1 Configuration.. 49

3.2 D-Channel Events. 49

3.3 Siemens Hicom/Hipath Behavior 50

3.4 D-Channel Events per Phone Model 51

3.4.1 Siemens Optiset 52

3.4.1.1 Phone Map & Event List 52

Chapter 4 Avaya Definity 2W... 53

4.1 Configuration.. 53

4.2 D-channel Events. 53

4.3 Avaya Definity 2W Behavior 54

4.4 D-channel Events per Phone Model 55

4.4.1 Avaya 8410D.. 56

4.4.1.1 Phone Map & Event List 56

4.4.2 Avaya 6408/6416/6424D.. 57

4.4.2.1 Phone Map & Event List 57

4.4.2.2 Call Scenarios. 59

4.4.3 Avaya CALL MASTER IV/V. 62

4.4.3.1 Phone Map & Event List 62

Chapter 5 Nortel Meridian 1. 63

5.1 Configuration.. 63

5.2 D-Channel Events. 63

5.3 Nortel Meridian 1 Behavior 64

5.4 D-Channel Events per Phone Model 66

5.4.1 M2216. 66

5.4.2 M2616. 67

5.4.2.1 Phone Map & Event List 67

5.4.3 M3901. 68

5.4.3.1 Phone Map & Event List 68

5.4.3.2 Call Scenarios. 69

5.4.4 M3903. 72

5.4.4.1 Call Scenarios. 72

5.4.5 M3905. 76

5.4.5.1 Phone Map & Event List 77

5.4.5.2 Call Scenarios. 78

Appendix A Technical/sales Support 80


Copyright Declaration

All rights reserved; no part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, without prior written permission from Synway Information Engineering Co., Ltd (hereinafter referred to as ‘Synway’).

Synway reserves all rights to modify this document without prior notice. Please contact Synway for the latest version of this document before placing an order.

Synway has made every effort to ensure the accuracy of this document but does not guarantee the absence of errors. Moreover, Synway assumes no responsibility in obtaining permission and authorization of any third party patent, copyright or product involved in relation to the use of this document.


Chapter 1 D-Channel Events


1.1 Brief Introduction to D-channel Events

The D-channel events vary in type and format as well as their effect on the call state, depending on the model and the manufacturer of PBXes and phones. That is, products from different manufacturers, even products in different series from a same manufacturer, provide different D-channel events. The following chapters respectively describe the D-channel events of all PBX and phone models which can be used with our DST series boards and IPR series software products.

Generally, the D-channel events supported by most PBXes and phones can be classified into two categories – PBX events and phone events - based on where they were generated.

Common PBX events include Ring events, Audio events, Display events and LED (light) events, and common phone events mainly cover Hook events and Button events.

Next we are going to the introduction of all D-channel events which can be reported by our DST series boards and IPR series software products. Note that only some of them can be observed in a particular PBX or phone system. For more information, refer to each PBX chapter in this manual.


1.2 PBX Events


1.2.1 Ring Events

In some PBX systems, once an inbound call is detected, the PBX will send instructions to the phone as a command to ring. Then the driver will decode these instructions to be DE_RING_ON (DST_RING_ON) and DE_RING_OFF (DST_RING_OFF) events. The number of which shall be determined by the particular PBX system. As to ring counting, in some systems where the PBX sends one DE_RING_ON (DST_RING_ON) event and one DE_RING_OFF (DST_RING_OFF) event to the phone in each complete ring cycle, the application can calculate the length of time the phone was ringing based on the number of received ring events. In other systems where the PBX only sends a DE_RING_ON (DST_RING_ON) event when it orders the phone to start ringing, and a DE_RING_OFF (DST_RING_OFF) event when it commands the phone to end ringing, the application must rely on the interval between these two events to determine how long the phone has been ringing.


1.2.1.1 DE_RING_ON (0x101F)

Same as DST_RING_ON.

Event Description:

The PBX orders the phone to start ringing. In some systems, this event is generated only once during a complete call, while in others, it is generated at the beginning of each ring. For more information, refer to the relevant PBX chapter.

Return Value:

Nil


1.2.1.2 DE_RING_OFF (0x1020)

Same as DST_RING_OFF.

Event Description:

The PBX orders the phone to end ringing. In some systems, this event is generated only once during a complete call, while in others, it is generated at the end of each ring. For more information, refer to the relevant PBX chapter.

Return Value:

Nil


1.2.2 Audio Events

In some systems the PBX controls external audio devices such as handset, microphone or speaker. It will send instructions to the phone as a command to change the state of these devices. Then the driver will decode these instructions to be the DE_AUDIO_CHG (DST_AUDIO_CHG) event. In other systems, the phone supports its own audio devices and the PBX does not control them. In such case, the phone does not report the change in audio state to the PBX so that the DST boards can not report the DE_AUDIO_CHG (DST_AUDIO_CHG) event to the application.


1.2.2.1 DE_AUDIO_CHG (0x104A)

Same as DST_AUDION_CHG.

Event Description:

The PBX commands the phone to change the state of corresponding audio devices. However, in those situations where the PBX does not generate this event, or turns on the audio devices during the phone initialization and never turns them off, this event can not be used to control the recording operation.

Return Value:

dwSubReason

Bit0-Bit3:

Device State | Bit3 | Bit2 | Bit1 | Bit0 | Hex Value
 | SPKR RECV | SPKR TRANS | HDSET RECV | HDSET TRANS
0=ON 1=OFF | 0 | 0 | 0 | 0 | 0x00
 | 0 | 0 | 0 | 1 | 0x01
 | 0 | 0 | 1 | 0 | 0x02
 | 0 | 0 | 1 | 1 | 0x03
 | 0 | 1 | 0 | 0 | 0x04
 | 0 | 1 | 0 | 1 | 0x05
 | 0 | 1 | 1 | 0 | 0x06
 | 0 | 1 | 1 | 1 | 0x07
 | 1 | 0 | 0 | 0 | 0x08
 | 1 | 0 | 0 | 1 | 0x09
 | 1 | 0 | 1 | 0 | 0x0A
 | 1 | 0 | 1 | 1 | 0x0B
 | 1 | 1 | 0 | 0 | 0x0C
 | 1 | 1 | 0 | 1 | 0x0D
 | 1 | 1 | 1 | 0 | 0x0E
 | 1 | 1 | 1 | 1 | 0x0F

Bit4-Bit31: Reserved


1.2.3 LED Events

In some systems, the PBX controls phone lights. It will send instructions to the phone as a command to change the light state. Then the driver will decode these instructions to be the DE_HOLD_LT_ON/OFF (DST_HOLD_LT_ON/OFF) event and the like. By monitoring light events, the application can track the call process more accurately, including such particular states as call hold, call transfer, etc. In other systems, the phone manages its own lights and the PBX does not control them. In such case, the phone does not report the change in light state to the PBX so that the DST boards can not report the light events to the application.

On many phones each light corresponds to a specific function. For example, some phones have Hold and Speaker buttons. When these buttons are operated, a corresponding event DE_HOLD_LT_ON/OFF (DST_HOLD_LT_ON/OFF) or DE_SPEAKER_LT_ON/OFF (DST_SPEAKER_LT_ON/OFF) is reported to the application. Besides, a particular light is probably mapped to a configurable function button. When such button is pressed, the application will get the corresponding event DE_FUNC_LT_ON/OFF (DST_FUNC_LT_ON/OFF).

In some PBX systems, light states involve not only ON and OFF but also FLASHING, FASTFLASHING, QUICKFLASH and so on. Therefore, all light events reported to the application also cover the categories as listed below.

² DE _XXX_LT_OFF (DST_XXX_LT_OFF)

² DE _XXX_LT_ON (DST_XXX_LT_ON)

² DE _XXX_LT_FASTFLASHING (DST_XXX_LT_FASTFLASHING)

² DE _XXX_LT_FLASHING (DST_XXX_LT_FLASHING)

² DE _XXX_LT_QUICKFLASH (DST_XXX_LT_QUICKFLASH)

² DE_XXX_LT_VERY_FASTFLASHING (DST_XXX_LT_VERY_FASTFLASHING)

² DE_XXX_LT_WINK (DST_XXX_LT_WINK)

² DE_XXX_LT_SLOW_WINK (DST_XXX_LT_SLOW_WINK)

² DE_XXX_LT_MEDIUM_WINK (DST_XXX_LT_MEDIUM_WINK)

Note: The above categories are all specified by Synway ourselves. The intervals defined by these events are various for different phone and PBX models. Even in a same environment, they vary on different system configurations.


1.2.3.1 DE_LT_FASTFLASHING (0x100B)

Same as DST_LT_FASTFLASHING

Refer to DE_LT_VERY_FASTFLASHING


1.2.3.2 DE_LT_FLASHING (0x1003)

Same as DST_LT_FLASHING

Refer to DE_LT_VERY_FASTFLASHING


1.2.3.3 DE_LT_OFF (0x1002)

Same as DST_LT_OFF

Refer to DE_LT_VERY_FASTFLASHING


1.2.3.4 DE_LT_ON (0x1001)

Same as DST_LT_ON

Refer to DE_LT_VERY_FASTFLASHING


1.2.3.5 DE_LT_QUICKFLASH (0x1025)

Same as DST_LT_QUICKFLASH

Refer to DE_LT_VERY_FASTFLASHING


1.2.3.6 DE_LT_VERY_FASTFLASHING (0x1033)

Same as DST_LT_VERY_FASTFLASHING

Event Description:

Lights on the phone turn into one of the following states: ON, OFF, FLASHING, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7 : Light Number (0-255)

Bit8=1 Green Light

Bit9=1 Red Light

Bit10-Bit31: Reserved


1.2.3.7 DE_ANSWER_LT_FASTFLASHING (0x 10C 3)

Same as DST_ANSWER_LT_FASTFLASHING

Refer to DE_ANSWER_LT_VERY_FASTFLASHING


1.2.3.8 DE_ANSWER_LT_FLASHING (0x 10C 2)

Same as DST_ANSWER_LT_FLASHING

Refer to DE_ANSWER_LT_VERY_FASTFLASHING


1.2.3.9 DE_ANSWER_LT_OFF (0x 10C 0)

Same as DST_ANSWER_LT_OFF

Refer to DE_ANSWER_LT_VERY_FASTFLASHING


1.2.3.10 DE_ANSWER_LT_ON (0x 10C 1)

Same as DST_ANSWER_LT_ON

Refer to DE_ANSWER_LT_VERY_FASTFLASHING


1.2.3.11 DE_ANSWER_LT_VERY_FASTFLASHING (0x10C4)

Same as DST_ANSWER_LT_VERY_FASTFLASHING

Event Description:

The ANSWER light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.12 DE_CALLBACK_LT_FASTFLASHING (0x 126A)

Same as DST_CALLBACK_LT_FASTFLASHING


1.2.3.13 DE_CALLBACK_LT_FLASHING (0x1268)

Same as DST_CALLBACK_LT_FLASHING

Refer to DE_CALLBACK_LT_WINK


1.2.3.14 DE_CALLBACK_LT_OFF (0x1266)

Same as DST_CALLBACK_LT_OFF

Refer to DE_CALLBACK_LT_WINK


1.2.3.15 DE_CALLBACK_LT_ON (0x1267)

Same as DST_CALLBACK_LT_ON

Refer to DE_CALLBACK_LT_WINK


1.2.3.16 DE_CALLBACK_LT_WINK (0x1269)

Same as DST_CALLBACK_LT_WINK

Event Description:

The CALLBACK light on the phone turns into one of the following states: ON, OFF, FLASHING or WINK, FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.17 DE_CALLWAITING_LT_ON (0x 10F 9)

Same as DST_CALLWAITING_LT_ON

Event Description:

The CALLWAITING light on the phone turns into the state ON.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.18 DE_CONFERENCE_LT_FASTFLASHING (0x10E3)

Same as DST_CONFERENCE_LT_FASTFLASHING

Refer to DE_CONFERENCE_LT_WINK


1.2.3.19 DE_CONFERENCE_LT_FLASHING (0x10E2)

Same as DST_CONFERENCE_LT_FLASHING

Refer to DE_CONFERENCE_LT_WINK


1.2.3.20 DE_CONFERENCE_LT_OFF (0x10E0)

Same as DST_CONFERENCE_LT_OFF

Refer to DE_CONFERENCE_LT_WINK


1.2.3.21 DE_CONFERENCE_LT_ON (0x10E1)

Same as DST_CONFERENCE_LT_ON

Refer to DE_CONFERENCE_LT_WINK


1.2.3.22 DE_CONFERENCE_LT_QUICKFLASH (0x10E5)

Same as DST_CONFERENCE_LT_QUICKFLASH

Refer to DE_CONFERENCE_LT_WINK


1.2.3.23 DE_CONFERENCE_LT_VERY_FASTFLASHING (0x10E4)

Same as DST_CONFERENCE_LT_VERY_FASTFLASHING

Refer to DE_CONFERENCE_LT_WINK


1.2.3.24 DE_CONFERENCE_LT_WINK (0x10E6)

Same as DST_CONFERENCE_LT_WINK

Event Description:

The CONFERENCE light on the phone turns into one of the following states: ON, OFF, FLASHING or WINK, FASTFLASHING, QUICKFLASH. VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.25 DE_DIRECTORY_LT_FASTFLASHING (0x1133)

Same as DST_DIRECTORY_LT_FASTFLASHING

Refer to DE_DIRECTORY_LT_WINK


1.2.3.26 DE_DIRECTORY_LT_FLASHING (0x1132)

Same as DST_DIRECTORY_LT_FLASHING

Refer to DE_DIRECTORY_LT_WINK


1.2.3.27 DE_DIRECTORY_LT_MEDIUM_WINK(0x1138)

Same as DST_ DIRECTORY_LT_MEDIUM_WINK

Refer to DE_DIRECTORY_LT_WINK


1.2.3.28 DE_DIRECTORY_LT_OFF (0x1130)

Same as DST_DIRECTORY_LT_OFF

Refer to DE_DIRECTORY_LT_WINK


1.2.3.29 DE_DIRECTORY_LT_ON (0x1131)

Same as DST_DIRECTORY_LT_ON

Refer to DST_DIRECTORY_LT_WINK


1.2.3.30 DE_DIRECTORY_LT_QUICKFLASH (0x1135)

Same as DST_DIRECTORY_LT_QUICKFLASH

Refer to DE_DIRECTORY_LT_WINK


1.2.3.31 DE_DIRECTORY_LT_SLOW_WINK (0x1137)

Same as DST_DIRECTORY_LT_SLOW_WINK

Refer to DE_DIRECTORY_LT_WINK


1.2.3.32 DE_DIRECTORY_LT_VERY_FASTFLASHING (0x1134)

Same as DST_DIRECTORY_LT_VERY_FASTFLASHING

Refer to DE_DIRECTORY_LT_WINK


1.2.3.33 DE_DIRECTORY_LT_WINK (0x1136)

Same as DST_DIRECTORY_LT_WINK

Event Description:

The DIRECTORY light on the phone turns into one of the following states: ON, OFF, FLASHING, MEDIUM_WINK, SLOW_WINK or WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.34 DE_DIVERT_LT_FASTFLASHING (0x1182)

Same as DST_DIVERT_LT_FASTFLASHING

Refer to DE_DIVERT_LT_ON


1.2.3.35 DE_DIVERT_LT_FLASHING (0x1181)

Same as DST_DIVERT_LT_FLASHING

Refer to DE_DIVERT_LT_ON


1.2.3.36 DE_DIVERT_LT_OFF (0x 117F)

Same as DST_DIVERT_LT_OFF

Refer to DE_DIVERT_LT_ON


1.2.3.37 DE_DIVERT_LT_ON (0x1180)

Same as DST_DIVERT_LT_ON

Event Description:

The DIVERT light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.38 DE_DND_LT_FASTFLASHING (0x1170)

Same as DST_DND_LT_FASTFLASHING

Refer to DE_DND_LT_WINK


1.2.3.39 DE_DND_LT_FLASHING (0x 116F)

Same as DST_DND_LT_FLASHING

Refer to DE_DND_LT_WINK


1.2.3.40 DE_DND_LT_MEDIUM_WINK (0x1175)

Same as DST_DND_LT_MEDIUM_WINK

Refer to DE_DND_LT_WINK


1.2.3.41 DE_DND_LT_OFF (0x116D)

Same as DST_DND_LT_OFF

Refer to DE_DND_LT_WINK


1.2.3.42 DE_DND_LT_ON (0x116E)

Same as DST_DND_LT_ON

Refer to DE_DND_LT_WINK


1.2.3.43 DE_DND_LT_QUICKFLASH (0x1172)

Same as DST_DND_LT_QUICKFLASH

Refer to DE_DND_LT_WINK


1.2.3.44 DE_DND_LT_VERY_FASTFLASHING (0x1171)

Same as DST_ DND_LT_VERY_FASTFLASHING

Refer to DE_DND_LT_WINK


1.2.3.45 DE_DND_LT_WINK (0x1173)

Same as DST_DND_LT_WINK

Event Description:

The DND (Do Not Disturb) light on the phone turns into one of the following states: ON, OFF, FLASHING, MEDIUM_WINK or WINK, QUICKFLASH, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.46 DE_FEATURE_LT_FASTFLASHING (0x106B)

Same as DST_FEATURE_LT_FASTFLASHING

Refer to DE_FEATURE_LT_VERY_FASTFLASHING


1.2.3.47 DE_FEATURE_LT_FLASHING (0x106A)

Same as DST_FEATURE_LT_FLASHING

Refer to DE_FEATURE_LT_VERY_FASTFLASHING


1.2.3.48 DE_FEATURE_LT_OFF (0x1068)

Same as DST_FEATURE_LT_OFF

Refer to DE_FEATURE_LT_VERY_FASTFLASHING


1.2.3.49 DE_FEATURE_LT_ON (0x1069)

Same as DST_FEATURE_LT_ON

Refer to DE_FEATURE_LT_VERY_FASTFLASHING


1.2.3.50 DE_FEATURE_LT_VERY_FASTFLASHING (0x106C)

Same as DST_FEATURE_LT_VERY_FASTFLASHING

Event Description:

The FEATURE light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING. Alcatel phones do not have function lights but present some symbols on the phone display instead. In such case the above events just indicate the state of these symbols.

Return Value:

dwSubReason | Non-Alcatel Phone | Alcatel Phone
 | Bit0-Bit7: Light Number Bit8=1 Green Light Bit9=1 Red Light Bit10=1 Amber Light Bit11-Bit31: Reserved | Bit0-Bit7: Symbol Number Bit8=1 Square, located on the right side of the display area Bit9=1 Music symbol Bit10=1 Square, located in the middle of the display area Bit11=1 Handset symbol Bit12=1 Square, located on the left side of the display area Bit13=1 Alert symbol Bit14-Bit31: Reserved


1.2.3.51 DE_FLASH_LT_FASTFLASHING (0x1196)

Same as DST_FLASH_LT_FASTFLASHING

Refer to DE_FLASH_LT_WINK


1.2.3.52 DE_FLASH_LT_FLASHING (0x1195)

Same as DST_FLASH_LT_FLASHING

Refer to DE_FLASH_LT_WINK


1.2.3.53 DE_FLASH_LT_MEDIUM_WINK (0x119B)

Same as DST_FLASH_LT_MEDIUM_WINK

Refer to DE_FLASH_LT_WINK


1.2.3.54 DE_FLASH_LT_OFF (0x1193)

Same as DST_FLASH_LT_OFF

Refer to DE_FLASH_LT_WINK


1.2.3.55 DE_FLASH_LT_ON (0x1194)

Same as DST_FLASH_LT_ON

Refer to DE_FLASH_LT_WINK


1.2.3.56 DE_FLASH_LT_QUICKFLASH (0x1198)

Same as DST_FLASH_LT_QUICKFLASH

Refer to DE_FLASH_LT_WINK


1.2.3.57 DE_FLASH_LT_SLOW_WINK (0x 119A)

Same as DST_FLASH_LT_SLOW_WINK

Refer to DE_FLASH_LT_WINK


1.2.3.58 DE_FLASH_LT_VERY_FASTFLASHING (0x1197)

Same as DST_FLASH_LT_VERY_FASTFLASHING

Refer to DE_FLASH_LT_WINK


1.2.3.59 DE_FLASH_LT_WINK (0x1199)

Same as DST_FLASH_LT_WINK

Event Description:

The FLASH light on the phone turns into one of the following states: ON, OFF, FLASHING, WINK, SLOW_WINK or MEDIUM_WINK, QUICKFLASH, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.60 DE_FUNC_LT_FASTFLASHING (0x100B)

Same as DST_FUNC_LT_FASTFLASHING

Refer to DE_FUNC_LT_WINK


1.2.3.61 DE_FUNC_LT_FLASHING (0x1003)

Same as DST_FUNC_LT_FLASHING

Refer to DE_FUNC_LT_WINK


1.2.3.62 DE_FUNC_LT_MEDIUM_WINK (0x114D)

Same as DST_FUNC_LT_MEDIUM_WINK

Refer to DE_FUNC_LT_WINK


1.2.3.63 DE_FUNC_LT_OFF (0x1002)

Same as DST_FUNC_LT_OFF

Refer to DE_FUNC_LT_WINK


1.2.3.64 DE_FUNC_LT_ON (0x1001)

Same as DST_FUNC_LT_ON

Refer to DE_FUNC_LT_WINK


1.2.3.65 DE_FUNC_LT_QUICKFLASH (0x1025)

Same as DST_FUNC_LT_ QUICKFLASH

Refer to DE_FUNC_LT_WINK


1.2.3.66 DE_FUNC_LT_VERY_FASTFLASHING (0x1033)

Same as DST_FUNC_LT_VERY_FASTFLASHING

Refer to DE_FUNC_LT_WINK


1.2.3.67 DE_FUNC_LT_WINK (0x114B)

Same as DST_ FUNC_LT_WINK

Event Description:

Function lights on the phone turn into one of the following states: ON, OFF, FLASHING, MEDIUM_WINK or WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING. Alcatel phones do not have function lights but present some symbols on the phone display instead. In such case the above events just indicate the state of these symbols.

Return Value:

dwSubReason | Non-Alcatel Phone | Alcatel Phone
 | Bit0-Bit7: Light Number Bit8=1 Green Light Bit9=1 Red Light Bit10=1 Amber Light Bit11-Bit31: Reserved | Bit0-Bit7: Symbol Number Bit8=1 Square, located on the right side of the display area Bit9=1 Music symbol Bit10=1 Square, located in the middle of the display area Bit11=1 Handset symbol Bit12=1 Square, located on the left side of the display area Bit13=1 Alert symbol Bit14-Bit31: Reserved


1.2.3.68 DE_GROUP_LT_FASTFLASHING (0x1179)

Same as DST_GROUP_LT_FASTFLASHING

Refer to DE_GROUP _LT_ON


1.2.3.69 DE_GROUP_LT_FLASHING (0x1178)

Same as DST_GROUP_LT_FLASHING

Refer to DE_GROUP _LT_ON


1.2.3.70 DE_GROUP_LT_OFF (0x1176)

Same as DST_GROUP_LT_OFF

Refer to DE_GROUP _LT_ON


1.2.3.71 DE_GROUP_LT_ON (0x1177)

Same as DST_GROUP_LT_ON

Event Description:

The GROUP light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.72 DE_HOLD_LT_FASTFLASHING (0x1083)

Same as DST_HOLD_LT_FASTFLASHING

Refer to DE_HOLD_LT_VERY_FASTFLASHING


1.2.3.73 DE_HOLD_LT_FLASHING (0x1082)

Same as DST_HOLD_LT_FLASHING

Refer to DE_HOLD_LT_VERY_FASTFLASHING


1.2.3.74 DE_HOLD_LT_OFF (0x1080)

Same as DST_HOLD_LT_OFF

Refer to DE_HOLD_LT_VERY_FASTFLASHING


1.2.3.75 DE_HOLD_LT_ON (0x1081)

Same as DST_HOLD_LT_ON

Refer to DE_HOLD_LT_VERY_FASTFLASHING


1.2.3.76 DE_HOLD_LT_VERY_FASTFLASHING (0x1084)

Same as DST_HOLD_LT_VERY_FASTFLASHING

Event Description:

The HOLD light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.77 DE_ICM_LT_FASTFLASHING (0x 126F)

Same as DST_ICM_LT_FASTFLASHING

Refer to DE_ICM_LT_WINK


1.2.3.78 DE_ICM_LT_FLASHING (0x126D)

Same as DST_ICM_LT_FLASHING

Refer to DE_ICM_LT_WINK


1.2.3.79 DE_ICM_LT_OFF (0x126B)

Same as DST_ICM_LT_OFF

Refer to DE_ICM_LT_WINK


1.2.3.80 DE_ICM_LT_ON (0x 126C)

Same as DST_ICM_LT_ON

Refer to DE_ICM_LT_WINK


1.2.3.81 DE_ICM_LT_WINK (0x126E)

Same as DST_ICM_LT_WINK

Event Description:

The ICM light on the phone turns into one of the following states: ON, OFF, FLASHING or WINK, FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.82 DE_MIC_LT_FASTFLASHING (0x107B)

Same as DST_MIC_LT_FASTFLASHING

Refer to DE_MIC_LT_VERY_FASTFLASHING


1.2.3.83 DE_MIC_LT_FLASHING (0x107A)

Same as DST_MIC_LT_FLASHING

Refer to DE_MIC_LT_VERY_FASTFLASHING


1.2.3.84 DE_MIC_LT_OFF (0x1078)

Same as DST_MIC_LT_OFF

Refer to DE_MIC_LT_VERY_FASTFLASHING


1.2.3.85 DE_MIC_LT_ON (0x1079)

Same as DST_MIC_LT_ON

Refer to DE_MIC_LT_VERY_FASTFLASHING


1.2.3.86 DE_MIC_LT_VERY_FASTFLASHING (0x107C)

Same as DST_MIC_LT_VERY_FASTFLASHING

Event Description:

The MIC (Microphone) light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.87 DE_MSG_LT_FASTFLASHING (0x10D3)

Same as DST_MSG_LT_FASTFLASHING

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.88 DE_MSG_LT_FLASHING (0x10D2)

Same as DST_MSG_LT_FLASHING

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.89 DE_MSG_LT_MEDIUM_WINK (0x 119F)

Same as DST_MSG_LT_MEDIUM_WINK

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.90 DE_MSG_LT_OFF (0x10D0)

Same as DST_MSG_LT_OFF

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.91 DE_MSG_LT_ON (0x10D1)

Same as DST_MSG_LT_ON

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.92 DE_MSG_LT_QUICKFLASH (0x10D5)

Same as DST_MSG_LT_QUICKFLASH

Refer to DE_MSG_LT_VERY_FASTFLASHING


1.2.3.93 DE_MSG_LT_VERY_FASTFLASHING (0x10D4)

Same as DST_MSG_LT_VERY_FASTFLASHING

Event Description:

The MSG (Message) light on the phone turns into one of the following states: ON, OFF, FLASHING or MEDIUM_WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.94 DE_MUTE_LT_FASTFLASHING (0x1121)

Same as DST_MUTE_LT_FASTFLASHING

Refer to DE_MUTE_LT_WINK


1.2.3.95 DE_MUTE_LT_FLASHING (0x1120)

Same as DST_MUTE_LT_FLASHING

Refer to DE_MUTE_LT_WINK


1.2.3.96 DE_MUTE_LT_OFF (0x111E)

Same as DST_MUTE_LT_OFF

Refer to DE_MUTE_LT_WINK


1.2.3.97 DE_MUTE_LT_ON (0x 111F)

Same as DST_MUTE_LT_ON

Refer to DE_MUTE_LT_WINK


1.2.3.98 DE_MUTE_LT_QUICKFLASH (0x1123)

Same as DST_MUTE_LT_QUICKFLASH

Refer to DE_MUTE_LT_WINK


1.2.3.99 DE_MUTE_LT_VERY_FASTFLASHING (0x1122)

Same as DST_MUTE_LT_VERY_FASTFLASHING

Refer to DE_MUTE_LT_WINK


1.2.3.100 DE_MUTE_LT_WINK (0x1124)

Same as DST_MUTE_LT_WINK

Event Description:

The MUTE light on the phone turns into one of the following states: ON, OFF, FLASHING or WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.101 DE_PAGE_LT_FASTFLASHING (0x110B)

Same as DST_PAGE_LT_FASTFLASHING

Refer to DE_PAGE_LT_VERY_FASTFLASHING


1.2.3.102 DE_PAGE_LT_FLASHING (0x 110A)

Same as DST_PAGE_LT_FLASHING

Refer to DE_PAGE_LT_VERY_FASTFLASHING


1.2.3.103 DE_PAGE_LT_OFF (0x1108)

Same as DST_PAGE_LT_OFF

Refer to DE_PAGE_LT_VERY_FASTFLASHING


1.2.3.104 DE_PAGE_LT_ON (0x1109)

Same as DST_PAGE_LT_ON

Refer to DE_PAGE_LT_VERY_FASTFLASHING


1.2.3.105 DE_PAGE_LT_VERY_FASTFLASHING (0x110C)

Same as DST_PAGE_LT_VERY_FASTFLASHING

Event Description:

The PAGE light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.106 DE_PROGRAM_LT_FASTFLASHING (0x10CB)

Same as DST_PROGRAM_LT_FASTFLASHING

Refer to DE_PROGRAM_LT_WINK


1.2.3.107 DE_PROGRAM_LT_FLASHING (0x10CA)

Same as DST_PROGRAM_LT_FLASHING

Refer to DE_PROGRAM_LT_WINK


1.2.3.108 DE_PROGRAM_LT_MEDIUM_WINK (0x10CF)

Same as DST_PROGRAM_LT_MEDIUM_WINK

Refer to DE_PROGRAM_LT_WINK


1.2.3.109 DE_PROGRAM_LT_OFF (0x 10C 8)

Same as DST_PROGRAM_LT_OFF

Refer to DE_PROGRAM_LT_WINK


1.2.3.110 DE_PROGRAM_LT_ON (0x 10C 9)

Same as DST_PROGRAM_LT_ON

Refer to DE_PROGRAM_LT_WINK


1.2.3.111 DE_PROGRAM_LT_QUICKFLASH (0x10CD)

Same as DST_PROGRAM_LT_QUICKFLASH

Refer to DE_PROGRAM_LT_WINK


1.2.3.112 DE_PROGRAM_LT_VERY_FASTFLASHING (0x10CC)

Same as DST_PROGRAM_LT_VERY_FASTFLASHING

Refer to DE_PROGRAM_LT_WINK


1.2.3.113 DE_PROGRAM_LT_WINK (0x10CE)

Same as DST_PROGRAM_LT_WINK

Event Description:

The PROGRAM light on the phone turns into one of the following states: ON, OFF, FLASHING, WINK or MEDIUM WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.114 DE_REDIAL_LT_FASTFLASHING (0x1103)

Same as DST_REDIAL_LT_FASTFLASHING

Refer to DE_REDIAL_LT_VERY_FASTFLASHING


1.2.3.115 DE_REDIAL_LT_FLASHING (0x1102)

Same as DST_REDIAL_LT_FLASHING

Refer to DE_REDIAL_LT_VERY_FASTFLASHING


1.2.3.116 DE_REDIAL_LT_OFF (0x1100)

Same as DST_REDIAL_LT_OFF

Refer to DE_REDIAL_LT_VERY_FASTFLASHING


1.2.3.117 DE_REDIAL_LT_ON (0x1101)

Same as DST_REDIAL_LT_ON

Refer to DE_REDIAL_LT_VERY_FASTFLASHING


1.2.3.118 DE_REDIAL_LT_VERY_FASTFLASHING (0x1104)

Same as DST_REDIAL_LT_VERY_FASTFLASHING

Event Description:

The REDIAL Light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.119 DE_RING_LT_FASTFLASHING (0x10BB)

Same as DST_RING_LT_FASTFLASHING


1.2.3.120 DE_RING_LT_FLASHING (0x10BA)

Same as DST_RING_LT_FLASHING


1.2.3.121 DE_RING_LT_OFF (0x10B8)

Same as DST_RING_LT_OFF


1.2.3.122 DE_RING_LT_ON (0x10B9)

Same as DST_RING_LT_ON

Refer to DE_RING_LT_VERY_FASTFLASHING


1.2.3.123 DE_RING_LT_QUICKFLASH (0x10BD)

Same as DST_RING_LT_QUICKFLASH

Refer to DE_RING_LT_VERY_FASTFLASHING


1.2.3.124 DE_RING_LT_VERY_FASTFLASHING (0x10BC)

Same as DST_RING_LT_VERY_FASTFLASHING

Event Description:

The RING light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.125 DE_SCROLL_LT_FASTFLASHING (0x118B)

Same as DST_SCROLL_LT_FASTFLASHING

Refer to DE_SCROLL_LT_ON


1.2.3.126 DE_SCROLL_LT_FLASHING (0x 118A)

Same as DST_SCROLL_LT_FLASHING

Refer to DE_SCROLL_LT_ON


1.2.3.127 DE_SCROLL_LT_OFF (0x1188)

Same as DST_SCROLL_LT_OFF

Refer to DE_SCROLL_LT_ON


1.2.3.128 DE_SCROLL_LT_ON (0x1189)

Same as DST_SCROLL_LT_ON

Event Description:

The SCROLL light on the phone turns into one of the following states: ON, OFF, FLASHING, FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.129 DE_SOFT_LT_FASTFLASHING (0x10EB)

Same as DST_SOFT_LT_FASTFLASHING

Refer to DE_SOFT_LT_ON


1.2.3.130 DE_SOFT_LT_OFF (0x10E8)

Same as DST_SOFT_LT_OFF

Refer to DE_SOFT_LT_ON


1.2.3.131 DE_SOFT_LT_ON (0x10E9)

Same as DST_SOFT_LT_ON

Event Description:

The SOFT light on the phone turns into one of the following states: ON, OFF, FASTFLASHING

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.132 DE_SPEAKER_LT_FASTFLASHING (0x1073)

Same as DST_SPEAKER_LT_FASTFLASHING

Refer to DE_SPEAKER_LT_WINK


1.2.3.133 DE_SPEAKER_LT_FLASHING (0x1072)

Same as DST_SPEAKER_LT_FLASHING

Refer to DE_SPEAKER_LT_WINK


1.2.3.134 DE_SPEAKER_LT_MEDIUM_WINK (0x119E)

Same as DST_SPEAKER_LT_MEDIUM_WINK

Refer to DE_SPEAKER_LT_WINK


1.2.3.135 DE_SPEAKER_LT_OFF (0x1070)

Same as DST_SPEAKER_LT_OFF

Refer to DE_SPEAKER_LT_WINK


1.2.3.136 DE_SPEAKER_LT_ON (0x1071)

Same as DST_SPEAKER_LT_ON

Refer to DE_SPEAKER_LT_WINK


1.2.3.137 DE_SPEAKER_LT_QUICKFLASH (0x1075)

Same as DST_SPEAKER_LT_QUICKFLASH

Refer to DE_SPEAKER_LT_WINK


1.2.3.138 DE_SPEAKER_LT_VERY_FASTFLASHING (0x1074)

Same as DST_SPEAKER_LT_VERY_FASTFLASHING

Refer to DE_SPEAKER_LT_WINK


1.2.3.139 DE_SPEAKER_LT_WINK (0x1076)

Same as DST_SPEAKER_LT_WINK

Event Description:

The SPEAKER light on the phone turns into one of the following states: ON, OFF, FLASHING, MEDIUM_WINK or WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.140 DE_SPEEDDIAL_LT_FASTFLASHING (0x11A3)

Same as DST_SPEEDDIAL_LT_FASTFLASHING

Refer to DE_SPEEDDIAL_LT_WINK


1.2.3.141 DE_SPEEDDIAL_LT_FLASHING (0x11A2)

Same as DST_SPEEDDIAL_LT_FLASHING


1.2.3.142 DE_SPEEDDIAL_LT_MEDIUM_WINK (0x11A8)

Same as DST_SPEEDDIAL_LT_MEDIUM_WINK


1.2.3.143 DE_SPEEDDIAL_LT_OFF (0x11A0)

Same as DST_SPEEDDIAL_LT_OFF


1.2.3.144 DE_SPEEDDIAL_LT_ON (0x11A1)

Same as DST_SPEEDDIAL_LT_ON


1.2.3.145 DE_SPEEDDIAL_LT_QUICKFLASH (0x11A5)

Same as DST_SPEEDDIAL_LT_QUICKFLASH


1.2.3.146 DE_SPEEDDIAL_LT_SLOW_WINK (0x11A7)

Same as DST_SPEEDDIAL_LT_SLOW_WINK


1.2.3.147 DE_SPEEDDIAL_LT_VERY_FASTFLASHING (0x11A4)

Same as DST_SPEEDDIAL_LT_ VERY_FASTFLASHING


1.2.3.148 DE_SPEEDDIAL_LT_WINK (0x11A6)

Same as DST_SPEEDDIAL_LT_WINK

Event Description:

The SPEEDDIAL light on the phone turns into one of the following states: ON, OFF, FLASHING, MEDIUM_WINK, SLOW_WINK or WINK, FASTFLASHING, QUICKFLASH, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.3.149 DE_TRANSFER_LT_FASTFLASHING (0x10DB)

Same as DST_TRANSFER_LT_FASTFLASHING

Refer to DE_TRANSFER_LT_WINK


1.2.3.150 DE_TRANSFER_LT_FLASHING (0x10DA)

Same as DST_TRANSFER_LT_FLASHING

Refer to DE_TRANSFER_LT_WINK


1.2.3.151 DE_TRANSFER_LT_OFF (0x10D8)

Same as DST_TRANSFER_LT_OFF

Refer to DE_TRANSFER_LT_WINK


1.2.3.152 DE_TRANSFER_LT_ON (0x10D9)

Same as DST_TRANSFER_LT_ON

Refer to DE_TRANSFER_LT_WINK


1.2.3.153 DE_TRANSFER_LT_VERY_FASTFLASHING (0x10DC)

Same as DST_TRANSFER_LT_VERY_FASTFLASHING

Refer to DE_TRANSFER_LT_WINK


1.2.3.154 DE_TRANSFER_LT_WINK (0x10DE)

Same as DST_TRANSFER_LT_WINK

Event Description:

The TRANSFER light on the phone turns into one of the following states: ON, OFF, FLASHING or WINK, FASTFLASHING, VERY_FASTFLASHING.

Return Value:

dwSubReason

Bit0-Bit7: Light Number

Bit8=1 Green Light

Bit9=1 Red Light

Bit10=1 Amber Light

Bit11-Bit31: Reserved


1.2.4 LCD Events

In most systems, the PBX will send instructions to the phone as a command to update the information displayed on the LCD.

However, to certain phone models, when some buttons are operated, the information displayed on the LCD is updated by the phone itself and not controlled by the PBX. In such case, the phone does not report the display update to the PBX so that the DST boards can not report the LCD event to the application.


1.2.4.1 DE_DISPLAY_CLEAR (0x 102A)

Same as DST_DISPLAY_CLEAR

Event Description:

The PBX commands the phone to clear the LCD display.

Return Value:

Nil


1.2.4.2 DE_DISPLAY_CLOCK (0x1028)

Same as DST_DISPLAY_CLOCK

Event Description:

The PBX orders the phone to update the displayed time (usually including the date).

Return Value:

* pvBuffer

a pointer to the tm structure storing the date and the time


1.2.4.3 DE_DISPLAY_MSG (0x104B)

Same as DST_DISPLAY_MSG

Event Description:

The PBX commands the phone to display a message which is saved in the phone’s memory. Actually it is not the message data but the message ID displayed on the LCD. Refer to the concerned PBX chapter for the message represented by each ID.

Return Value:

dwSubReason

message ID


1.2.4.4 DE_DISPLAY_TIMER (0x1029)

Same as DST_DISPLAY_TIMER

Event Description:

The PBX orders the phone to update the timer which measures call duration.

Return Value:

Nil


1.2.4.5 DE_MSG_CHG (0x1008)

Same as DST_MSG_CHG

Event Description:

The phone receives the information from the PBX and displays it on the LCD. In most PBX systems, both the calling and called party numbers can be separated from the information stored in strings by some algorithms.

Return Value:

*pvBuffer | a pointer to the buffer which holds the information to be displayed in strings
dwDataLength | the size of the data buffer pointed to by pvBuffer (including the null character terminator)


1.2.5 Call State Events


1.2.5.1 DE_ABANDONED (0x103A)

Same as DST_ABANDONED

Event Description:

The remote end abandons the call. It usually occurs when the remote end first hangs up the phone.

Return Value:

Nil


1.2.5.2 DE_AUTO_ANSWER (0x102D)

Same as DST_AUTO_ANSWER

Event Description:

The auto-answer feature is activated.

Return Value:

Nil


1.2.5.3 DE_AUTO_ANSWER_CANCELED (0x102E)

Same as DST_AUTO_ANSWER_CANCELED

Event Description:

The auto-answer feature is deactivated.

Return Value:

Nil


1.2.5.4 DE_CFWD (0x102B)

Same as DST_CFWD

Event Description:

Call forwarding is activated.

Return Value:

*pvBuffer | a pointer to the buffer which contains the phone number that the call is forwarded to
dwDataLength | the size of the buffer pointed to by pvBuffer (including the null character terminator)


1.2.5.5 DE_CFWD_CANCELED (0x102C)

Same as DST_CFWD_CANCELED

Event Description:

Call forwarding is deactivated.

Return Value:

Nil


1.2.5.6 DE_SET_BUSY (0x102F)

Same as DST_SET_BUSY

Event Description:

Sets to be busy

Return Value:

Nil


1.2.5.7 DE_SET_BUSY_CANCELED (0x1030)

Same as DST_SET_BUSY_CANCELED

Event Description:

Busy setting is cancelled.

Return Value:

Nil


1.2.5.8 DE_CISCO_SCCP_CALL_INFO (0x1280)

Event Description:

Call information based on the CISCO SCCP protocol.

Return Value:

Return the structure IPR_CISCO_SCCP_CALL_INFO

Structure and Relative Macro Definition:

#define IPR_CISCO_SCCP_MAX_NAME_SIZE 40

#define IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE 24

typedef struct tagIPR_CISCO_SCCP_CALL_INFO

{

UCHAR CallingPartyName[IPR_CISCO_SCCP_MAX_NAME_SIZE]; //Calling party name

UCHAR CallingParty[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Calling party number

UCHAR CalledPartyName[IPR_CISCO_SCCP_MAX_NAME_SIZE]; //Called party name

UCHAR CalledParty[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Called party number

ULONG LineInstance; //Phone line indicator

ULONG CallId; // Call index

ULONG CallType; // Call direction

UCHAR OrigCalledPartyName[IPR_CISCO_SCCP_MAX_NAME_SIZE]; //Original called party name

UCHAR OrigCalledParty[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]

//Original called party number

UCHAR LastRedirectingPartyName[IPR_CISCO_SCCP_MAX_NAME_SIZE]; //Last redirecting party name

UCHAR LastRedirectingParty[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE];

//Last redirecting party number

ULONG OrigCalledPartyRedirectReason; //Original redirect reason

ULONG LastRedirectReason; //Last redirect reason

UCHAR CallingPartyVoiceMailbox[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Calling party’s voice mailbox

UCHAR CalledPartyVoiceMailbox[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Called party’s voice mailbox

UCHAR OriginalCalledPartyVoiceMailbox[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Original called party’s voice mailbox

UCHAR LastRedirectVoiceMailbox[IPR_CISCO_SCCP_MAX_DIRECTORY_NUM_SIZE]; //Last redirect’s voice mailbox

ULONG CallInstance; //Call number for calls on a same telephone

}IPR_CISCO_SCCP_CALL_INFO, *PIPR_CISCO_SCCP_CALL_INFO;


1.2.5.9 DE_CALLSTATE_IDLE (0x1304)

Event Description:

Indicates the call state ‘Idle’.

Return Value:

Nil


1.2.5.10 DE_CALLSTATE_DIALING (0x1306)

Event Description:

Indicates the call state ‘Dialing’.

Return Value:

Nil


1.2.5.11 DE_CALLSTATE_ALERTING (0x1307)

Event Description:

Indicates the call state ‘Ringing’.

Return Value:

Nil


1.2.5.12 DE_CALLSTATE_FAR_END_RINGBACK (0x1308)

Event Description:

Indicates the call state ‘Ringback (from remote end)’.

Return Value:

Nil


1.2.5.13 DE_CALLSTATE_TALK (0x1309)

Event Description:

Indicates the call state ‘Talking’.

Return Value:

Nil


1.3 Phone Events


1.3.1 HOOK Events


1.3.1.1 DE_OFFHOOK (0x8)

Same as DST_OFFHOOK

Event Description:

The handset is picked up (off-hook).

Return Value:

Nil


1.3.1.2 DE_ONHOOK (0xe)

Same as DST_ONHOOK

Event Description:

The handset is placed down (on-hook).

Return Value:

Nil


1.3.2 Button Events

Whenever the buttons on the phone are operated, the DST boards will report corresponding button events to the application. If it is a specific function button, e.g. the Hold button, the DE_HOLD_BTN_PRS/RLS (DST_HOLD_BTN_PRS/RLS) will be reported; if it is a configurable function button, then the DE_FUNC_BTN_PRS/RLS (DST_FUNC_BTN_PRS/RLS) event will be reported. There are many types of button events as described below.

² Line button events: The Line button on the phone is used to answer an inbound call or start an outbound call.

² Fixed button events: The Fixed button on the phone corresponds to a certain feature, such as Hold or Speaker.


1.3.2.1 DE_ANSWER_BTN_PRS (0x1015)

Same as DST_ANSWER_BTN_PRS

Event Description:

The Answer button on the phone is pressed.

Return Value:

Nil


1.3.2.2 DE_CALLBACK_BTN_PRS (0x1191)

Same as DST_CALLBACK_BTN_PRS

Event Description:

The CALLBACK button on the phone is pressed

Return Value:

Nil


1.3.2.3 DE_CALLBACK_BTN_RLS (0x1192)

Same as DST_CALLBACK_BTN_RLS

Event Description:

The CALLBACK button on the phone is released

Return Value:

Nil


1.3.2.4 DE_CANCEL_BTN_PRS (0x1110)

Same as DST_CANCEL_BTN_PRS

Event Description:

The CANCEL button on the phone is pressed.

Return Value:

Nil


1.3.2.5 DE_CLEAR_BTN_PRS (0x1169)

Same as DST_CLEAR_BTN_PRS

Event Description:

The Clear button on the phone is pressed.

Return Value:

Nil


1.3.2.6 DE_CONF_BTN_PRS (0x1018)

Same as DST_CONF_BTN_PRS

Event Description:

The Conference button on the phone is pressed.

Return Value:

Nil


1.3.2.7 DE_CONF_BTN_RLS (0x1037)

Same as DST_CONF_BTN_RLS

Event Description:

The Conference button on the phone is released.

Return Value:

Nil


1.3.2.8 DE_CTRL_BTN_PRS (0x110E)

Same as DST_CTRL_BTN_PRS

Event Description:

The Ctrl button on the phone is pressed.

Return Value:

Nil


1.3.2.9 DE_CTRL_BTN_RLS (0x110F)

Same as DST_CTRL_BTN_RLS

Event Description:

The Ctrl button on the phone is released.

Return Value:

Nil


1.3.2.10 DE_DGT_PRS (0x1006)

Same as DST_DGT_PRS

Event Description:

A digit button (usually ‘0~9, *, #’) on the phone is pressed.

Return Value:

dwSubReason

Bits0-7 : ASCII code value of the button

Bits8-31: Reserved


1.3.2.11 DE_DGT_RLS (0x1007)

Same as DST_DGT_RLS

Event Description:

A digit button (usually ‘0~9, *, #’) on the phone is released.

Return Value:

dwSubReason

Bits0-7: ASCII code value of the button

Bits8-31: Reserved


1.3.2.12 DE_DIRECTORY_BTN_PRS (0x1116)

Same as DST_DIRECTORY_BTN_PRS

Event Description:

The DIRECTORY button on the phone is pressed.

Return Value:

Nil


1.3.2.13 DE_DIVERT_BTN_PRS (0x115F)

Same as DST_DIVERT_BTN_PRS

Event Description:

The DIVERT button on the phone is pressed

Return Value:

Nil


1.3.2.14 DE_DND_BTN_PRS (0x1165)

Same as DST_DND_BTN_PRS

Event Description:

The DND (do not disturb) button on the phone is pressed

Return Value:

Nil


1.3.2.15 DE_DND_BTN_RLS (0x1166)

Same as DST_DND_BTN_RLS

Event Description:

The DND (do not disturb) button on the phone is released

Return Value:

Nil


1.3.2.16 DE_ENTER_BTN_PRS (0x1167)

Same as DST_ENTER_BTN_PRS

Event Description:

The Enter button on the phone is pressed.

Return Value:

Nil


1.3.2.17 DE_EXIT_BTN_PRS (0x101C)

Same as DST_EXIT_BTN_PRS

Event Description:

The Exit button on the phone is pressed.

Return Value:

Nil


1.3.2.18 DE_FEATURE_BTN_PRS (0x101A)

Same as DST_FEATURE_BTN_PRS

Event Description:

The Feature button on the phone is pressed.

Return Value:

Nil


1.3.2.19 DE_FLASH_BTN_PRS (0x1114)

Same as DST_FLASH_BTN_PRS

Event Description:

The FLASH button on the phone is pressed.

Return Value:

Nil


1.3.2.20 DE_FLASH_BTN_RLS (0x1115)

Same as DST_FLASH_BTN_RLS

Event Description:

The FLASH button on the phone is released.

Return Value:

Nil


1.3.2.21 DE_FUNC_BTN_PRS (0x100E)

Same as DST_FUNC_BTN_PRS

Event Description:

A function button on the phone is pressed. Actually, function buttons vary on different phone models. On some phones, they are configurable. The DST boards number the buttons for all supported phone models. Refer to the phone map illustrated in each PBX chapter for details.

Return Value:

dwSubReason

Bits0-7: Function button number (0-255)

Bits8-31: Reserved


1.3.2.22 DE_FUNC_BTN_RLS (0x100F)

Same as DST_FUNC_BTN_RLS

Event Description:

A function button on the phone is released.

Return Value:

dwSubReason

Bits0-7: Function button number (0-255)

Bits8-31: Reserved


1.3.2.23 DE_GROUP_BTN_PRS (0x1161)

Same as DST_GROUP_BTN_PRS

Event Description:

The GROUP button on the phone is pressed

Return Value:

Nil


1.3.2.24 DE_HELP_BTN_PRS (0x101D)

Same as DST_HELP_BTN_PRS

Event Description:

The HELP button on the phone is pressed.

Return Value:

Nil


1.3.2.25 DE_HOLD_BTN_PRS (0x1010)

Same as DST_HOLD_BTN_PRS

Event Description:

The Hold button on the phone is pressed.

Return Value:

Nil


1.3.2.26 DE_HOLD_BTN_RLS (0x1011)

Same as DST_HOLD_BTN_RLS

Event Description:

The Hold button on the phone is released.

Return Value:

Nil


1.3.2.27 DE_ICM_BTN_PRS (0x1270)

Same as DST_ICM_BTN_PRS

Event Description:

The ICM button on the phone is pressed.

Return Value:

Nil


1.3.2.28 DE_ICM_BTN_RLS (0x1271)

Same as DST_ICM_BTN_RLS

Event Description:

The ICM button on the phone is released.

Return Value:

Nil


1.3.2.29 DE_INTERCOM_BTN_PRS (0x11AD)

Same as DST_INTERCOM_BTN_PRS

Event Description:

The Intercom button on the phone is pressed.

Return Value:

Nil


1.3.2.30 DE_INTERCOM_BTN_RLS (0x11AE)

Same as DST_INTERCOM_BTN_RLS

Event Description:

The Intercom button on the phone is released.

Return Value:

Nil


1.3.2.31 DE_LINE_BTN_PRS (0x1021)

Same as DST_LINE_BTN_PRS

Event Description:

The Line button on the phone is pressed.

Return Value:

Nil


1.3.2.32 DE_MENU_BTN_PRS (0x1022)

Same as DST_MENU_BTN_PRS

Event Description:

The Menu button on the phone is pressed.

Return Value:

Nil


1.3.2.33 DE_MIC_BTN_PRS (0x1112)

Same as DST_MIC_BTN_PRS

Event Description:

The MIC (Microphone) button on the phone is pressed.

Return Value:

Nil


1.3.2.34 DE_MIC_BTN_RLS (0x1113)

Same as DST_MIC_BTN_RLS

Event Description:

The MIC (Microphone) button on the phone is released.

Return Value:

Nil


1.3.2.35 DE_MODE_BTN_PRS (0x119C)

Same as DST_MODE_BTN_PRS

Event Description:

The Mode button on the phone is pressed.

Return Value:

Nil


1.3.2.36 DE_MODE_BTN_RLS (0x119D)

Same as DST_MODE_BTN_RLS

Event Description:

The Mode button on the phone is released.

Return Value:

Nil


1.3.2.37 DE_MSG_BTN_PRS (0x1040)

Same as DST_MSG_BTN_PRS

Event Description:

The MSG (message) button on the phone is pressed.

Return Value:

Nil


1.3.2.38 DE_MUTE_BTN_PRS (0x104F)

Same as DST_MUTE_BTN_PRS

Event Description:

The MUTE button on the phone is pressed.

Return Value:

Nil


1.3.2.39 DE_MUTE_BTN_RLS (0x11F4)

Same as DST_MUTE_BTN_RLS

Event Description:

The MUTE button on the phone is released.

Return Value:

Nil


1.3.2.40 DE_NEXT_BTN_PRS (0x1024)

Same as DST_NEXT_BTN_PRS

Event Description:

The Next button on the phone is pressed.

Return Value:

Nil


1.3.2.41 DE_PAGE_BTN_PRS (0x1057)

Same as DST_PAGE_BTN_PRS

Event Description:

The PAGE button on the phone is pressed.

Return Value:

Nil


1.3.2.42 DE_PAUSE_BTN_PRS (0x11AB)

Same as DST_PAUSE_BTN_PRS

Event Description:

The Pause button on the phone is pressed.

Return Value:

Nil


1.3.2.43 DE_PAUSE_BTN_RLS (0x11AC)

Same as DST_PAUSE_BTN_RLS

Event Description:

The Pause button on the phone is released.

Return Value:

Nil


1.3.2.44 DE_PREVIOUS_BTN_PRS (0x1023)

Same as DST_PREVIOUS_BTN_PRS

Event Description:

The Previous button on the phone is pressed.

Return Value:

Nil


1.3.2.45 DE_PROGRAM_BTN_PRS (0x104E)

Same as DST_PROGRAM_BTN_PRS

Event Description:

The PROGRAM button on the phone is pressed

Return Value:

Nil


1.3.2.46 DE_RECALL_BTN_PRS (0x1019)

Same as DST_RECALL_BTN_PRS

Event Description:

The Recall button on the phone is pressed.

Return Value:

Nil


1.3.2.47 DE_REDIAL_BTN_PRS (0x1017)

Same as DST_REDIAL_BTN_PRS

Event Description:

The Redial button on the phone is pressed.

Return Value:

Nil


1.3.2.48 DE_REDIAL_BTN_RLS (0x1035)

Same as DST_REDIAL_BTN_RLS

Event Description:

The Redial button on the phone is released.

Return Value:

Nil


1.3.2.49 DE_RELEASE_BTN_PRS (0x1012)

Same as DST_RELEASE_BTN_PRS

Event Description:

The Release button on the phone is pressed.

Return Value:

Nil


1.3.2.50 DE_RELEASE_BTN_RLS (0x1013)

Same as DST_RELEASE_BTN_RLS

Event Description:

The Release button on the phone is released.

Return Value:

Nil


1.3.2.51 DE_SCROLL_BTN_PRS (0x115D)

Same as DST_SCROLL_BTN_PRS

Event Description:

The SCROLL button on the phone is pressed.

Return Value:

Nil


1.3.2.52 DE_SCROLL_BTN_RLS (0x115E)

Same as DST_SCROLL_BTN_RLS

Event Description:

The SCROLL button on the phone is released.

Return Value:

Nil


1.3.2.53 DE_SELECT_BTN_PRS (0x11A9)

Same as DST_SELECT_BTN_PRS

Event Description:

The Select button on the phone is pressed.

Return Value:

Nil


1.3.2.54 DE_SELECT_BTN_RLS (0x11AA)

Same as DST_SELECT_BTN_RLS

Event Description:

The Select button on the phone is released.

Return Value:

Nil


1.3.2.55 DE_SHIFT_BTN_PRS (0x1055)

Same as DST_SHIFT_BTN_PRS

Event Description:

The Shift button on the phone is pressed.

Return Value:

Nil


1.3.2.56 DE_SHIFT_BTN_RLS (0x1056)

Same as DST_SHIFT_BTN_RLS

Event Description:

The Shift button on the phone is released.

Return Value:

Nil


1.3.2.57 DE_SOFT_BTN_PRS (0x101E)

Same as DST_SOFT_BTN_PRS

Event Description:

A Soft button on the phone is pressed. These buttons are usually located around the LCD. The phone uses the built-in software to define the function of these buttons and display the information on the LCD. That is, these buttons are programmable for different functions. That’s why they are named as Soft buttons. The DST boards number these buttons for all supported phone models. See the phone map illustrated in each PBX chapter for details.

Return Value:

dwSubReason

Bits0-7: Soft button number (0-255)

Bits8-31: Reserved


1.3.2.58 DE_SOFT_BTN_RLS (0x1059)

Same as DST_SOFT_BTN_RLS

Event Description:

The Soft button on the phone is released.

Return Value:

Nil


1.3.2.59 DE_SPEAKER_BTN_PRS (0x1016)

Same as DST_SPEAKER_BTN_PRS

Event Description:

The Speaker/HandFree button on the phone is pressed.

Return Value:

Nil


1.3.2.60 DE_SPEAKER_BTN_RLS (0x1034)

Same as DST_SPEAKER_BTN_RLS

Event Description:

The Speaker/HandFree button on the phone is released.

Return Value:

Nil


1.3.2.61 DE_SPEEDDIAL_BTN_PRS (0x1163)

Same as DST_SPEEDDIAL_BTN_PRS

Event Description:

The SPEEDDIAL button on the phone is pressed

Return Value:

Nil


1.3.2.62 DE_SPEEDDIAL_BTN_RLS (0x1164)

Same as DST_SPEEDDIAL_BTN_RLS

Event Description:

The SPEEDDIAL button on the phone is released

Return Value:

Nil


1.3.2.63 DE_TRANSFER_BTN_PRS (0x1014)

Same as DST_TRANSFER_BTN_PRS

Event Description:

The Transfer button on the phone is pressed.

Return Value:

Nil


1.3.2.64 DE_TRANSFER_BTN_RLS (0x1036)

Same as DST_TRANSFER_BTN_RLS

Event Description:

The Transfer button on the phone is released

Return Value:

Nil


1.3.2.65 DE_SPEEDDIAL_NUMBER (0x130a)

Event Description:

Sends the number information contained within the Speed dial number.

Return Value:

*pvBuffer | a pointer to the buffer which holds the information to be displayed in strings
dwDataLength | the size of the data buffer pointed to by pvBuffer (including the null character terminator)


1.4 ISDN BRI Events


1.4.1 DE_CALL_ABANDONED (0x75)

Same as DST_CALL_ABANDONED

Event Description:

The calling party abandons the call.

Return Value:

Nil


1.4.2 DE_CALL_ALERTING (0x6E)

Same as DST_CALL_ALERTING

Event Description:

The call turns into the RINGING state.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.3 DE_CALL_CONNECTED (0x6F)

Same as DST_CALL_CONNECTED

Event Description:

The call turns into the CONNECTED state.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.4 DE_CALL_HELD (0x73)

Same as DST_CALL_HELD

Event Description:

The call turns into the HELD state.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.5 DE_CALL_IN_PROGRESS (0x6B)

Same as DST_CALL_IN_PROGRESS

Event Description:

The call progress.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.6 DE_CALL_REJECTED (0x76)

Same as DST_CALL_REJECTED

Event Description:

The called party rejects the call.

Return Value:

Nil


1.4.7 DE_CALL_RELEASED (0x70)

Same as DST_CALL_RELEASED

Event Description:

Request for call release.

Return Value:

Nil


1.4.8 DE_CALL_RESUMED (0x72)

Same as DST_CALL_RESUMED

Event Description:

Request for call resume.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.9 DE_CALL_RETRIEVED (0x74)

Same as DST_CALL_RETRIEVED

Event Description:

The call retrieves from the HELD state.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


1.4.10 DE_CALL_SUSPENDED (0x71)

Same as DST_CALL_SUSPENDED

Event Description:

Request for call suspend.

Return Value:

*pvBuffer | a pointer to the string of the calling and called party numbers (calling party number + called party number, spaced by ’\n’)
dwDataLength | the size of the string of the calling and called party numbers (including the null character terminator)
dwSubReason | indicates the call direction 1: Inbound 2: Outbound


Chapter 2 Programming with D-channel Events


2.1 Application-defined Call State Machine

The application should establish a call state machine for itself according to the feature of a specific PBX phone system, and then use some D-channel events as state transition conditions for accurate control over the start/stop of the recording and the rest to record the complete operation on the phone.


2.2 Non D-channel Events

In some systems, there are no corresponding messages on the D-channel to report the events which have effects on the call state transition, such as those indicating the appearance of busy tone, ringback tone, etc. Under such circumstance, the SynCTI driver will report such events as E-CHG_BusyTone instead of D-channel events to the user software. For more information, refer to the ‘Tone Detector’ section in Chapter 1 of SynCTI Programmer's Manual.

Some phone models do not generate D-channel events when their digit buttons are pressed, but directly produce DTMF signals on the B-channel, like analog phones. In this case, the E_CHG_RcvDTMF event is used to obtain the button state as well as the caller ID, instead of D-channel events.


2.3 State Machine Example

Below illustrates a call state machine involving D-channel events for your reference. The application environment may vary on different PBX models, configurations, software versions as well as phone models. And D-channel events, number of states and transition conditions all differ in various systems. Therefore, developers should carefully observe and analyze all D-channel events generated under a particular circumstance and design a specific call state machine to meet their own requirement.

The table below describes all state transition conditions which may correspond to different D-channel events under different PBX systems.

Call State Start→End | Description
Outbound Call |
Idle→Waiting | Request: The calling party initiates a call and waits for the line seizure acknowledgement (i.e. the dial tone in most situations) from the PBX.
Waiting →Idle | Abandoned: The calling party abandons the call.
Waiting →Dial | Acknowledged: Receives the line seizure acknowledgement from the PBX (i.e. the dial tone in most situations).
Waiting →Active | Connected: It is a special case where an inbound call comes just when the calling party initiates a call.
Dial→Ringback | Called Party Response: The called end rings upon detection of the inbound call and sends the ringback tone to the calling party.
Dial→Idle | Abandoned: The calling party abandons the call before the called party responds to it.
Dial→Active | Connected: It is a special case where an inbound call comes while the calling party is dialing.
Ringback→Idle | Abandoned: The calling party abandons the call before the called party answers.
Ringback→Active | Connected: The call is connected.
Active→Idle | Released: The call is released
Active→Hold | Hold: The call is put on hold.
Active→Transfer | Transfer: The call is transferred.
Hold→Idle | Abandoned/Released: If the called party hangs up first, the call is abandoned; if the calling party hangs up first, the call is released.
Hold→Active | Resumed: The call on hold is resumed.
Transfer→Idle | Abandoned/Released: If the called party hangs up first, the call is abandoned; if the calling party hangs up first, the call is released.
Inbound call |
Idle→Ringing | Ringing: Usually the phone rings when there comes an inbound call.
Ringing→Idle | Abandoned or Rejected: The call is abandoned by the remote end or rejected by the local end.
Ringing→Active | Connected: The call is connected.


2.4 Time to Start/Stop Recording

Most phones have handsets and will report corresponding events when they are picked up or hung up to the application. Therefore, the application can start recording upon reception of the DE_OFFHOOK (DST_OFFHOOK) event and stop it upon reception of DE_ONHOOK (DST_ONHOOK).

However, phones used in most call centers do not have handsets and thus the DST board can not report Hook events to the application. Hence other methods shall be used to determine the time for recording, such as by monitoring the DE_AUDIO_CHG (DST_AUDIO_CHG) event which helps the PBX to change the state of the Speaker and/or Microphone, or; by monitoring some special Button events such as DE_LINE_BTN_PRS (DST_LINE_BTN_PRS) and DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS), the operations which correspond to are similar to the pickup and hangup behavior.

Note: For detailed information about event programming modes, refer to Section 1.14.1 ‘Setting Event Output Mode’ in SynCTI Programmer’s Manual.


Chapter 3 Siemens Hicom/Hipath


3.1 Configuration

l Run ShCtiConfig.exe to update board firmware

Write the updated PBX model - Siemens Hicom/Hipath into the DST board firmware. This update once written will be long kept in the board, not to be lost even during power outage. Refer to ShCtiConfig.exe User Manual for details.

l Configure the driver’s runtime environment (through the file Shconfig.ini)

Ø PBXType – set to Siemens Hicom/Hipath.

Ø PhoneType – select the correct value from the ‘DST Series Supported PBX Models’ section in Chapter 1 of SynCTI Programmer's Manual.

Ø DefaultVoiceFormat – usually the Siemens Hipath PBX uses A-law codec and this configuration item should be set to 6 for it; the Siemens Hicom PBX uses μ-Law and this item should be set to 7 for it.


3.2 D-Channel Events

All D-channel events generated in this system are listed below, grouped by event type. These events vary depending on the particular configuration of the PBX as well as the phone model involved in the system. We do not guarantee that all the following events are reported in each system.

l PBX Events

Ø Ring Events

² DE_RING_OFF (DST_RING_OFF)

² DE_RING_ON (DST_RING_ON)

Ø Audio Events

² DE_AUDIO_CHG (DST_AUDIO_CHG)

Ø LED Events

² DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING)

² DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING)

² DE_FUNC_LT_ON (DST_FUNC_LT_ON)

² DE_FUNC_LT_OFF (DST_FUNC_LT_OFF)

² DE_FUNC_LT_QUICKFLASH (DST_FUNC_LT_QUICKFLASH)

² DE_FUNC_LT_VERY_FASTFLASHING (DST_FUNC_LT_VERY_FASTFLASHING)

Ø LCD Events

² DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR)

² DE_DISPLAY_CLOCK (DST_DISPLAY_CLOCK)

² DE_MSG_CHG (DST_MSG_CHG)

l Phone Events

Ø HOOK Events

² DE_OFFHOOK (DST_OFFHOOK)

² DE_ONHOOK (DST_ONHOOK)

Ø Button Events

² DE_DGT_PRS (DST_DGT_PRS)

² DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)

² DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS)

² DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS)


3.3 Siemens Hicom/Hipath Behavior

Each PBX has its own behaviors. This section demonstrates the common behaviors performed by the Siemens Hicom/Hipath.

l Dialed Number (DTMF) Detection

When the digits on the phone are pressed, a corresponding message will be passed over the D-channel and the DE_DGT_PRS (DST_DGT_PRS) event will be reported to the application almost at the same time. When the B-channel obtains DTMF from either direction, the signals will be detected by the DTMF detector on the DST board and the E_CHG_RcvDTMF event will be reported.

l Calling & Called Party Numbers

Usually, both the calling and called party numbers are passed over the D-channel and can be gained by the application via the DE_MSG_CHG (DST_MSG_CHG) event, which contains the parameters representing the displayed information stings and the size. Note that these strings are stored in ASCII format so that the calling and called party numbers only can be separated by using some algorithms.

l PBX Events

Ø Ring Events

Once an inbound call is detected, the PBX will send instructions to the phone as a command to ring. To be exact, the PBX will send a DE_RING_ON (DST_RING_ON) event when it orders the phone to start ringing, and a DE_RING_OFF (DST_RING_OFF) event when it commands the phone to end ringing. The application can rely on the interval between these two events to determine how long the phone has been ringing.

Ø Audio Events

The PBX commands the phone to change the audio state, such as the state of the speaker or the state of the handset receiver/transmitter. These commands are decoded as the DE_AUDIO_CHG (DST_AUDIO_CHG) event. The PBX sends instructions to the phone as a command to change the state of such devices as speaker and handset (receiver/transmitter). Then the driver will decode these instructions to be the DE_AUDIO_CHG (DST_AUDIO_CHG) event.

Ø LED Events

The lights on the Siemens Hicom/Hipath PBX work as shown below.

² DE_FUNC_LT_OFF (DST_FUNC_LT_OFF): Line is idle;

² DE_FUNC_LT_ON (DST_FUNC_LT_ON): Line is active;

² DE_FUNC_LT_VERY_FASTFLASHING (DST_FUNC_LT_VERY_FASTFLASHING): Line is silent (microphone mute);

² DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING): Line is ringing;

² DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING): Call hold.

The dwSubReason field of each light event tells the color and the number. It includes 4 bytes that can be represented by 0xABCD, among which AB are reserved, C is the light color and D is the Light Number. In this system, however, dwSubReason doesn’t give the color information. See below for details.

AB | C | D
byte2-3 | byte1 | byte0
Reserved | Reserved | Light Number

Ø LCD Events

There are three LCD events reported to the application: DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR), DE_DISPLAY_CLOCK (DST_DISPLAY_CLOCK), DE_MSG_CHG (DST_MSG_CHG).


3.4 D-Channel Events per Phone Model

The following illustration is a list of all D-channel events generated by some types of the Siemens phones. The following section is for application developers to understand the variation noted between phone models.


3.4.1 Siemens Optiset


3.4.1.1 Phone Map & Event List

Device Number | Possible Events and Parameters
H1 | DE_OFFHOOK (DST_OFFHOOK) DE_ONHOOK (DST_ONHOOK)
C1 | DE_MSG_CHG (DST_MSG_CHG)
S1 | DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS) dwSubReason = 0
S2 | DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS) dwSubReason = 1
S3 | DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS) dwSubReason = 4
S4 | DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS) dwSubReason = 2
S5 | DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS) dwSubReason = 3
D1-D12 | DE_DGT_PRS (DST_DGT_PRS)
F0-F11 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS) dwSubReason = 0-11
L0-L11 | DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING) DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING) dwSubReason = 0-11


Chapter 4 Avaya Definity 2W


4.1 Configuration

l Run ShCtiConfig.exe to update board firmware

Write the updated PBX model - Avaya Definity 2W into the DST board firmware. This update once written will be long kept in the board, not to be lost even during power outage. Refer to ShCtiConfig.exe User Manual for details.

l Configure the driver’s runtime environment (through the file Shconfig.ini)

Ø PBXType – set to Avaya Definity 2W

Ø PhoneType – select the correct value from the ‘DST Series Supported PBX Models’ section in Chapter 1 of SynCTI Programmer's Manual.

Ø DefaultVoiceFormat – usually the AVAYA_2 PBX uses A-law codec and this configuration item should be set to 6.


4.2 D-channel Events

All D-channel events generated in this system are listed below, grouped by event type. These events vary depending on the particular configuration of the PBX as well as the phone model involved in the system. We do not guarantee that all the following events are reported in each system.

l PBX Events

Ø Call State Events

² DE_ABANDONED (DST_ABANDONED)

Ø LED Events

² DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING)

² DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING)

² DE_FUNC_LT_ON (DST_FUNC_LT_ON)

² DE_FUNC_LT_OFF (DST_FUNC_LT_OFF)

² DE_FUNC_LT_QUICKFLASH (DST_FUNC_LT_QUICKFLASH)

² DE_FUNC_LT_VERY_FASTFLASHING (DST_FUNC_LT_VERY_FASTFLASHING)

Ø LCD Events

² DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR)

² DE_MSG_CHG (DST_MSG_CHG)

l Phone Events

Ø HOOK Events

² DE_OFFHOOK (DST_OFFHOOK)

² DE_ONHOOK (DST_ONHOOK)

Ø Button Events

² DE_ANSWER_BTN_PRS (DST_ANSWER_BTN_PRS)

² DE_CONF_BTN_PRS (DST_CONF_BTN_PRS)

² DE_EXIT_BTN_PRS (DST_EXIT_BTN_PRS)

² DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)

² DE_HOLD_BTN_PRS (DST_HOLD_BTN_PRS)

² DE_MENU_BTN_PRS (DST_MENU_BTN_PRS)

² DE_NEXT_BTN_PRS (DST_NEXT_BTN_PRS)

² DE_REDIAL_BTN_PRS (DST_REDIAL_BTN_PRS)

² DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS)

² DE_SOFT_BTN_PRS (DST_SOFT_BTN_PRS)

² DE_TRANSFER_BTN_PRS (DST_TRANSFER_BTN_PRS)


4.3 Avaya Definity 2W Behavior

Each PBX has its own behaviors. This section demonstrates the common behaviors performed by the Avaya Definity 2W.

l Dialed Number (DTMF) Detection

When the digits on the phone are pressed, a corresponding message will be passed over the D-channel and the DE_DGT_PRS (DST_DGT_PRS) event will be reported to the application almost at the same time. When the B-channel obtains DTMF from either direction, the signals will be detected by the DTMF detector on the DST board and the E_CHG_RcvDTMF event will be reported.

l Calling & Called Party Numbers

Usually, both the calling and called party numbers are passed over the D-channel and can be gained by the application via the DE_MSG_CHG (DST_MSG_CHG) event, which contains the parameters representing the displayed information stings and the size. Note that these strings are stored in ASCII format so that the calling and called party numbers only can be separated by using some algorithms.

l PBX Events

Ø Ring Events

The Avaya Definity 2W PBX does not generate the Ring events DE_RING_ON (DST_RING_ON) and DE_RING_OFF (DST_RING_OFF). One of the lights on the phone flashes when an inbound call is detected. At this time, the developer can use the specific parameters of the reported event (DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING)) to find the light which flashes.

Ø LED Events

The lights on the Avaya Definity 2W PBX work as shown below.

² DE_FUNC_LT_OFF (DST_FUNC_LT_OFF): Line is idle;

² DE_FUNC_LT_ON (DST_FUNC_LT_ON): Line is active;

² DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING): Line is ringing;

² DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING): Call hold;

² DE_FUNC_LT_VERY_FASTFLASHING (DST_FUNC_LT_VERY_FASTFLASHING): Teleconferencing or call transfer;

² DE_FUNC_LT_QUICKFLASH (DST_FUNC_LT_QUICKFLASH): Non programmable button is pressed.

The dwSubReason field of each light event tells the color and the number. It includes 4 bytes that can be represented by 0xABCD, among which AB are reserved, C is the light color and D is the Light Number as shown in the following table.

A | B | C |  |  | D
byte31-24 | byte23-16 | byte15-10 | byte9 | byte8 | byte7-0
Reserved | Reserved | Reserved | Red Light | Green Light | Light Number

Ø LCD Events

There are two LCD events reported to the application: DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR) and DE_MSG_CHG (DST_MSG_CHG).


4.4            D-channel Events per Phone Model

Here provides the description on how each Avaya phone model generates the D-channel events for your reference.


4.4.1 Avaya 8410D


4.4.1.1 Phone Map & Event List

Device Number | Possible Events and Parameters
H1 | DE_OFFHOOK (DST_OFFHOOK)，DE_ONHOOK (DST_ONHOOK)
C1 | DE_MSG_CHG (DST_MSG_CHG)，DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR)
F1 | DE_MENU_BT_PRS (DST_MENU_BT_PRS)
F2 | DE_EXIT_BT_PRS (DST_EXIT_BT_PRS)
F3 | DE_PREVIOUS_BT_PRS (DST_PREVIOUS_BT_PRS)
F4 | DE_NEXT_BT_PRS (DST_NEXT_BT_PRS)
F5 | DE_TRANSFER_BT_PRS (DST_TRANSFER_BT_PRS)
F6 | DE_CONF_BT_PRS (DST_CONF _BT_PRS)
F7 | DE_RELEASE_BT_PRS (DST_RELEASE_BT_PRS)
F8 | DE_HOLD_BT_PRS (DST_HOLD_BT_PRS)
L0-L9 | DE_FUNC_BT_PRS (DST_FUNC_BT_PRS) DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING) DE_FUNC_LT_QUICKFLASHING (DST_FUNC_LT_QUICKFLASHING) DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING) DE_FUNC_LT_VERY_FAST_FLASHING (DST_FUNC_LT_VERY_FAST_FLASHING) dwSubReason（BIT0-7）= 0-9 dwSubReason（BIT8）=1 GREEN dwSubReason（BIT9）=1 RED
L255 | DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) dwSubReason = 0x2FF


4.4.2 Avaya 6408/6416/6424D


4.4.2.1 Phone Map & Event List

Device Number | Possible Events and Parameters
S1-S4 | DE_SOFT_BT_PRS (DST_SOFT_BT_PRS) 1 号菜单：dwSubReason = 1-4 2 号菜单：dwSubReason = 5-8 3 号菜单：dwSubReason = 9-12
F1 | DE_MENU_BT_PRS (DST_MENU_BT_PRS)
F2 | DE_EXIT_BT_PRS (DST_EXIT_BT_PRS)
F3 | DE_PREVIOUS_BT_PRS (DST_PREVIOUS_BT_PRS)
F4 | DE_NEXT_BT_PRS (DST_NEXT_BT_PRS)
F5 | DE_REDIAL_BT_PRS (DST_REDIAL_BT_PRS)
F6 | DE_TRANSFER_BT_PRS (DST_TRANSFER_BT_PRS)
F7 | DE_ CONF_BT_PRS (DST_ CONF_BT_PRS)
F9-F12 | DE_FUNC_BT_PR (DST_FUNC_BT_PR) F9： dwSubReason = 8 F10：dwSubReason = 0 F11：dwSubReason = 7 F12：dwSubReason = 0x17
L1-L8 | DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING) DE_FUNC_LT_QUICKFLASHING (DST_FUNC_LT_QUICKFLASHING) DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING) DE_FUNC_LT_VERY_FAST_FLASHING (DST_FUNC_LT_VERY_FAST_FLASHING) L1： dwSubReason = 0x100 L2： dwSubReason = 0x200 L3： dwSubReason = 0x107 L4： dwSubReason = 0x207 L5： dwSubReason = 0x108 L6： dwSubReason = 0x208 L7： dwSubReason = 0x117 L8： dwSubReason = 0x217
L9 | DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) dwSubReason = 0x2FF


4.4.2.2 Call Scenarios

Outbound Call - Handset

Inbound Call - Handset

Outbound Call - Speaker Phone

Inbound Call - Speaker Phone

Outbound Call - Handset


4.4.3 Avaya CALL MASTER IV/V


4.4.3.1 Phone Map & Event List

Device Number | Possible Events and Parameters
F1 | DE_MENU_BT_PRS (DST_MENU_BT_PRS)
F2 | DE_EXIT_BT_PRS (DST_EXIT_BT_PRS)
F3 | DE_PREVIOUS_BT_PRS (DST_PREVIOUS_BT_PRS)
F4 | DE_NEXT_BT_PRS (DST_NEXT_BT_PRS)
F5 | DE_OFFHOOK (DST_OFFHOOK)， DE_ONHOOK (DST_ONHOOK)
F6 | DE_HOLD_BT_PRS (DST_HOLD_BT_PRS)
F7 | DE_REDIAL_BT_PRS (DST_REDIAL_BT_PRS)
F8 | DE_TRANSFER_BT_PRS (DST_TRANSFER_BT_PRS)
F9 | DE_CONF_BT_PRS (DST_CONF_BT_PRS)
L0-L15 | DE_FUNC_BT_PRS (DST_FUNC_BT_PRS) DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING) DE_FUNC_LT_QUICKFLASHING (DST_FUNC_LT_QUICKFLASHING) DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING) DE_FUNC_LT_VERY_FAST_FLASHING (DST_FUNC_LT_VERY_FAST_FLASHING) dwSubReason（BIT0-7）= 0-15 dwSubReason（BIT8）=1 GREEN dwSubReason（BIT9）=1 RED
L255 | DE_FUNC_LT_ON (DST_FUNC_LT_ON) DE_FUNC_LT_OFF (DST_FUNC_LT_OFF) dwSubReason = 0x2FF


Chapter 5 Nortel Meridian 1


5.1 Configuration

l Run ShCtiConfig.exe to update board firmware

Write the updated PBX model - Meridian into the DST board firmware. This update once written will be long kept in the board, not to be lost even during power outage. Refer to ShCtiConfig.exe User Manual for details.

l Configure the driver’s runtime environment (through the file Shconfig.ini)

Ø PBXType – set to Nortel Meridian1

Ø PhoneType – select the correct value from the ‘DST Series Supported PBX Models’ section in Chapter 1 of SynCTI Programmer's Manual.

Ø DefaultVoiceFormat – usually the Meridian PBX uses μ-law codec and this configuration item should be set to 7.


5.2 D-Channel Events

All D-channel events generated in this system are listed below, grouped by event type. These events vary depending on the particular configuration of the PBX as well as the phone model involved in the system. We do not guarantee that all the following events are reported in each system.

l PBX Events

Ø Ring Events

² DE_RING_ON (DST_RING_ON)

² DE_RING_OFF (DST_RING_OFF)

Ø Audio Events

² DE_AUDIO_CHG (DST_AUDIO_CHG)

Ø Call State Events

² DE_CFWD (DST_CFWD)

² DE_CFWD_CANCELED (DST_CFWD_CANCELED)

² DE_AUTO_ANSWER (DST_AUTO_ANSWER)

² DE_AUTO_ANSWER_CANCELED (DST_AUTO_ANSWER_CANCELED)

² DE_SET_BUSY (DST_SET_BUSY)

² DE_SET_BUSY_CANCELED (DST_SET_BUSY_CANCELED)

Ø LED Events

² DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING)

² DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING)

² DE_FUNC_LT_ON (DST_FUNC_LT_ON)

² DE_FUNC_LT_OFF (DST_FUNC_LT_OFF)

Ø LCD Events

Ø DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR)

Ø DE_DISPLAY_CLOCK (DST_DISPLAY_CLOCK)

Ø DE_DISPLAY_MSG (DST_DISPLAY_MSG)

Ø DE_DISPLAY_TIMER (DST_DISPLAY_TIMER)

Ø DE_MSG_CHG (DST_MSG_CHG)

l Phone Events

Ø HOOK events

² DE_ONHOOK (DST_ONHOOK)

² DE_OFFHOOK (DST_OFFHOOK)

Ø Button Events

² DE_DGT_PRS (DST_DGT_PRS)

² DE_DGT_RLS (DST_DGT_RLS)

² DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)

² DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS)

² DE_HOLD_BTN_PRS (DST_HOLD_BTN_PRS)

² DE_HOLD_BTN_RLS (DST_HOLD_BTN_RLS)

² DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS)

² DE_SPEAKER_BTN_PRS (DST_SPEAKER_BTN_PRS)

² DE_SPEAKER_BTN_RLS (DST_SPEAKER_BTN_RLS)


5.3 Nortel Meridian 1 Behavior

Each PBX has its own behaviors. This section demonstrates the common behaviors performed by the Nortel Meridian 1.

l Dialed Number (DTMF) Detection

When the digits on the phone are pressed, a corresponding message will be passed over the D-channel and the DE_DGT_PRS (DST_DGT_PRS) event will be reported to the application almost at the same time. When the B-channel obtains DTMF from either direction, the signals will be detected by the DTMF detector on the DST board and the E_CHG_RcvDTMF event will be reported. Note that the Meridian phone does not generate DTMF signals on the B-Channel during the dial.

l Calling & Called Party Numbers

In most PBX systems, both the calling and called party numbers are passed over the D-channel and can be gained by the application via the DE_MSG_CHG (DST_MSG_CHG) event, which contains the parameters representing the displayed information stings and the size. Note that these strings are stored in ASCII format so that the calling and called party numbers only can be separated by using some algorithms.

l PBX Events

Ø Ring Events

Usually, the PBX will send one DE_RING_ON (DST_RING_ON) event and one DE_RING_OFF (DST_RING_OFF) event to the phone in each complete ring cycle, so the application must record the number of received ring events to calculate the length of time the phone was ringing. However, the 2216 and 3905 phones do not generate ring events.

Ø HOOK Events

Since the 2216 and 3905 phones do not have handsets, no DE_ONHOOK (DST_ONHOOK) and DE_OFFHOOK (DST_OFFHOOK) events will be reported.

Ø Audio Events

Generally, the PBX will send instructions to the phone as a command to change the audio state. However, as to the 2216 and 3905 phones, the PBX only sends the DE_AUDIO_CHG (DST_AUDIO_CHG) event to turn on the audio devices during the phone initialization and never turns them off. Such case is called as ‘hot mic’. As a result, this event can not be used to control the recording operation.

Ø LCD Events

The dwSubReason field of the reported DE_DISPLAY_MSG (DST_DISPLAY_MSG) event indicates the message ID. Below are some messages and their corresponding IDs observed at the Nortel Meridian 1 PBX site. However, it is not an exhaustive list for all messages, and not all phone models will generate these messages in the list.

dwSubReason | Message
0x0002 | Release and Try Again
0x0003 | Press CFWD or Enter New #
0x0004 | CFWD Enter Digits, Press CFWD
0x0005 | CALL TRANSFER ENTER DIGITS
0x0006 | TRANSFER WHEN REDAY
0x0007 | CONFERENCE PARTY ENTER DIGITS
0x0008 | CONFERENCE WHEN REDAY
0x0009 | PROGRAMMING AUTODIAL ENTER MUMBER
0x000A | PRESS AUTODIAL TO SAVE
0x0010 | DESTINATION BUSY ACTIVE RING AGAIN?
0x0071 | PROGRAMMING STORED # ENTER NUMBER
0x0072 | PRESS STORED# TO SAVE
0x008F | Charge is not Allowed
0x0092 | Press OK to park call on

Ø LED Light Events

The lights on the Nortel Meridian1 PBX work as shown below.

DE_FUNC_LT_FASTFLASHING (DST_FUNC_LT_FASTFLASHING): Call hold, 2 flashes per second;

DE_FUNC_LT_FLASHING (DST_FUNC_LT_FLASHING): Line is ringing, 1 flash per second;

DE_FUNC_LT_ON (DST_FUNC_LT_ON): Line is active or certain feature is activated.

DE_FUNC_LT_OFF (DST_FUNC_LT_OFF): Line is idle.

The dwSubReason field of each light event tells the color and the number. It includes 4 bytes that can be represented by 0xABCD, among which AB are reserved, C is the light color and D is the Light Number. In this system, however, dwSubReason doesn’t give the color information. See below for details.

AB | C | D
byte2-3 | byte1 | byte0
Reserved | Reserved | Light Number


5.4 D-Channel Events per Phone Model


5.4.1 M2216

The M2216 phone has no handset, so it won’t generate the DE_ONHOOK (DST_ONHOOK) and DE_OFFHOOK (DST_OFFHOOK) events. Moreover, the PBX only sends the DE_AUDIO_CHG (DST_AUDIO_CHG) event to turn on the audio devices during the phone initialization and never turns them off. Such case is called as ‘hot mic’. As a result, the DE_AUDIO_CHG (DST_AUDIO_CHG) event can not be used to control the recording operation. This behavior is quite similar to that of the M3905 phone. You may refer to the description on the M3905 if necessary.


5.4.2 M2616


5.4.2.1 Phone Map & Event List

Device Number | Possible Events and Parameters
H1 | DE_OFFHOOK (DST_OFFHOOK)，DE_ONHOOK (DST_ONHOOK)
C1 | DE_MSG_CHG (DST_MSG_CHG) DE_DISPLAY_TIMER (DST_DISPLAY_TIMER) DE_DISPLAY_CLOCK (DST_DISPLAY_CLOCK) DE_DISPLAY_CLEAR (DST_DISPLAY_CLEAR) DE_DISPLAY_MSG (DST_DISPLAY_MSG)
D1-D12 | DE_DGT_PRS (DST_DGT_PRS)，DE_DGT_RLS (DST_DGT_RLS)
F0-F15 | DE_FUNC_BT_PRS (DST_FUNC_BT_PRS)，DE_FUNC_BT_RLS (DST_FUNC_BT_RLS)
F16 | DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS)，DE_RELEASE_BTN_RLS (DST_RELEASE_BTN_RLS)
F17 | DE_HOLD_BTN_PRS (DST_HOLD_BTN_PRS)，DE_HOLD_BTN_RLS (DST_HOLD_BTN_RLS)


5.4.3 M3901


5.4.3.1 Phone Map & Event List

Device Number | Possible Events and Parameters
D1-D12 | DE_DGT_PRS (DST_DGT_PRS)，DE_DGT_RLS (DST_DGT_RLS)
F1 | DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS)，DE_RELEASE_BTN_RLS (DST_RELEASE_BTN_RLS)
F2 | DE_FEATURE_BTN_PRS (DST_FEATURE_BTN_PRS)，DE_FEATURE_BTN_RLS (DST_FEATURE_BTN_RLS)
F3 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)，DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS)
F4 | DE_HOLD_BTN_PRS (DST_HOLD_BTN_PRS)，DE_HOLD_BTN_RLS (DST_HOLD_BTN_RLS)


5.4.3.2 Call Scenarios

Outbound Call - Handset

Inbound Call - Handset

Outbound Call - Speaker Phone

Inbound Call - Speaker Phone


5.4.4 M3903


5.4.4.1 Call Scenarios

Outbound Call - Handset

Inbound Call - Handset

Outbound Call - Speaker Phone

Inbound Call - Speaker Phone


5.4.5 M3905

The M3905 phone has no handset, so it won’t generate the DE_ONHOOK (DST_ONHOOK) and DE_OFFHOOK (DST_OFFHOOK) events. Moreover, the PBX only sends the DE_AUDIO_CHG (DST_AUDIO_CHG) event to turn on the audio devices during the phone initialization and never turns them off. Such case is called as ‘hot mic’. As a result, the DE_AUDIO_CHG (DST_AUDIO_CHG) event can not be used to control the recording operation.


5.4.5.1 Phone Map & Event List

Device Number | Possible Events and Parameters
H1 | DE_HOLD_BTN_PRS (DST_HOLD_BTN_PRS)， DE_HOLD_BTN_RLS (DST_HOLD_BTN_RLS)
H2 | DE_RELEASE_BTN_PRS (DST_RELEASE_BTN_PRS)， DE_RELEASE_BTN_RLS (DST_RELEASE_BTN_RLS)
D1-D12 | DE_DGT_PRS (DST_DGT_PRS)，DE_DGT_RLS (DST_DGT_RLS)
F1-F11 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)， DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS) F1： dwSubReason = 0x6 F2： dwSubReason = 0x5 F3： dwSubReason = 0x4 F4： dwSubReason = 0x3 F5： dwSubReason = 0x2 F6： dwSubReason = 0x1 F7： dwSubReason = 0x0B F8： dwSubReason = 0x0A F9： dwSubReason = 0x9 F10：dwSubReason = 0x8 F11：dwSubReason = 0
S1 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)， DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS) Transfer：dwSubReason = 0x11 RingAGN：dwSubReason = 0x14 PrivRLS：dwSubReason = 0x17
S2 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)， DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS) Conf：dwSubReason = 0x11 Park：dwSubReason = 0x15 Charge：dwSubReason = 0x19
S3 | DE_FUNC_BTN_PRS (DST_FUNC_BTN_PRS)， DE_FUNC_BTN_RLS (DST_FUNC_BTN_RLS) Forward：dwSubReason = 0x13 Pickup：dwSubReason = 0x16 Cparty：dwSubReason = 0x1A


5.4.5.2 Call Scenarios

Outbound Call - Handset

Inbound Call – Handset


Appendix A Technical/sales Support

Thank you for choosing Synway. Please contact us should you have any inquiry regarding our products. We shall do our best to help you.

Headquarters

Synway Information Engineering Co., Ltd

http://www.synway.net/

9F, Synway D&R Center, No.3756, Nanhuan Road, Binjiang District, Hangzhou, P.R.China, 310053

Tel: +86-571-88860561

Fax: +86-571-88850923

Technical Support

Tel: +86-571-88864579

Mobile: +86-13735549651

Email: techsupport@sanhuid.com

Email: techsupport@synway.net

MSN: scycindy_sh@hotmail.com

Sales Department

Tel: +86-571-88860561

Tel: +86-571-88864579

Fax: +86-571-88850923

Email: sales@synway.net